Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
Hi,
This is a new LV2 plugin. It uses Ztoolkit for its UI so I packaged
that separately.
I made a separate package for ztoolkit-rsvg because adding librsvg
brings in the whole glib stack, while ztoolkit by itself is very
minimal. Feel free to let me know if you have any other suggestions.
Thanks,
Alex
From 0ba05eed84867e0e7bd17fbbf8916c53f6cf7abd Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 15:03:08 +0000
Subject: [PATCH 2/2] gnu: Add zlfo.
* gnu/packages/music.scm (zlfo): New variable.
---
gnu/packages/music.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 16e69840df..8d07a23127 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5189,3 +5189,30 @@ featureful and easy to use. It offers unlimited automation options, LV2
plugin support, JACK support and chord assistance.")
(home-page "https://www.zrythm.org")
(license license:agpl3+)))
+
+(define-public zlfo
+ (package
+ (name "zlfo")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/ZLFO")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bm466ci5xyvxvq7l9p6xyh789lvk6i31b4zja1igqh13akbjnjz"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("ztoolkit-rsvg" ,ztoolkit-rsvg)))
+ (native-inputs
+ `(("git" ,git)
+ ("lv2" ,lv2)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "LFO plugin")
+ (description "ZLFO is a fully featured LFO for CV-based automation
+that comes as a cross-platform LV2 plugin bundle with a custom UI.")
+ (home-page "https://git.zrythm.org/cgit/ZLFO/")
+ (license license:agpl3+)))
--
2.25.1
From c8b1c930846eb6cc0f8b2aed47e430e62466577a Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 15:00:50 +0000
Subject: [PATCH 1/2] gnu: Add ztoolkit.
* gnu/packages/audio.scm (ztoolkit): New variable.
---
gnu/packages/audio.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)
Toggle diff (53 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 5b8c610882..dece9c03fe 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4036,3 +4036,46 @@ libsamplerate for reading and resampling audio files, based on Robin Gareus'
@code{audio_decoder} code.")
(home-page "https://git.zrythm.org/cgit/libaudec")
(license license:agpl3+)))
+
+(define-public ztoolkit
+ (package
+ (name "ztoolkit")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/ztoolkit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
+ (build-system meson-build-system)
+ (propagated-inputs
+ `(("cairo" ,cairo)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("git" ,git)))
+ (synopsis "GUI toolkit for LV2 plugins")
+ (description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
+inspired by GTK. It handles events and low level drawing on behalf of
+the user and provides a high-level API for managing the UI and custom
+widgets. ZToolkit is written in C and was created to be used for building
+audio plugin UIs, where the dependencies often need to be kept to a
+minimum.")
+ (home-page "https://git.zrythm.org/cgit/ztoolkit/")
+ (license license:agpl3+)))
+
+(define-public ztoolkit-rsvg
+ (package
+ (inherit ztoolkit)
+ (name "ztoolkit-rsvg")
+ (arguments
+ `(#:configure-flags `("-Denable_rsvg=true")))
+ (propagated-inputs
+ `(("cairo" ,cairo)
+ ("librsvg" ,librsvg)
+ ("libx11" ,libx11)))
+ (synopsis "ZToolkit with SVG support")))
--
2.25.1
-----BEGIN PGP SIGNATURE-----
iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl5VN/4ACgkQAi6uQjE9
cPPdjQgAmyetoChwWP464Zeh2BMdvdAWb7Ofsf1UBhU0D4HA8phFPCBgqP9T6K1l
mGdOx9gz5J9SKt3YbhQhgds/WP8WImxN8x4cKar6adg5obfhfznXHwggLwtREwjd
2EM9UTKEz0pojHHlfjJL80qKvtDWLPr1xB1XoD0rF8RPR6htHHz+kOunQBfiy53P
rVdRh9S5aoeg656vFo7hHxMFSH7Qfp7HW2hwzaZqvCoG/bFSztRiHNgohl4JG0FW
EuhY22ZdS5vS6CY1H21Fe7jexVxmOqCLw3xwIjk1IZaIdryMkpkmg7h7ck1YoUej
JdwaeKoyEGZPmdJWce5lV0VOzRo/wA==
=56RQ
-----END PGP SIGNATURE-----