[PATCH] Add zlfo.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alexandros Theodotou
  • Jakub K?dzio?ka
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 25 Feb 2020 16:06
(name . Guix patches)(address . guix-patches@gnu.org)
0f84534047c834937c210429116d686bc159e8a3.camel@zrythm.org
Hi,

This is a new LV2 plugin. It uses Ztoolkit for its UI so I packaged
that separately.

I made a separate package for ztoolkit-rsvg because adding librsvg
brings in the whole glib stack, while ztoolkit by itself is very
minimal. Feel free to let me know if you have any other suggestions.

Thanks,
Alex
From 0ba05eed84867e0e7bd17fbbf8916c53f6cf7abd Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 15:03:08 +0000
Subject: [PATCH 2/2] gnu: Add zlfo.

* gnu/packages/music.scm (zlfo): New variable.
---
gnu/packages/music.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 16e69840df..8d07a23127 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5189,3 +5189,30 @@ featureful and easy to use. It offers unlimited automation options, LV2
plugin support, JACK support and chord assistance.")
(home-page "https://www.zrythm.org")
(license license:agpl3+)))
+
+(define-public zlfo
+ (package
+ (name "zlfo")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/ZLFO")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bm466ci5xyvxvq7l9p6xyh789lvk6i31b4zja1igqh13akbjnjz"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("ztoolkit-rsvg" ,ztoolkit-rsvg)))
+ (native-inputs
+ `(("git" ,git)
+ ("lv2" ,lv2)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "LFO plugin")
+ (description "ZLFO is a fully featured LFO for CV-based automation
+that comes as a cross-platform LV2 plugin bundle with a custom UI.")
+ (home-page "https://git.zrythm.org/cgit/ZLFO/")
+ (license license:agpl3+)))
--
2.25.1
From c8b1c930846eb6cc0f8b2aed47e430e62466577a Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 15:00:50 +0000
Subject: [PATCH 1/2] gnu: Add ztoolkit.

* gnu/packages/audio.scm (ztoolkit): New variable.
---
gnu/packages/audio.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 5b8c610882..dece9c03fe 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4036,3 +4036,46 @@ libsamplerate for reading and resampling audio files, based on Robin Gareus'
@code{audio_decoder} code.")
(home-page "https://git.zrythm.org/cgit/libaudec")
(license license:agpl3+)))
+
+(define-public ztoolkit
+ (package
+ (name "ztoolkit")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/ztoolkit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
+ (build-system meson-build-system)
+ (propagated-inputs
+ `(("cairo" ,cairo)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("git" ,git)))
+ (synopsis "GUI toolkit for LV2 plugins")
+ (description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
+inspired by GTK. It handles events and low level drawing on behalf of
+the user and provides a high-level API for managing the UI and custom
+widgets. ZToolkit is written in C and was created to be used for building
+audio plugin UIs, where the dependencies often need to be kept to a
+minimum.")
+ (home-page "https://git.zrythm.org/cgit/ztoolkit/")
+ (license license:agpl3+)))
+
+(define-public ztoolkit-rsvg
+ (package
+ (inherit ztoolkit)
+ (name "ztoolkit-rsvg")
+ (arguments
+ `(#:configure-flags `("-Denable_rsvg=true")))
+ (propagated-inputs
+ `(("cairo" ,cairo)
+ ("librsvg" ,librsvg)
+ ("libx11" ,libx11)))
+ (synopsis "ZToolkit with SVG support")))
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl5VN/4ACgkQAi6uQjE9
cPPdjQgAmyetoChwWP464Zeh2BMdvdAWb7Ofsf1UBhU0D4HA8phFPCBgqP9T6K1l
mGdOx9gz5J9SKt3YbhQhgds/WP8WImxN8x4cKar6adg5obfhfznXHwggLwtREwjd
2EM9UTKEz0pojHHlfjJL80qKvtDWLPr1xB1XoD0rF8RPR6htHHz+kOunQBfiy53P
rVdRh9S5aoeg656vFo7hHxMFSH7Qfp7HW2hwzaZqvCoG/bFSztRiHNgohl4JG0FW
EuhY22ZdS5vS6CY1H21Fe7jexVxmOqCLw3xwIjk1IZaIdryMkpkmg7h7ck1YoUej
JdwaeKoyEGZPmdJWce5lV0VOzRo/wA==
=56RQ
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 26 Feb 2020 23:03
(name . Alexandros Theodotou)(address . alex@zrythm.org)(name . Guix patches)(address . guix-patches@gnu.org)
20200226220320.qfog7rmaqsglx2dg@gravity
On Tue, Feb 25, 2020 at 03:06:38PM +0000, Alexandros Theodotou wrote:
Toggle quote (5 lines)
> Hi,
>
> This is a new LV2 plugin. It uses Ztoolkit for its UI so I packaged
> that separately.

Hi,

could you send your patches inline, instead of as an attachment? It
makes reviews easier. The workflow on your side is easier too, since you
only need to `git send-email` (available as git:send-email in guix).
It's fine if you prefer not to do this, though.

Toggle quote (4 lines)
> * gnu/packages/audio.scm (ztoolkit): New variable.
> ---
> gnu/packages/audio.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 43 insertions(+)
I'm not sure if audio.scm is the best place for a GUI toolkit. It might
be fine since audio plugins are the primary usecase, but I'm not sure.

Toggle quote (14 lines)
> +(define-public ztoolkit
> + (package
> + (name "ztoolkit")
> + (version "0.1.1")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.zrythm.org/git/ztoolkit")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
Please run etc/indent-code.el on your packages.

Toggle quote (4 lines)
> + (build-system meson-build-system)
> + (propagated-inputs
> + `(("cairo" ,cairo)
> + ("libx11" ,libx11)))
Why are these propagated-inputs? I would've thought that these
dependencies get linked into the binary, so they don't need to propagate
to the user's profile.

Toggle quote (3 lines)
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("git" ,git)))
Why the dependency on git? The package seems to build fine without it.

Toggle quote (29 lines)
> + (synopsis "GUI toolkit for LV2 plugins")
> + (description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
> +inspired by GTK. It handles events and low level drawing on behalf of
> +the user and provides a high-level API for managing the UI and custom
> +widgets. ZToolkit is written in C and was created to be used for building
> +audio plugin UIs, where the dependencies often need to be kept to a
> +minimum.")
> + (home-page "https://git.zrythm.org/cgit/ztoolkit/")
> + (license license:agpl3+)))

> +(define-public zlfo
> + (package
> + (name "zlfo")
> + (version "0.1.3")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.zrythm.org/git/ZLFO")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0bm466ci5xyvxvq7l9p6xyh789lvk6i31b4zja1igqh13akbjnjz"))))
> + (build-system meson-build-system)
> + (inputs
> + `(("ztoolkit-rsvg" ,ztoolkit-rsvg)))
> + (native-inputs
> + `(("git" ,git)
Same question as above.

Toggle quote (3 lines)
> + ("lv2" ,lv2)
> + ("pkg-config" ,pkg-config)))
> + (synopsis "LFO plugin")
That's quite blunt, and impenetrable for non-domain-experts. Is there
really nothing more you could say about the package? Perhaps expand the
acronym?

Toggle quote (2 lines)
> + (description "ZLFO is a fully featured LFO for CV-based automation
> +that comes as a cross-platform LV2 plugin bundle with a custom UI.")
Consider using Texinfo's @acronym.

Toggle quote (2 lines)
> + (license license:agpl3+)))
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl5W6ycACgkQ4xWnWEYT
FWRFFw//TgpQQAiCWjQlMbX2KAkIA6+f3kqETCJQfokHKV/D7N/4N/3ybEUgIoU3
Hrswg3zcnY7wMTwT3NuegBD2YiczbIa+Vz6OcZ6ilW/rAVp5cDEfzkX5+otoU6FC
+4ndF5ZCiDn62ebg1iK9lLzNNP4H60CUTLRK0WfQ4cVQzC+yDY+J6z+FD0CeYhBr
6l5knop2hX44MWyKKZN/+jOuSXR12QWEPVutsorrpeIjSv6CF6ZSxiv5qCRXfRh2
pepmr/5LdcWeHbRr5fZXwYyNmwJF0kJA+MPTWhRmcZGsc6jd5JHu+ws/OkW5kjEA
rwC6JflU0D9ScW0rfJ3crScg+9bBnRzHkrWd9fxbfsQnXligQhA2NQu03MiV2w5e
eHjoy82QCAx5elmg63ORHzbhAcAKbCbkCDolZ2hCEjpLg5EU6+3UsmsoOQbmEzgG
CZxNtuelf95uNnnHsnuFP40RKPZ0tUxMTCyJL11OSL0HkiesqNJHU/DBkibdW/qt
Pt0A4EJEkr8ZiIxV9e7e0f51WcIJXYEXT3Pwof6Sl4qEH+Xri25tEbnVz4Km86cO
1izR/phXo86LFH6r6C5sSeieiXqdCc13kgDijrtF5gAQRXSL/xWm3FecMgYmdxb2
pmDJVzyuzekBnDHfF14INDTsJESLF6feDAnGkzmBLFE9Z6w8QjU=
=62ba
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 26 Feb 2020 23:08
(name . Alexandros Theodotou)(address . alex@zrythm.org)(name . Guix patches)(address . guix-patches@gnu.org)
20200226220822.huzkjdkskfzan2ay@gravity
One more thing: zlfo has a reference to lv2 (see guix size). This
usually means that either it shouldn't be a native input, or the build
process stores the path in the output unnecessarily, increasing the
package closure size.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl5W7FYACgkQ4xWnWEYT
FWTumA//cGIrWv2x/unJVRsFgmAJmADn5Jk9Y1RjoIbBZv3PjRMSLRfOrh5Mrh5L
YThwn49NatX/nt1lFE8EEeaWlEgcOM1o5UbCFOLwk6WoHGauY4CTL6DIuX/i+hyl
vbCaUJeh5GxVhHctI9fEA4jghpY+2b7LHIh5V7GMfda2CYRHii+ChlwtQ98/q0qn
IdYDrLf+xqRvOOrc5ahucmABDOfbEczwQOk6EZKfMMWV1qKFxZ45kWngZ8im6QP/
0yQky1viHl/+c7TZdfpkT1OuAEX8t+UH6LxjEwUhx+ZTfoCTBGTMxj4fIzxuocp5
6T8UOcx+lCaruZRJ0NeegwmheKkkkKhSzOdzrYtZve+1xSmelrCN48Y7EBaB/tdC
OmgFvBuJdOpuhcAd8pMi73W0HY+H876brNtZtKQPA8AL29glu210qVk0ZzLn4rOI
3fLuRLo8AySu6RXGmDg1wFkf6Ub1jWJ5NkKDaY+K8inMPFVF4kWXIv2Yzsshb6ac
8dP0dLml0SYUnvf6Ju7CcUeTKmEoT8efCYNQeMkBOhTSu6Px5qDyBzXIoOLJlP1Y
icRhfsCYIvr9gVKpgR696ySIIGBRcLjSee5ZqJ7QzSVqgnJ1Rb2kGD8CSdynwV8+
oJ3jIAnF3UZnIg3ZKCy1AnhuAmF8jDhluCOtVDK0eknBj/rH+eg=
=7xTd
-----END PGP SIGNATURE-----


R
R
Ricardo Wurmus wrote on 27 Feb 2020 09:11
Re: [bug#39784] [PATCH] Add zlfo.
(name . Jakub K?dzio?ka)(address . kuba@kadziolka.net)
87pne0ih5z.fsf@elephly.net
Jakub K?dzio?ka <kuba@kadziolka.net> writes:

Toggle quote (90 lines)
> On Tue, Feb 25, 2020 at 03:06:38PM +0000, Alexandros Theodotou wrote:
>> Hi,
>>
>> This is a new LV2 plugin. It uses Ztoolkit for its UI so I packaged
>> that separately.
>
> Hi,
>
> could you send your patches inline, instead of as an attachment? It
> makes reviews easier. The workflow on your side is easier too, since you
> only need to `git send-email` (available as git:send-email in guix).
> It's fine if you prefer not to do this, though.
>
>> * gnu/packages/audio.scm (ztoolkit): New variable.
>> ---
>> gnu/packages/audio.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
>> 1 file changed, 43 insertions(+)
> I'm not sure if audio.scm is the best place for a GUI toolkit. It might
> be fine since audio plugins are the primary usecase, but I'm not sure.
>
>> +(define-public ztoolkit
>> + (package
>> + (name "ztoolkit")
>> + (version "0.1.1")
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://git.zrythm.org/git/ztoolkit")
>> + (commit (string-append "v" version))))
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32
>> + "07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
> Please run etc/indent-code.el on your packages.
>
>> + (build-system meson-build-system)
>> + (propagated-inputs
>> + `(("cairo" ,cairo)
>> + ("libx11" ,libx11)))
> Why are these propagated-inputs? I would've thought that these
> dependencies get linked into the binary, so they don't need to propagate
> to the user's profile.
>
>> + (native-inputs
>> + `(("pkg-config" ,pkg-config)
>> + ("git" ,git)))
> Why the dependency on git? The package seems to build fine without it.
>
>> + (synopsis "GUI toolkit for LV2 plugins")
>> + (description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
>> +inspired by GTK. It handles events and low level drawing on behalf of
>> +the user and provides a high-level API for managing the UI and custom
>> +widgets. ZToolkit is written in C and was created to be used for building
>> +audio plugin UIs, where the dependencies often need to be kept to a
>> +minimum.")
>> + (home-page "https://git.zrythm.org/cgit/ztoolkit/")
>> + (license license:agpl3+)))
>
>> +(define-public zlfo
>> + (package
>> + (name "zlfo")
>> + (version "0.1.3")
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://git.zrythm.org/git/ZLFO")
>> + (commit (string-append "v" version))))
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32
>> + "0bm466ci5xyvxvq7l9p6xyh789lvk6i31b4zja1igqh13akbjnjz"))))
>> + (build-system meson-build-system)
>> + (inputs
>> + `(("ztoolkit-rsvg" ,ztoolkit-rsvg)))
>> + (native-inputs
>> + `(("git" ,git)
> Same question as above.
>
>> + ("lv2" ,lv2)
>> + ("pkg-config" ,pkg-config)))
>> + (synopsis "LFO plugin")
> That's quite blunt, and impenetrable for non-domain-experts. Is there
> really nothing more you could say about the package? Perhaps expand the
> acronym?
>
>> + (description "ZLFO is a fully featured LFO for CV-based automation
>> +that comes as a cross-platform LV2 plugin bundle with a custom UI.")

CV is “control voltage” and LFO is “low frequency oscillator”. While CV
is sometimes expanded, LFO rarely is, but it wouldn’t hurt to use
“@dfn{low frequency oscillator} (LFO)” here.

What it means is that the plugin outputs a slow waveform (much slower
than audio waveform signals) that can be used to modulate other
parameters in a synthesizer / LV2 plugin network automatically, much
like control voltages are used in (hardware) modular synthesizers to
control parameters of other modules. A common use case is to modulate
the pitch of an audio oscillator with an LFO so as to produce vibrato
(i.e. the pitch rises and falls periodically, a couple of times per
second, centered around a certain pitch).

I would remove the “cross-platform” because as far as Guix is concerned
packages are available for all platforms that Guix supports.

--
Ricardo
A
A
Alexandros Theodotou wrote on 21 Mar 2020 19:50
(address . 39784@debbugs.gnu.org)
7c9f720c38ca4b0286c3c543341936d546dd2820.camel@zrythm.org
Hi,

Thanks for the feedback.

Just updated the patches (see attachment).

Thanks,
Alex
From fc6c3eccadb6cccab9a8e2f0e3f6a74f02f56e6f Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 18:49:06 +0000
Subject: [PATCH 3/3] gnu: Add zlfo.

* gnu/packages/music.scm (zlfo): New variable.
---
gnu/packages/music.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 468be9937f..aba6dda87e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5213,3 +5213,31 @@ featureful and easy to use. It offers unlimited automation options, LV2
plugin support, JACK support and chord assistance.")
(home-page "https://www.zrythm.org")
(license license:agpl3+)))
+
+(define-public zlfo
+ (package
+ (name "zlfo")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/ZLFO")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bm466ci5xyvxvq7l9p6xyh789lvk6i31b4zja1igqh13akbjnjz"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("librsvg" ,librsvg)
+ ("lv2" ,lv2)
+ ("ztoolkit-rsvg" ,ztoolkit-rsvg)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Low frequency oscillator plugin")
+ (description "ZLFO is a fully featured
+@dfn{low frequency oscillator} (LFO) for @dfn{control voltage} (CV)-based
+automation that comes as an LV2 plugin bundle with a custom UI.")
+ (home-page "https://git.zrythm.org/cgit/ZLFO/")
+ (license license:agpl3+)))
--
2.25.1
From fbaa53144f4ec96bb725d03aa305e039116e8ca1 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 18:45:51 +0000
Subject: [PATCH 2/3] gnu: Add ztoolkit-rsvg.

* gnu/packages/audio.scm (ztoolkit-rsvg): New variable.
---
gnu/packages/audio.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index fe951b5153..cb9d830a41 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4111,3 +4111,15 @@ audio plugin UIs, where the dependencies often need to be kept to a
minimum.")
(home-page "https://git.zrythm.org/cgit/ztoolkit/")
(license license:agpl3+)))
+
+(define-public ztoolkit-rsvg
+ (package
+ (inherit ztoolkit)
+ (name "ztoolkit-rsvg")
+ (arguments
+ `(#:configure-flags `("-Denable_rsvg=true")))
+ (inputs
+ `(("cairo" ,cairo)
+ ("librsvg" ,librsvg)
+ ("libx11" ,libx11)))
+ (synopsis "ZToolkit with SVG support")))
--
2.25.1
From f9398e031b8f88fb0cd7be7f9aa63cfd3bc1e825 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 18:44:13 +0000
Subject: [PATCH 1/3] gnu: Add ztoolkit.

* gnu/packages/audio.scm (ztoolkit): New variable.
---
gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f3edd21c69..fe951b5153 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4081,3 +4081,33 @@ given plugin and its UI(s) match up with the provided metadata and adhere
to well-known best practices.")
(home-page "https://open-music-kontrollers.ch/lv2/lv2lint/")
(license license:artistic2.0)))
+
+(define-public ztoolkit
+ (package
+ (name "ztoolkit")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/ztoolkit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("cairo" ,cairo)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "GUI toolkit for LV2 plugins")
+ (description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
+inspired by GTK. It handles events and low level drawing on behalf of
+the user and provides a high-level API for managing the UI and custom
+widgets. ZToolkit is written in C and was created to be used for building
+audio plugin UIs, where the dependencies often need to be kept to a
+minimum.")
+ (home-page "https://git.zrythm.org/cgit/ztoolkit/")
+ (license license:agpl3+)))
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl52Ye4ACgkQAi6uQjE9
cPOnWggAl1k5Y2l8hUw4is38FwnhCx9Hg2dzRvxbTgPD5lvylTriZ+oXQgz64fOf
D6JMf0qDAEjleHOfqiXF2rAjXYiBmBt3ZSMkGwwc9G3ZSx+nGKCBvESPS/LsLlrD
PhuUR1Ucv6MgYgG6tjRifufH1czH3k7R+2QQdxO2oLiFL+Fi4DRGIftzCG8t8mjM
v/0MBLg44YTTuxWYbi6gsAVxjgG789VfeWICpTKtT5SI5MZWQ8ue3OJAcyebxdoa
vLDiSn/D5GkRTRwK6Wat3PO6ykOF1QRfrMthvNoFvlXM9DwGboJvBUGF1YKF9vYj
dSGo8USbYS2Kfuo+MYp0oL8unyWX+w==
=Coo1
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 23 Mar 2020 15:45
(name . Alexandros Theodotou)(address . alex@zrythm.org)
20200323144503.nosivm2euxfjhcpi@gravity
Thanks for your updated patches! You still haven't ran indent-code.el on
them, but I fixed that on my side. I also took the liberty to define the
inputs of ztoolkit-rsvg in terms of the ztoolkit package, like this:

@@ -4119,7 +4119,6 @@ minimum.")
(arguments
`(#:configure-flags `("-Denable_rsvg=true")))
(inputs
- `(("cairo" ,cairo)
- ("librsvg" ,librsvg)
- ("libx11" ,libx11)))
+ `(("librsvg" ,librsvg)
+ ,@(package-inputs ztoolkit)))
(synopsis "ZToolkit with SVG support")))

Your patches have been applied on master, with the last commit being
d3e7282ec35d87842e8143f0230e27fd5ec5e74d

Cheers!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl54y24ACgkQ4xWnWEYT
FWTc9g//a4SN7vjhilt51QaTHZHcD9g6fMyplcJL4wyV0BhvRgzJ4IuTCPvW38a+
N/Gp5Rpt0puDtRefHvb8O03kmeV01E4+8lcSj5wwdsmyGrTaECzyQvkYU1oi+ooe
NAYniagocO7tu+uzWEc7nv0peuNc0mP3F511LuGtd4ra0uVqxvmbyuu0ZJ+DTGzb
vcDbTO1OSPeAE88+Kc+ZEQNXWoXO2GzRSVKnaWJGNHI8o5PlEExcf5mzEA91XwqX
eT+9TqyvmIrw1w4dqwoQKXWIvkF60xwcMKMc6TTzPxtc1i9uO6iYK5V0jXzuFh5M
JFocFRMMBfULopulZ7+5skyPpEYrWxCxeHaqMAp6z1XL52J1qDApdKoiJzIOriAo
Z5WS/JAPrRNcRsKBtEG4G3JfWHpapmqRkDU5mDAqohbP1ZOvZOEjsAE07q5CO2VW
xiWp0N9GtsUB/uvcltd3vQd4XuRDydHsvRGwJi9BTZ6yAyI8kEyLTZYBrz123b36
YJjdbZFoklAcWcFYxDg6BTL80eUOzSkhUx3LcD0Tyq88Xf6ADgLmGnkzQKzAqko/
5tZ0HPuvFIeHsArg3uTlqhEpiSiF0NckzpxhWKQzfA8OM+gJScygBw0ueghIEEJB
8DLfoTUBfX6S0WEXURPN6D4gy7Aqy2tW2zy2y1dJg1X1hKzDB8M=
=/J/V
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 24 Mar 2020 12:07
close #39784
(address . control@debbugs.gnu.org)
20200324110756.euzlxj5gbtgyyng5@gravity
close 39784
thanks

Forgot to change the cc to -done :P
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl556gQACgkQ4xWnWEYT
FWShoA/+MTgwCgu/VJeZRgyLyuZao3fw8XQ9eptR7w4pW/bScJLw8wMiP2SW9WKC
U0llg7uWIuIgkxvb3a7epwWoRRvyEvwlJ7XuHrlEk/sHX11okgJUSwzdu9bk0JcK
IlYB6jNKTU5uYuaFx11q66BI/eQ3iUTbmHYpxmCLI9kXygFRknqjsIMtIcsoOGq5
NQlwGNcmfiBRlHeKzb9NxfxYFaPDSwhKQ1y4AJpaUa3axgVZo0ln3W4bc3q9bVTE
nch079GK0/LbjV4YYmSBKXiwdLaA74Md8V9tv9pagC3hmYnEKcX5MumUSFdYdLqy
ddMTcYQZSSWAr2wQnqGh+nshuEMA0asq94qV77PHhQdw/x0q6xUYfofq5I09iPE7
qfgLpKdsgfXey8R9fydKAZgfKgHJHKL+RNP5YMviYnYi+sMboJSzFybrqX+KOEib
mbVbiJVaDn8AQhN1fenjTqFyLX4xcY2A1lpu7hR5m9DY2gD85UmPqxuh0aU2fqOH
m967g9yp6FqJ0qxDQHWRL97abdIPbSTSicBw8VkO+YdlPFgCI7hIuYPEWjPR//rD
ydupgJQ72N2Y+uQWRXx7YeRsUM6B5VMOX0JkVRIThr692s1Mj6t0r0NQh8COJkb8
3Nh3g8asYFxCGJ+lUawxGKYHMc3kzskuLvShhTalv01Zs7vQy18=
=b77n
-----END PGP SIGNATURE-----


?