Vincent Legoll wrote 5 years ago
Looks like it is still working in a guix VM running on AMD ryzen 3700X host.
But there is some output differences between previous version and this one.
in raw mode (cpuid -r), it outputs one more line per core:
0x20000000 0x00: eax=0x00000000 ebx=0x00000000 ecx=0x00000000 edx=0x00000000
which is probably OK, looks like the change:
Sun Feb 2 2020 Todd Allen <todd.allen@etallen.com>
* cpuid.c: Added leaf walking of the 0x20000000 (Intel Phi) range
[...]
But in normal mode, output changed a lot, some separators changed from ":"
to "=", a lot of reported values, new things... This will probably break
any simplistic parsing of that output, if there is anything doing that in
guix...
Having a cursory look at the changelog, it looks like this is getting a lot
more change since the beginning of this year, or something else.
Maybe Tood Allen can give us a hint...
Guixers, please advise how to proceed further.
Thanks--
Vincent Legoll
From f15fe227325fe1744ecf58d6bfe513e6c97026fe Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sun, 23 Feb 2020 23:15:33 +0100
Subject: [PATCH] gnu: cpuid: Update to 20200211. * gnu/packages/linux.scm
(cpuid): Update to 20200211.
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (23 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f0fd2fb5df..3fdc716545 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5626,14 +5626,14 @@ available in the kernel Linux.")
(define-public cpuid
(package
(name "cpuid")
- (version "20200116")
+ (version "20200211")
(source (origin
(method url-fetch)
(uri (string-append "http://www.etallen.com/cpuid/cpuid-"
version ".src.tar.gz"))
(sha256
(base32
- "1gxi4iwy6j366l6bkj1yyxhrk1rxmwfp498gikfxn8xwhij9dn0a"))))
+ "06sjbqqp80l7nhsp6khglkzdp9qy4vhbvjxbfilznhsmrqiwlw55"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("CC=gcc")
--
2.25.1