Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)
Slightly tested in a x86_64 VM.
Description taken from wikipedia.
--
Vincent Legoll
From 3ae07227d95dc02b9cb802e9e07a425ac38f66f7 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sat, 22 Feb 2020 00:37:23 +0100
Subject: [PATCH] gnu: benchmark: Add bonnie++. * gnu/packages/benchmark.scm
(bonnie++): New variable.
---
gnu/packages/benchmark.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 602681ac86..b084ef1f86 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
@@ -231,3 +232,28 @@ This can give a much better understanding of the command's performance.")
"Benchmark is a library to benchmark code snippets,
similar to unit tests.")
(license license:asl2.0)))
+
+(define-public bonnie++
+ (package
+ (name "bonnie++")
+ (version "1.98")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.coker.com.au/bonnie++/bonnie++-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "010bmlmi0nrlp3aq7p624sfaj5a65lswnyyxk3cnz1bqig0cn2vf"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)))
+ (arguments '(#:tests? #f)) ; there are no tests
+ (home-page "https://doc.coker.com.au/projects/bonnie/")
+ (synopsis "Hard drive and file system benchmark suite")
+ (description
+ "Bonnie++ is a benchmark suite that is aimed at performing a number of
+simple tests of hard drive and file system performance. Bonnie++ allows you to
+benchmark how your file systems perform with respect to data read and write
+speed, the number of seeks that can be performed per second, and the number of
+file metadata operations that can be performed per second.")
+ (license license:gpl2)))
--
2.25.1