[PATCH] gnu: benchmark: Add bonnie++

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)
CAEwRq=p9sCeBx5MxOchtDNtqmUM152L13SR4f6c8tEnG8rvX8Q@mail.gmail.com
Slightly tested in a x86_64 VM.
Description taken from wikipedia.

--
Vincent Legoll
From 3ae07227d95dc02b9cb802e9e07a425ac38f66f7 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sat, 22 Feb 2020 00:37:23 +0100
Subject: [PATCH] gnu: benchmark: Add bonnie++. * gnu/packages/benchmark.scm
(bonnie++): New variable.

---
gnu/packages/benchmark.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 602681ac86..b084ef1f86 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
@@ -231,3 +232,28 @@ This can give a much better understanding of the command's performance.")
"Benchmark is a library to benchmark code snippets,
similar to unit tests.")
(license license:asl2.0)))
+
+(define-public bonnie++
+ (package
+ (name "bonnie++")
+ (version "1.98")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.coker.com.au/bonnie++/bonnie++-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "010bmlmi0nrlp3aq7p624sfaj5a65lswnyyxk3cnz1bqig0cn2vf"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)))
+ (arguments '(#:tests? #f)) ; there are no tests
+ (home-page "https://doc.coker.com.au/projects/bonnie/")
+ (synopsis "Hard drive and file system benchmark suite")
+ (description
+ "Bonnie++ is a benchmark suite that is aimed at performing a number of
+simple tests of hard drive and file system performance. Bonnie++ allows you to
+benchmark how your file systems perform with respect to data read and write
+speed, the number of seeks that can be performed per second, and the number of
+file metadata operations that can be performed per second.")
+ (license license:gpl2)))
--
2.25.1
Vincent Legoll wrote 5 years ago
[PATCH v2] gnu: benchmark: Add bonnie++
(address . 39731@debbugs.gnu.org)
CAEwRq=pd3FUm6L08NA0jJDMUc6UkPvxSyEw4yNXyomx+YA5e3g@mail.gmail.com
Forgot the (C) (again)...

--
Vincent Legoll
From 8b572b851f8b41b8d344cd8b8040c8f62ac6dd27 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sat, 22 Feb 2020 00:37:23 +0100
Subject: [PATCH] gnu: benchmark: Add bonnie++.

* gnu/packages/benchmark.scm (bonnie++): New variable.
---
gnu/packages/benchmark.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 602681ac86..9a30d6952f 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
@@ -231,3 +233,28 @@ This can give a much better understanding of the command's performance.")
"Benchmark is a library to benchmark code snippets,
similar to unit tests.")
(license license:asl2.0)))
+
+(define-public bonnie++
+ (package
+ (name "bonnie++")
+ (version "1.98")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.coker.com.au/bonnie++/bonnie++-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "010bmlmi0nrlp3aq7p624sfaj5a65lswnyyxk3cnz1bqig0cn2vf"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)))
+ (arguments '(#:tests? #f)) ; there are no tests
+ (home-page "https://doc.coker.com.au/projects/bonnie/")
+ (synopsis "Hard drive and file system benchmark suite")
+ (description
+ "Bonnie++ is a benchmark suite that is aimed at performing a number of
+simple tests of hard drive and file system performance. Bonnie++ allows you to
+benchmark how your file systems perform with respect to data read and write
+speed, the number of seeks that can be performed per second, and the number of
+file metadata operations that can be performed per second.")
+ (license license:gpl2)))
--
2.25.1
Marius Bakke wrote 5 years ago
87zhd52i1z.fsf@devup.no
Vincent Legoll <vincent.legoll@gmail.com> writes:

Toggle quote (7 lines)
> From 8b572b851f8b41b8d344cd8b8040c8f62ac6dd27 Mon Sep 17 00:00:00 2001
> From: Vincent Legoll <vincent.legoll@gmail.com>
> Date: Sat, 22 Feb 2020 00:37:23 +0100
> Subject: [PATCH] gnu: benchmark: Add bonnie++.
>
> * gnu/packages/benchmark.scm (bonnie++): New variable.

Applied, thanks!

It was difficult to find license information, so I added a small
comment about it.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl5W2RgACgkQoqBt8qM6
VPodowgAudnYrdX4frh8H/rj8of8J9Jbefk4ITbLEgJYtK2ILVlpwZ7WrYv6cfsI
WnMEym4aUj/TMOu2PdVQtVS2Bn0LsCwULWa6FiHoUQwsHSEEsspdG69g+8iCdcwj
uoIu7bb54QXPevE9JecuhjMfoHbEIYinx/xx6ENGlmdvsLtKUfBNepyfr+IdWITu
ytl9XvETD4Up0Tmwe4ULkHnBQmylD6ZIu34jS7roOaqSQXItZh3EPSq6W33Mzha2
31zy3Owk8pC3n0ekF6CemxbE5eJ9XMC9IL9dXRfvNNjPvN2/U/Gagi1ary6MAct7
gWgVVN/Z5eQULiDQLTvrOeEk48j89Q==
=W9Ot
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39731@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39731
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help