Real-time AV1 playback in VLC

  • Done
  • quality assurance status badge
Details
One participant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
Merged with
L
L
Leo Famulari wrote on 21 Feb 2020 17:25
(address . guix-patches@gnu.org)
20200221162558.GA6445@jasmine.lan
On my Thinkpad x230, VLC cannot play back AV1 videos in real-time. They
stutter and drop frames.

This is because our VLC's AV1 playback is being provided by FFmpeg,
which by default chooses libaom, which is too slow.

By building VLC with the dav1d AV1 decoder, VLC chooses to use dav1d for
playback, and everything is fine.

Here are some AV1 samples; I like the 1080 "Summer Nature" clip:

L
L
Leo Famulari wrote on 21 Feb 2020 17:28
[PATCH] gnu: VLC: Improve AV1 playback.
(address . 39714@debbugs.gnu.org)
6366ce21da70e8b3ef1ea4451fff954864d91526.1582302489.git.leo@famulari.name
* gnu/packages/video.scm (inputs): Add dav1d.
---
gnu/packages/video.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f8c9f9e45a..255591755a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1123,6 +1123,7 @@ videoformats depend on the configuration flags of ffmpeg.")
(inputs
`(("alsa-lib" ,alsa-lib)
("avahi" ,avahi)
+ ("dav1d" ,dav1d)
("dbus" ,dbus)
("eudev" ,eudev)
("flac" ,flac)
--
2.25.1
L
Closed
L
L
Leo Famulari wrote on 21 Feb 2020 18:49
(no subject)
(address . control@debbugs.gnu.org)
20200221174919.GA4347@jasmine.lan
reopen 39714
merge 39714 39719
?