[PATCH] gnu: Add pm_pcie_driver.

  • Open
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 20 Feb 2020 14:59
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20200220135910.24500-1-dannym@scratchpost.org
* gnu/packages/linux.scm (pm_pcie_driver): New variable.
---
gnu/packages/linux.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aff8fd08fc..25dc756e56 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1046,6 +1046,26 @@ module allows the control of the backlight level or luminance property when
supported under @file{/sys/class/backlight/}.")
(license license:gpl2+)))
+(define-public pm_pcie_driver
+ (package
+ (name "pm_pcie_driver")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://www.passmark.com/downloads/pm_pcie_driver.tar.gz")
+ (sha256
+ (base32
+ "0xxyr7xi3j8v64yixzw01w7hi0c8pvd21wyr3k8fjiilvls2x9iw"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (home-page "https://www.passmark.com/products/pcie-test-card/index.php")
+ (synopsis "Passmark PCIe test card driver")
+ (description "This package provides a Linux kernel driver for the Passmark
+PCIe test card.")
+ (license license:gpl2+)))
+
;;;
;;; Pluggable authentication modules (PAM).
D
D
Danny Milosavljevic wrote on 20 Feb 2020 15:01
[PATCH v2] gnu: Add pm_pcie_driver.
(address . 39690@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20200220140107.24695-1-dannym@scratchpost.org
* gnu/packages/linux.scm (pm_pcie_driver): New variable.
---
gnu/packages/linux.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aff8fd08fc..25dc756e56 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1046,6 +1046,26 @@ module allows the control of the backlight level or luminance property when
supported under @file{/sys/class/backlight/}.")
(license license:gpl2+)))
+(define-public pm_pcie_driver
+ (package
+ (name "pm_pcie_driver")
+ (version "2.0.1000")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://www.passmark.com/downloads/pm_pcie_driver.tar.gz")
+ (sha256
+ (base32
+ "0xxyr7xi3j8v64yixzw01w7hi0c8pvd21wyr3k8fjiilvls2x9iw"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (home-page "https://www.passmark.com/products/pcie-test-card/index.php")
+ (synopsis "Passmark PCIe test card driver")
+ (description "This package provides a Linux kernel driver for the Passmark
+PCIe test card.")
+ (license license:gpl2+)))
+
;;;
;;; Pluggable authentication modules (PAM).
T
T
Tobias Geerinckx-Rice wrote on 20 Feb 2020 15:27
(address . 39690@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87sgj5xriz.fsf@nckx
Danny,

Danny Milosavljevic ???
Toggle quote (3 lines)
> + (uri
> "https://www.passmark.com/downloads/pm_pcie_driver.tar.gz")

Are you a paying customer? Any chance you could ask your rep for
a versioned link? :o)

Toggle quote (2 lines)
> + (license license:gpl2+)))

~/pm_pcie_driver λ grep -Eri "licen|gpl"
pm_pcie_driver.c:MODULE_LICENSE("GPL");
~/pm_pcie_driver λ

Sigh. Assuming for a moment that this is legal: wouldn't it be
gpl2-only, like Linux?

LG otherwise!

Thanks,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl5Ol28ACgkQ2Imw8BjF
STwySQ//SZDPzRdt2UN7cky6309NNk8Vp/RMiqGnpIx0tYIkJ0lzp8lr09gqOC7T
/llvG9gSdGQFhj7rGrjC1rt6cPmbxzO5GrAmBS4QTkxSupJH5U6Glqn6wyls/19c
iv7VPxXeHp3KvWf+f0SZYqvteCHFPM2eiZKqK/h3DzmAJ85RB4BNyKEBT0tB/Oyj
0r0lzKYQSRb7+0hlH+Oue8ZTVdLYT4tu5O1rG0+KZh87gAvwb7XTWYrkjLxcgK1a
VFG/c8pqDVeNHyTJfs9rsTpBkJ1i5hBY1B6d/1NAFFxza3vzU3yVkQ7AqXlyk+PI
bClBOoCFT+oJ6rZBlfcEbGVgzdv35z/giKd0bA+GXX7G3M8wnB7pLUM8I6cs436G
5FZWOKlWnpeUzLyRXZGGhy/CYpcnzMfnrk+mgVGULRcjeWtjRS7Yu9tGfZKknFE1
Y5GJ9bXwojY+sRJAIQ5IOr9akAXw/wuMJJuJzwifinrQjmx/r0U0MhFHBVP50n7H
XLHXPXWl6HO4hQxlNrYVhsrQZ6myzuhBQRZwEauq5RxSXDCEZfpdsUrKLIlGsvra
RpFK22aav+mZ6U9R4YJml8WHe8Laapwf7KMyZz7EsxrClW5V62ZqJkxk4iv12UeR
iaVlNLm4TmL/1n+zQPXEvn+pFTGOvCRCiR6HnsBItn3E1K0f8Uc=
=iQ5K
-----END PGP SIGNATURE-----

D
D
Danny Milosavljevic wrote on 20 Feb 2020 18:01
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 39690@debbugs.gnu.org)
20200220180154.5204b10b@scratchpost.org
Hi T G-R,

On Thu, 20 Feb 2020 15:27:59 +0100
Tobias Geerinckx-Rice <me@tobias.gr> wrote:

Toggle quote (2 lines)
> Are you a paying customer?

Yes.

Toggle quote (3 lines)
> Any chance you could ask your rep for
> a versioned link? :o)

I'll try.

Toggle quote (9 lines)
> ~/pm_pcie_driver λ grep -Eri "licen|gpl"
> pm_pcie_driver.c:MODULE_LICENSE("GPL");
> ~/pm_pcie_driver λ
>
> Sigh. Assuming for a moment that this is legal:


>wouldn't it be gpl2-only, like Linux?

Yeah, probably.

Thanks for the review!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl5Ou4IACgkQ5xo1VCww
uqXDMQf/QgOkVPoNTd5YFn0hjObzqNA+Ih1wWzRIvaMA1WmQItB0Y/E7jzwdGH7F
Tv7MqI3CWFDw6n6ujtiLgcRQv1t7qsk9Le885llUUwdzxEdhFltxS4FESWpMZ8Bb
gPqUM807MlycCPiRjA+4Mpnm7VMdSZIbsleMEBxJxfVT+MN4i7Xc+7I3gEJDtRmM
9x1z/kVY7OXKfaYYb7WtcQvEt59o7z11oJUgp78JS7XoMIpBIVzePMI3HPZzN2AB
zguM9vTg0BlKFxMSEpNvRSrE2zAmw/LcxtC7pCdyoIviLj3XVv39jF6lL6//6HpT
i74Km9y3UwNgIlKbi49YdnC7pOuiXQ==
=VNgR
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 39690@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39690
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch