(Out-of-tree) system kernel modules only found in :out

  • Open
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Marius Bakke
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 17 Feb 2020 15:45
(name . Tobias Geerinckx-Rice via Bug reports for GNU Guix)(address . bug-guix@gnu.org)
87blpx6zmn.fsf@nckx
Guix,

After adding (specification->package+output "zfs:module") to my
system packages, it's still missing from current-system:

$ guix system reconfigure …

$ ls /run/current-system/profile/lib/modules/
5.4.0-pf7-4-ed26-M88

That's my horrible custom Linux fork/version/abomination.
Apologies. The ZFS package simply compiles against Guix's default
linux-libre-5.4.20-gnu package.

After editing the zfs package to install everything into the main
:out output:

$ guix system reconfigure …

$ ls /run/current-system/profile/lib/modules/
5.4.0-pf7-4-ed26-M88 5.4.20-gnu

$ ls
/run/current-system/profile/lib/modules/5.4.20-gnu/extra/zfs/
zfs.ko

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl5KpyAACgkQ2Imw8BjF
STxhWhAAsXAl6/kwzdJ9nPz5ywUZrVwYGZrO2JFUC66NXk+n47RwomBVl5LZZ0Kd
nU3ci8F7JBMtVj7awPmowfXO4TekSaov0DBoepUVLHkk7WYsmkx0M9zvAuX/Jo8/
Y3FYBzeTl0sSStdNHrRDfX2jcd6kQxa2hwr+XZDhPgmMFDxXUVtH7HCUjdvIhJVb
m/t5NuB++IivzqSnnyz4tCdKuLiIYK7xsMRFZlXOyWHQHSkJuEnPey+RQ1sioAqn
MA53b+Ck/YoCbD6aGuyTCz9XMy9r200NLF8GpEixBqrPw0w9SPHbddN6f4Kt42+4
8PnXcsq0bbvZTAn1bnqjADj5lwiMZphqDpVhqiCEs7HBcaKqo6uVQ+3zmDcwQmR5
2scBG2NfLQryYwUiD6G8ZoqK3npdp8+DIN6Ha7yNy+YX8vWmZPf+DsONs7RYIu8v
xZrFicKumNXMrSCspWJ4LOC260VeMMq6RRT2QHENlPeH9HTPCiwj6CcaUc3x72te
kNESmsrm+h+CO+3c9g9thR86Z6w1nbW8wsxgXrc3BpXNPuN0gC01k8wDvtJW1oPZ
1y1NWnnfhAzgCcfZr7hWbsJO/2+nS/rZ5YREDpSX23DuEHFbhHZEu9mqLRRrYvsr
yPXCQQi6Zh16pZc9dlLW/m6IftsaNOyq9puRrsSmaNZgcdua+7w=
=0ZjV
-----END PGP SIGNATURE-----

D
D
Danny Milosavljevic wrote on 18 Feb 2020 12:43
(name . Tobias Geerinckx-Rice via Bug reports for GNU Guix)(address . bug-guix@gnu.org)
20200218124334.47d35462@scratchpost.org
Hi,

I don't know what could be up with it.

I've never used specification->package+output before and I don't know whether
one has to do something special afterwards.

(v2) and see whether it magically fixes the problem (probably not).
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl5LzeYACgkQ5xo1VCww
uqWtPQf/ZBqcoAdHv6BdDz+WjoczOLGWmFP6eBh6eD16dyFItoVEOpMkjaM/kQ7K
s4oQGXgpqA2mWmfxzpH5J5h4SfNML2FnC3XxJ2R1uwghnblZoQzzhaeaNxeApmm9
472SCdvQUgC4L9qOHU7g8jNmX4XX0EhSdcN9mn1KJfJXDTQdB83ZHmbvusROY4tS
IKDUVTYWkgBM/D433VQU+TWWQeJvtsCwOmUkcPLpWp7pA65zB0n7Q9+3JnN1B/MH
LEjDxRrSwEXYCnm/1pSY/8tAuC+fYVioU5hyJRQhDMMt21XWjI6ICkFqhpCY2xf8
kZ6X+QPvb31A6KcrEGBDqeRnxvXr+Q==
=02iW
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 18 Feb 2020 18:26
87eeur6c2x.fsf@devup.no
Tobias Geerinckx-Rice via Bug reports for GNU Guix <bug-guix@gnu.org>
writes:

Toggle quote (14 lines)
> Guix,
>
> After adding (specification->package+output "zfs:module") to my
> system packages, it's still missing from current-system:
>
> $ guix system reconfigure …
>
> $ ls /run/current-system/profile/lib/modules/
> 5.4.0-pf7-4-ed26-M88
>
> That's my horrible custom Linux fork/version/abomination.
> Apologies. The ZFS package simply compiles against Guix's default
> linux-libre-5.4.20-gnu package.

To build out-of-tree modules with a custom kernel I would expect that
you have to rebuild them against your kernel:

(define my-kernel
(package/inherit
linux-libre
...))

(define with-custom-kernel
(package-input-rewriting `((,linux-libre . ,my-kernel))))

(define zfs-with-custom-kernel
(with-custom-kernel zfs))

Alternatively, I see that 'linux-module-build-system' takes a #:linux
argument:

(define zfs-with-my-kernel
(package/inherit
zfs
(arguments (substitute-keyword-arguments (package-arguments zfs))
((#:linux _ #f) my-kernel))))

Will these options work for you, or am I misunderstanding something?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl5MHlYACgkQoqBt8qM6
VPoDEgf/U7lFOJVU7f6BZdfp/Mu1IixfVL1cHrtMyu3Slpl657bsGZraaoG0DoeO
UPk/u5I2u7bKD9pR0f9hv6KOl5IDWSTlT/XM41M2uk9xywCrnTw+s/FpjLAmWYRy
f1Gzw6c4Lk7IRQs64q42Bb2voyEoeD40LhbQazBB1u14qY6L5iuSltQzlul2KNul
GAz1yVWHUuXQG2t3p7+EUS6EhcjD+SLL5Ku4tWiezdm8wMdfITnl9rHy1LsS7Jqs
d5DCbC1/nQhyFxVSyVqo+oc1F61RD9sKiiyP16ctelqhoH7XgZ0eYuUs9Vku0v00
ybPgW7LN+Z5/P/0F/bVv8sOPFwAuCA==
=TAZg
-----END PGP SIGNATURE-----

T
T
Tobias Geerinckx-Rice wrote on 18 Feb 2020 18:34
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 39643@debbugs.gnu.org)
87d0abu7cv.fsf@nckx
Marius,

Marius Bakke ???
Toggle quote (3 lines)
> Will these options work for you, or am I misunderstanding
> something?

I think so. The bug is about zfs:module being treated differently
from zfs:out when constructing a system/ union, not about the
build system.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl5MIEAACgkQ2Imw8BjF
STyTcxAArQI3JMekzSKfjOO0i7DVCPmgBhj9tK+2LLFJ2AAMHdGZdtZbXxohNCTw
UdwrRDJNpia7eSbxvM9E/oaaubjt2rq8/u/wH4J/ewCJ6bo7iigylCm2BFRRWBva
OqlNsUjYnfeO6hkFKb3ofIe1hQz8PYfPrzNCCNc4ODIRLHxri6jD5WYIEL++ZOTj
HNCy7fbv74j+2IGdkfkUuqSWP2D4WKFjs7w+Hbcztup/rejprITSPxA+4kFvHFB9
lGvTn6F8BcvPOgIpqjUh8FCI0kk1O8fwjHpQTGZKCkR1YKPjPrmuLpmoIwfjQ2G0
umZiUavlSprFtaG85h9hG1SGxsfnlmIJLfCGMmSuUVtrCYtAWucBO5hG/3Zo+K3b
zkyivurEESHDfI2MRb7eINxUednOV4asmXxt49jElJyRfy2lzUijUgzbR4BkRP9g
xnq3E1uT6buxF+bMVnHd2YT7d7pK36teb4RkzZF50wMoow2X5HlT8Rx26WDCnT/L
f/cJa2OvzQoKuhCwAoJdiFJorlAZ0Z6Sc/WzfoLGDnpyVJJB+Bygfb347l4rzCDp
qr7eELqJMjFNO9IqJWhDWEJyOGyVhEiDYyTzJfOlN9fr4sh7npbxgMguYmB338+y
bbVezYITymxq2aQ9KnuSV8ZXZcsDqJbAIeCq6vkY+1FcD/2mj5I=
=8MHn
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 39643@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39643
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch