[PATCH 0/6] KiCad add translation and update libraries.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brice Waegeneire
  • Danny Milosavljevic
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 16 Feb 2020 22:26
(address . guix-patches@gnu.org)
20200216212621.3063-1-brice@waegenei.re
This serie of patch follows https://issues.guix.info/issue/32616it adds the
missing libraries for KiCad 5 which have been splitted in several repositories
by upstream and also adds translation to KiCad.

I tried to add the documentation too but I wasn't succesfull. I endend up
blocked by the error "Install the Unicode::GCString module!" even though
"perl-unicode-linebreak" was in my inputs.

Brice Waegeneire (6):
gnu: Add kicad-footprints.
gnu: Add variable kicad-packages3d.
gnu: Add kicad-templates.
gnu: Remove kicad-library.
gnu: kicad-symbols: Update synopsis and description.
gnu: kicad: Add translations and search paths.

gnu/packages/engineering.scm | 296 ++++++++++++++++++++---------------
1 file changed, 167 insertions(+), 129 deletions(-)

--
2.25.0
B
B
Brice Waegeneire wrote on 16 Feb 2020 22:28
[PATCH 1/6] gnu: Add kicad-footprints.
(address . 39636@debbugs.gnu.org)
20200216212834.3862-1-brice@waegenei.re
* gnu/packages/engineering.scm (kicad-footprints): Add variable.
---
gnu/packages/engineering.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 4db8109249..cece357720 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Jovany Leandro G.C <bit4bit@riseup.net>
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -953,6 +954,23 @@ libraries for KiCad 5.")
;; See <https://github.com/KiCad/kicad-symbols/blob/master/LICENSE.md>.
(license license:cc-by-sa4.0)))
+(define-public kicad-footprints
+ (package
+ (inherit kicad-symbols)
+ (name "kicad-footprints")
+ (version "5.1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KiCad/kicad-footprints.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c4whgn14qhz4yqkl46w13p6rpv1k0hsc9s9h9368fxfcz9knb2j"))))
+ (synopsis "Official KiCad footprint libraries")
+ (description "This package contains the official KiCad footprint libraries.")))
+
(define-public linsmith
(package
(name "linsmith")
--
2.25.0
B
B
Brice Waegeneire wrote on 16 Feb 2020 22:28
[PATCH 2/6] gnu: Add variable kicad-packages3d.
(address . 39636@debbugs.gnu.org)
20200216212834.3862-2-brice@waegenei.re
* gnu/packages/engineering.scm (kicad-packages3d): Add variable.
---
gnu/packages/engineering.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index cece357720..2d488e2ae5 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -971,6 +971,23 @@ libraries for KiCad 5.")
(synopsis "Official KiCad footprint libraries")
(description "This package contains the official KiCad footprint libraries.")))
+(define-public kicad-packages3d
+ (package
+ (inherit kicad-symbols)
+ (name "kicad-packages3d")
+ (version "5.1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KiCad/kicad-packages3d.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cff2ms1bsw530kqb1fr1m2pjixyxzwa81mxgac3qpbcf8fnpvaz"))))
+ (synopsis "Official KiCad 3D model libraries")
+ (description "This package contains the official KiCad 3D model libraries.")))
+
(define-public linsmith
(package
(name "linsmith")
--
2.25.0
B
B
Brice Waegeneire wrote on 16 Feb 2020 22:28
[PATCH 3/6] gnu: Add kicad-templates.
(address . 39636@debbugs.gnu.org)
20200216212834.3862-3-brice@waegenei.re
* gnu/packages/engineering.scm (kicad-templates): Add variable.
---
gnu/packages/engineering.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 2d488e2ae5..adee1761d6 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -988,6 +988,24 @@ libraries for KiCad 5.")
(synopsis "Official KiCad 3D model libraries")
(description "This package contains the official KiCad 3D model libraries.")))
+(define-public kicad-templates
+ (package
+ (inherit kicad-symbols)
+ (name "kicad-templates")
+ (version "5.1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KiCad/kicad-templates.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cs3bm3zb5ngw5ldn0lzw5bvqm4kvcidyrn76438alffwiz2b15g"))))
+ (synopsis "Official KiCad project and worksheet templates")
+ (description "This package contains the official KiCad project and
+worksheet templates.")))
+
(define-public linsmith
(package
(name "linsmith")
--
2.25.0
B
B
Brice Waegeneire wrote on 16 Feb 2020 22:28
[PATCH 4/6] gnu: Remove kicad-library.
(address . 39636@debbugs.gnu.org)
20200216212834.3862-4-brice@waegenei.re
* gnu/packages/engineering.scm (kicad-library): Remove variable.
---
gnu/packages/engineering.scm | 62 ------------------------------------
1 file changed, 62 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index adee1761d6..0d7b0db2c4 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -864,68 +864,6 @@ perform specific functions, for example, pcbnew (Editing PCB), eeschema (editing
electrical diagrams), gerbview (viewing Gerber files) and others.")
(license license:gpl3+)))
-(define-public kicad-library
- (let ((version "4.0.7"))
- (package
- (name "kicad-library")
- (version version)
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://kicad-downloads.s3.cern.ch/libraries/kicad-library-"
- version ".tar.gz"))
- (sha256
- (base32 "1azb7v1y3l6j329r9gg7f4zlg0wz8nh4s4i5i0l9s4yh9r6i9zmv"))))
- (build-system cmake-build-system)
- (arguments
- `(#:out-of-source? #t
- #:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-footprints ; from footprints tarball
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "tar" "xvf"
- (assoc-ref inputs "kicad-footprints")
- "-C" (string-append (assoc-ref outputs "out")
- "/share/kicad/modules")
- "--strip-components=1")))
- ;; We change the default global footprint file, which is generated if
- ;; it doesn't exist in user's home directory, from the one using the
- ;; github plugin, to the one using the KISYSMOD environment path.
- (add-after 'install-footprints 'use-pretty-footprint-table
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (template-dir (string-append out "/share/kicad/template"))
- (fp-lib-table (string-append template-dir "/fp-lib-table")))
- (delete-file fp-lib-table)
- (copy-file (string-append fp-lib-table ".for-pretty")
- fp-lib-table))
- #t)))))
- (native-search-paths
- (list (search-path-specification
- (variable "KISYSMOD") ; footprint path
- (files '("share/kicad/modules")))
- (search-path-specification
- (variable "KISYS3DMOD") ; 3D model path
- (files '("share/kicad/modules/packages3d")))))
- ;; Kicad distributes footprints in a separate tarball.
- (native-inputs
- `(("kicad-footprints"
- ,(origin
- (method url-fetch)
- (uri (string-append
- "http://downloads.kicad-pcb.org/libraries/kicad-footprints-"
- version ".tar.gz"))
- (sha256
- (base32
- "08qrz5zzsb5127jlnv24j0sgiryd5nqwg3lfnwi8j9a25agqk13j"))))))
- (home-page "https://kicad-pcb.org/")
- (synopsis "Libraries for kicad")
- (description "This package provides Kicad component, footprint and 3D
-render model libraries.")
- (license license:lgpl2.0+))))
-
(define-public kicad-symbols
(package
(name "kicad-symbols")
--
2.25.0
B
B
Brice Waegeneire wrote on 16 Feb 2020 22:28
[PATCH 5/6] gnu: kicad-symbols: Update synopsis and description.
(address . 39636@debbugs.gnu.org)
20200216212834.3862-5-brice@waegenei.re
* gnu/packages/engineering.scm (kicad-symbols)[synopsis]: Updated.
[description]: Updated.
---
gnu/packages/engineering.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 0d7b0db2c4..477a1642c0 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -881,9 +881,9 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(arguments
`(#:tests? #f)) ; no tests exist
(home-page "https://kicad-pcb.org/")
- (synopsis "Official KiCad schematic symbol libraries for KiCad 5")
+ (synopsis "Official KiCad schematic symbol libraries")
(description "This package contains the official KiCad schematic symbol
-libraries for KiCad 5.")
+libraries.")
;; TODO: Exception: "To the extent that the creation of electronic designs
;; that use 'Licensed Material' can be considered to be 'Adapted Material',
;; then the copyright holder waives article 3 of the license with respect to
--
2.25.0
B
B
Brice Waegeneire wrote on 16 Feb 2020 22:28
[PATCH 6/6] gnu: kicad: Add translations and search paths.
(address . 39636@debbugs.gnu.org)
20200216212834.3862-6-brice@waegenei.re
* gnu/packages/engineering.scm (kicad)[arguments]: Add phase
install-translations.
[native-search-paths]: Add specification for KICAD_TEMPLATE_DIR,
KICAD_SYMBOL_DIR, KISYSMOD and KISYS3DMOD.
[native-inputs]: Add desktop-file-utils and kicad-i18l.
[inputs]: Remove desktop-file-utils and replace python by
python-wrapper.
(kicad-i18l): Add variable.
---
gnu/packages/engineering.scm | 179 ++++++++++++++++++++++-------------
1 file changed, 113 insertions(+), 66 deletions(-)

Toggle diff (196 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 477a1642c0..da882a19f6 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -793,76 +793,123 @@ language.")
(define-public ao
(deprecated-package "ao-cad" libfive))
+;; TODO Add doc https://gitlab.com/kicad/services/kicad-doc/-/tree/master
(define-public kicad
- (package
- (name "kicad")
- (version "5.1.5")
- (source
- (origin
- (method url-fetch)
- (file-name (string-append name "-" version ".tar.xz"))
- (uri (string-append
- "https://launchpad.net/kicad/" (version-major version)
- ".0/" version "/+download/kicad-" version ".tar.xz"))
- (sha256
- (base32 "0x3417f2pa7p65s9f7l49rqbnrzy8gz6i0n07mlbxqbnm0fmlql0"))))
- (build-system cmake-build-system)
- (arguments
- `(#:out-of-source? #t
- #:tests? #f ; no tests
- #:build-type "Release"
- #:configure-flags
- (list "-DKICAD_SCRIPTING_PYTHON3=ON"
- "-DKICAD_SCRIPTING_WXPYTHON_PHOENIX=ON"
- "-DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-program
- ;; Ensure correct Python at runtime.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (python (assoc-ref inputs "python"))
- (file (string-append out "/bin/kicad"))
- (path (string-append
- out
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages:"
- (getenv "PYTHONPATH"))))
- (wrap-program file
- `("PYTHONPATH" ":" prefix (,path))
- `("PATH" ":" prefix
- (,(string-append python "/bin:")))))
- #t)))))
- (native-inputs
- `(("boost" ,boost)
- ("gettext" ,gnu-gettext)
- ("pkg-config" ,pkg-config)
- ("swig" ,swig)
- ("zlib" ,zlib)))
- (inputs
- `(("cairo" ,cairo)
- ("curl" ,curl)
- ("desktop-file-utils" ,desktop-file-utils)
- ("glew" ,glew)
- ("glm" ,glm)
- ("hicolor-icon-theme" ,hicolor-icon-theme)
- ("libngspice" ,libngspice)
- ("libsm" ,libsm)
- ("mesa" ,mesa)
- ("opencascade-oce" ,opencascade-oce)
- ("openssl" ,openssl)
- ("python" ,python)
- ("wxwidgets" ,wxwidgets)
- ("wxpython" ,python-wxpython)))
- (home-page "https://kicad-pcb.org/")
- (synopsis "Electronics Design Automation Suite")
- (description "Kicad is a program for the formation of printed circuit
+ (package
+ (name "kicad")
+ (version "5.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (file-name (string-append name "-" version ".tar.xz"))
+ (uri (string-append
+ "https://launchpad.net/kicad/" (version-major version)
+ ".0/" version "/+download/kicad-" version ".tar.xz"))
+ (sha256
+ (base32 "0x3417f2pa7p65s9f7l49rqbnrzy8gz6i0n07mlbxqbnm0fmlql0"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:out-of-source? #t
+ #:tests? #f ; no tests
+ #:build-type "Release"
+ #:configure-flags
+ (list "-DKICAD_SCRIPTING_PYTHON3=ON"
+ "-DKICAD_SCRIPTING_WXPYTHON_PHOENIX=ON"
+ "-DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-translations
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (copy-recursively (assoc-ref inputs "kicad-i18l")
+ (assoc-ref outputs "out"))
+ #t))
+ (add-after 'install 'wrap-program
+ ;; Ensure correct Python at runtime.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (python (assoc-ref inputs "python"))
+ (file (string-append out "/bin/kicad"))
+ (path (string-append
+ out
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages:"
+ (getenv "PYTHONPATH"))))
+ (wrap-program file
+ `("PYTHONPATH" ":" prefix (,path))
+ `("PATH" ":" prefix
+ (,(string-append python "/bin:")))))
+ #t)))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "KICAD_TEMPLATE_DIR")
+ (files '("share/kicad/template")))
+ (search-path-specification
+ (variable "KICAD_SYMBOL_DIR") ; symbol path
+ (files '("share/kicad/library")))
+ (search-path-specification
+ (variable "KISYSMOD") ; footprint path
+ (files '("share/kicad/modules")))
+ (search-path-specification
+ (variable "KISYS3DMOD") ; 3D model path
+ (files '("share/kicad/modules/packages3d")))))
+ (native-inputs
+ `(("boost" ,boost)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gnu-gettext)
+ ("kicad-i18l" ,kicad-i18l)
+ ("pkg-config" ,pkg-config)
+ ("swig" ,swig)
+ ("zlib" ,zlib)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("curl" ,curl)
+ ("glew" ,glew)
+ ("glm" ,glm)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("libngspice" ,libngspice)
+ ("libsm" ,libsm)
+ ("mesa" ,mesa)
+ ("opencascade-oce" ,opencascade-oce)
+ ("openssl" ,openssl)
+ ("python" ,python-wrapper)
+ ("wxwidgets" ,wxwidgets)
+ ("wxpython" ,python-wxpython)))
+ (home-page "https://kicad-pcb.org/")
+ (synopsis "Electronics Design Automation Suite")
+ (description "Kicad is a program for the formation of printed circuit
boards and electrical circuits. The software has a number of programs that
perform specific functions, for example, pcbnew (Editing PCB), eeschema (editing
electrical diagrams), gerbview (viewing Gerber files) and others.")
- (license license:gpl3+)))
+ (license license:gpl3+)))
+
+(define kicad-i18l
+ (package
+ (name "kicad-i18l")
+ (version "5.1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/kicad/code/kicad-i18n.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rfpifl8vky1gba2angizlb2n7mwmsiai3r6ip6qma60wdj8sbd3"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (delete 'check))))
+ (native-inputs
+ `(("gettext" ,gnu-gettext)))
+ (home-page "https://kicad-pcb.org/")
+ (synopsis "KiCad GUI translations")
+ (description "This package contains the po files that is used for the GUI
+translations for KiCad.")
+ (license license:gpl3+)))
(define-public kicad-symbols
(package
--
2.25.0
D
D
Danny Milosavljevic wrote on 19 Feb 2020 16:35
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 39636@debbugs.gnu.org)
20200219163534.403c757c@scratchpost.org
Hi Brice,

thanks for the patch series.

On Sun, 16 Feb 2020 22:28:34 +0100
Brice Waegeneire <brice@waegenei.re> wrote:

Toggle quote (14 lines)
> + (native-search-paths
> + (list (search-path-specification
> + (variable "KICAD_TEMPLATE_DIR")
> + (files '("share/kicad/template")))
> + (search-path-specification
> + (variable "KICAD_SYMBOL_DIR") ; symbol path
> + (files '("share/kicad/library")))
> + (search-path-specification
> + (variable "KISYSMOD") ; footprint path
> + (files '("share/kicad/modules")))
> + (search-path-specification
> + (variable "KISYS3DMOD") ; 3D model path
> + (files '("share/kicad/modules/packages3d")))))

What is the effect of these?

Otherwise fine, I'll apply all of those, but I'm just wondering what the above
is for because I've seen thousands of packages and very very few have that,
and even fewer "normal end user" programs do.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl5NVcYACgkQ5xo1VCww
uqXXEQf/SOaxO9bFtjEtZ+KILsWFN9kIRMMzpjYp66iy1E8lQN4AIctiVM/7/Vjc
ebNTTRd/S64h44iyhrjeyGSVLrD4kOOUneQp/fOrSFS0nR0WnyyTzSp5Y0DmRmql
NGdJt/BMJ6KN/2e0xZ394y1t3B/WNJG3SiFcPQR5j5HEVPKXRxhCfEhfk+VVoeeY
AW+GovemzDct5O0KiZi02fbtKsDMrYxwfWzS/agEnI/IHo1R1RfKm5SL7+b2J2JF
FxG2QWOeNDDiCCfWyGC49qRnrHwJTZ9MUtbiOWwGz1PQ3VSm6ac2vSmxmtH/qN9g
2Qjz1N+4ZnbAQKM2ACZcuzxgxtE42w==
=iV1V
-----END PGP SIGNATURE-----


B
B
Brice Waegeneire wrote on 19 Feb 2020 20:07
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
07148b13cf2ed02357a4f989a943dbea@waegenei.re
On 2020-02-19 15:35, Danny Milosavljevic wrote:
Toggle quote (22 lines)
>> + (native-search-paths
>> + (list (search-path-specification
>> + (variable "KICAD_TEMPLATE_DIR")
>> + (files '("share/kicad/template")))
>> + (search-path-specification
>> + (variable "KICAD_SYMBOL_DIR") ; symbol path
>> + (files '("share/kicad/library")))
>> + (search-path-specification
>> + (variable "KISYSMOD") ; footprint path
>> + (files '("share/kicad/modules")))
>> + (search-path-specification
>> + (variable "KISYS3DMOD") ; 3D model path
>> + (files '("share/kicad/modules/packages3d")))))
>
> What is the effect of these?
>
> Otherwise fine, I'll apply all of those, but I'm just wondering what
> the above
> is for because I've seen thousands of packages and very very few have
> that,
> and even fewer "normal end user" programs do.

Note that in the 4th patch, the deleted package kicad-library, set 2 of
those native-paths already. These variables allows KiCad to find the
location of it's "libraries" packaged in the first patches of this
series. For example "KISYSMOD" will enable KiCad to find the schematic
symbol libraries provided by "kicad-symbols" or any other future package
that would provide some.

This is particularly useful, when running the wizards on your firsts run
of KiCad, to copy the global symbol library table without using the file
browser half haphazardly to find the path to that particular library.
With these environment variables set a user only need to use the
recommended option.

You can find the related documentation here:
D
D
Danny Milosavljevic wrote on 27 Feb 2020 14:33
Re: [bug#39636] [PATCH 0/6] KiCad add translation and update libraries.
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 39636-done@debbugs.gnu.org)
20200227143309.70ff3a9c@scratchpost.org
Hi,

I have pushed the patchset to guix master as the following commits:

* 259e65aac183c76323a15de18bc2c2897e728dba for kicad-footprints
* c595150709f6ead12d17f303821a7a6e916aa1d0 for kicad-packages3d
* ca839f3c1867903d217a2a61ebcc7dfb250b5e5f for kicad-templates
* 052847422341e580f79bda8384f03746baa5b5e2 for kicad-library
* badc3c6783c37d88bcea5b8905f76841c76c1b99 for kicad-symbols description update
* e7075353e02a761e8cfb71afb1496da0418edcf2 for kicad

Thanks.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl5XxRUACgkQ5xo1VCww
uqXHegf+O2JuFBW6TYU7G+x68YvtygTrsUhYVGL5g8RHyMUvZn+4C7SO1bcnkgSW
2LXN5PzPNMSk8WIu4PFAxwgaA/czDueFd/z/+Tky/27lHDs1JBNRygawKBpc9oYm
LynHUM00wgZS9+XMtpW9F4xet5q7tlbhYo6HbjaV98kZPNxU0w5CIpmyJlIE7uDO
zDuK4v2OW6e57jdtWwNU8Y/ISTN0qnbRyVB4zTcsqmTktGDssVrTYXmxrcIyGqEU
skGovcu+xtcUNYTtWKGkRXdJ5s1qi951u/Q2RrykO/Sz6OW14y0SpNye486rK5Hv
V29bR5DzIY5dwnlmRYr+EjIgQWm5VA==
=RkAv
-----END PGP SIGNATURE-----


Closed
?