Rene wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Hello,
this patch fix the absolute path for /bin/cat and is required to set thumbnail image for user in GNOME desktop.
Debug error:
--
1) gnome-control-center -v
2) try changing the user's thumbnail.
00:25:56.0336 AccountsService: WARNING: SetIconFile call failed: GDBus.Error:org.freedesktop.Accounts.Error.Failed: reading file '/gnu/store/k159736sj00s0jkirkr2270nlx6sx6h2-gnome-control-center-3.32.2/share/pixmaps/faces/mountain.jpg' failed: Failed to execute child process “/bin/cat” (No such file or directory)
--
Thanks
Rene
From 9df62bc0f1a4e99311191ae940e85b559887a480 Mon Sep 17 00:00:00 2001
From: Rene Saavedra <pacoon@protonmail.com>
Date: Sat, 15 Feb 2020 18:46:14 -0600
Subject: [PATCH] gnu: accountsservice: 'Add patch-/bin/cat' phase.
* gnu/packages/freedesktop.scm (accountsservice)[arguments]: Add 'patch-/bin/cat'
phase.
---
gnu/packages/freedesktop.scm | 6 ++++++
1 file changed, 6 insertions(+)
Toggle diff (26 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 01466b8ec5..80e185c8e7 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Reza Alizadeh Majd <r.majd@pantherx.org>
;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Rene Saavedra <pacoon@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -921,6 +922,11 @@ message bus.")
"--enable-elogind")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-/bin/cat
+ (lambda _
+ (substitute* "src/user.c"
+ (("/bin/cat") (which "cat")))
+ #t))
(add-before
'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
--
2.21.0