[PATCH] gnu: accountsservice: 'Add patch-/bin/cat' phase.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Rene
Owner
unassigned
Submitted by
Rene
Severity
normal

Debbugs page

Rene wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
nImNaykxB5G066ZbkFjY_GdiilBPYfvktuHMQK96LNXyjNasMe6T5eY7P7CbVrzJ6GE6CdJAxePvohC4jrldDUWegLpmtW-dRamx2S7nnAI=@protonmail.com
Hello,

this patch fix the absolute path for /bin/cat and is required to set thumbnail image for user in GNOME desktop.

Debug error:

--
1) gnome-control-center -v
2) try changing the user's thumbnail.

00:25:56.0336 AccountsService: WARNING: SetIconFile call failed: GDBus.Error:org.freedesktop.Accounts.Error.Failed: reading file '/gnu/store/k159736sj00s0jkirkr2270nlx6sx6h2-gnome-control-center-3.32.2/share/pixmaps/faces/mountain.jpg' failed: Failed to execute child process “/bin/cat” (No such file or directory)
--

Thanks
Rene
From 9df62bc0f1a4e99311191ae940e85b559887a480 Mon Sep 17 00:00:00 2001
From: Rene Saavedra <pacoon@protonmail.com>
Date: Sat, 15 Feb 2020 18:46:14 -0600
Subject: [PATCH] gnu: accountsservice: 'Add patch-/bin/cat' phase.

* gnu/packages/freedesktop.scm (accountsservice)[arguments]: Add 'patch-/bin/cat'
phase.
---
gnu/packages/freedesktop.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 01466b8ec5..80e185c8e7 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Reza Alizadeh Majd <r.majd@pantherx.org>
;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Rene Saavedra <pacoon@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -921,6 +922,11 @@ message bus.")
"--enable-elogind")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-/bin/cat
+ (lambda _
+ (substitute* "src/user.c"
+ (("/bin/cat") (which "cat")))
+ #t))
(add-before
'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
--
2.21.0
Marius Bakke wrote 5 years ago
87y2t25yzk.fsf@devup.no
Rene via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> Hello,
>
> this patch fix the absolute path for /bin/cat and is required to set thumbnail image for user in GNOME desktop.

Good catch, applied in c9aadd074961b149870cbe6128d77b6cacb1d2b6.

By the way, there are some other hard coded file names in that file, for
/usr/bin/passwd and /usr/bin/chage. We should probably patch those too.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl5JYJ8ACgkQoqBt8qM6
VPrRSgf/cgkDCAFeEhgaoN8EdLH3mjobrdhKdg45jq53Uukw+jKtwJboDgYfeY1M
mo9gwyBaG9RnNfTF+zjps61VmoSsbr/WHZAmAb0T7O8CnZOmW2GUaDExT3L9/YbC
9jUzh/oxAoqjGdh0cWqH1wOivtgTAPxmjLD5nM28c27hZ0crZdUo3BHXdxrBb0pV
UFrNvCn3g37sDH0CtxwsqA883KyoQLBY+HWahRM+vWBgcCGOcNH2BbfwRJ6ly5Vl
QV4d8IPApDD4h5Wx+oMRADvasB5CA5QOoGEIMxjvB4g57E9Y3fvjiEM1ZDruDSwO
qSrFnkIHSZUU/9lNkGvzn9j1PDwQyw==
=AnUf
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39628@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39628
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help