[PATCH] Add perl Config::Grammar

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)
CAEwRq=qF3x88_0w-FuDThaE+zq1960qvAxmthLK-rNWq8tf9XA@mail.gmail.com
Hello,

I packaged this on my way to get smokeping in, so
here is the patch.

WDYT ?

--
Vincent Legoll
From 6c29dd540a4b6b2dc8c340982d68e3eb26831233 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sun, 9 Feb 2020 23:01:58 +0100
Subject: [PATCH] gnu: perl: Add perl Config::Grammar CPAN module

* gnu/packages/perl.scm (perl-config-grammar): New variable.
---
gnu/packages/perl.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9fc3493a5d..ca24bb4de8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1380,6 +1380,25 @@ parser in your Perl programme and allows sharing configuration files between
languages.")
(license bsd-3)))
+(define-public perl-config-grammar
+ (package
+ (name "perl-config-grammar")
+ (version "1.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DS/DSCHWEI/"
+ "Config-Grammar-" version ".tar.gz"))
+ (sha256
+ (base32 "1qynf5bk6mnk90nggm3z8rdz2535kmqg46s0vj93pi68r6ia7cx8"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Config-Grammar")
+ (synopsis "Grammar-based config parser")
+ (description
+ "Config::Grammar is a module to parse configuration files. The configuration
+may consist of multiple-level sections with assignments and tabular data.")
+ (license perl)))
+
(define-public perl-config-any
(package
(name "perl-config-any")
--
2.25.0
Vincent Legoll wrote 5 years ago
[PATCH v2] Add perl Config::Grammar
(address . 39537@debbugs.gnu.org)
CAEwRq=qPSiM=dKrgPePOyyNCZQnKqZmbUcTdAQdNJmTB8Kehew@mail.gmail.com
An update, forgot the (C)

--
Vincent Legoll
From 73dde6125142ddb6d4cae180f5d150b76a9dfd7e Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Sun, 9 Feb 2020 23:01:58 +0100
Subject: [PATCH] gnu: perl: Add perl Config::Grammar CPAN module

* gnu/packages/perl.scm (perl-config-grammar): New variable.
---
gnu/packages/perl.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9fc3493a5d..654c0858ae 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Stephen J. Scheck <sscheck@cpan.org>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1380,6 +1381,25 @@ parser in your Perl programme and allows sharing configuration files between
languages.")
(license bsd-3)))
+(define-public perl-config-grammar
+ (package
+ (name "perl-config-grammar")
+ (version "1.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DS/DSCHWEI/"
+ "Config-Grammar-" version ".tar.gz"))
+ (sha256
+ (base32 "1qynf5bk6mnk90nggm3z8rdz2535kmqg46s0vj93pi68r6ia7cx8"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Config-Grammar")
+ (synopsis "Grammar-based config parser")
+ (description
+ "Config::Grammar is a module to parse configuration files. The configuration
+may consist of multiple-level sections with assignments and tabular data.")
+ (license perl)))
+
(define-public perl-config-any
(package
(name "perl-config-any")
--
2.25.0
Nicolas Goaziou wrote 5 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 39537-done@debbugs.gnu.org)
878slb1hkr.fsf@nicolasgoaziou.fr
Hello,

Vincent Legoll <vincent.legoll@gmail.com> writes:

Toggle quote (10 lines)
> An update, forgot the (C)
>
> --
> Vincent Legoll
>
> From 73dde6125142ddb6d4cae180f5d150b76a9dfd7e Mon Sep 17 00:00:00 2001
> From: Vincent Legoll <vincent.legoll@gmail.com>
> Date: Sun, 9 Feb 2020 23:01:58 +0100
> Subject: [PATCH] gnu: perl: Add perl Config::Grammar CPAN module

I fixed the commit message, added two spaces after sentences in the
description, fixed the license, then applied your patch, as
1c8b70c875843b98cd0ddac366f6a9272d335a46.

Thank you!

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39537@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39537
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help