[PATCH] gnu: sane-backends: Disable genesys_unit_tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 6 Feb 2020 23:39
(address . guix-patches@gnu.org)(address . 39449@debbugs.gnu.org)
20200206223954.20222-1-leo.prikler@student.tugraz.at
* gnu/packages/scanner.scm (sane-backends)[arguments]<#:phases>:
Add disable-failing-backend-tests.
---
gnu/packages/scanner.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index 6adaba18cd..3f922a4747 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -131,6 +131,10 @@ package contains the library, but no drivers.")
((#:phases phases)
`(modify-phases ,phases
(delete 'disable-backends)
+ (add-after 'disable-failing-tests 'disable-failing-backend-tests
+ (lambda _
+ (substitute* "testsuite/backend/genesys/Makefile.in"
+ ((" genesys_unit_tests\\$\\(EXEEXT\\)") ""))))
(add-after 'unpack 'add-backends
(lambda _
(substitute* "backend/dll.conf.in"
--
2.25.0
L
L
Ludovic Courtès wrote on 13 Feb 2020 23:36
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
87ftfe15dv.fsf@gnu.org
Hi,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (19 lines)
> * gnu/packages/scanner.scm (sane-backends)[arguments]<#:phases>:
> Add disable-failing-backend-tests.
> ---
> gnu/packages/scanner.scm | 4 ++++
> 1 file changed, 4 insertions(+)
>
> diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
> index 6adaba18cd..3f922a4747 100644
> --- a/gnu/packages/scanner.scm
> +++ b/gnu/packages/scanner.scm
> @@ -131,6 +131,10 @@ package contains the library, but no drivers.")
> ((#:phases phases)
> `(modify-phases ,phases
> (delete 'disable-backends)
> + (add-after 'disable-failing-tests 'disable-failing-backend-tests
> + (lambda _
> + (substitute* "testsuite/backend/genesys/Makefile.in"
> + ((" genesys_unit_tests\\$\\(EXEEXT\\)") ""))))

Applied with two things: returning #t, and adding a comment linking to
the bug report.

Danny: this is actually on i686, not on x86_64. See the build logs:

Toggle snippet (12 lines)
$ guix build sane-backends -s i686-linux --log-file --no-grafts
https://ci.guix.gnu.org/log/w150bi6vvqqll31qqy99vm1iwwj4hgm9-sane-backends-1.0.29
$ guix build sane-backends -s x86_64-linux --log-file --no-grafts
https://ci.guix.gnu.org/log/m8mdg866lkzw6jnbgdz8b4spk61mx2y6-sane-backends-1.0.29
$ guix describe
Generacio 128 Feb 10 2020 22:29:47 (nuna)
guix 8a0dd28
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 8a0dd289c5b201ebfdd5465d412230bb81110e4c

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 13 Feb 2020 23:36
control message for bug #39476
(address . control@debbugs.gnu.org)
87eeuy15do.fsf@gnu.org
tags 39476 fixed
close 39476
quit
?