[PATCH] gnu: subversion: Support running the tests in parallel.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
20200206084207.15195-1-mail@cbaines.net
This drops the time to build the package on my machine from ~14 minutes to ~5
minutes.

* gnu/packages/version-control.scm (subversion)[arguments]: Add set-PARALLEL
phase to set the PARALLEL environment variable.
---
gnu/packages/version-control.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 20db6b4b08..140eccb7ec 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1434,6 +1434,10 @@ following features:
(substitute* "subversion/tests/libsvn_repos/repos-test.c"
(("#!/bin/sh") (string-append "#!" (which "sh"))))
#t))
+ (add-before 'check 'set-PARALLEL
+ (lambda _
+ (setenv "PARALLEL" (number->string (parallel-job-count)))
+ #t))
(add-after 'install 'install-perl-bindings
(lambda* (#:key outputs #:allow-other-keys)
;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.
--
2.25.0
Leo Famulari wrote 5 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 39451@debbugs.gnu.org)
20200207225720.GB8706@jasmine.lan
On Thu, Feb 06, 2020 at 08:42:07AM +0000, Christopher Baines wrote:
Toggle quote (3 lines)
> This drops the time to build the package on my machine from ~14 minutes to ~5
> minutes.

Awesome. If it seems reliable for you (doesn't crash due to race
conditions) then please push.
Ludovic Courtès wrote 5 years ago
control message for bug #39451
(address . control@debbugs.gnu.org)
87r1yy15u8.fsf@gnu.org
tags 39451 fixed
close 39451
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39451@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39451
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help