[PATCH] gnu: lxqt-config: fixing keyboard layout.

  • Done
  • quality assurance status badge
Details
2 participants
  • Fakhri Sajadi
  • Marius Bakke
Owner
unassigned
Submitted by
Fakhri Sajadi
Severity
normal

Debbugs page

Fakhri Sajadi wrote 5 years ago
(address . guix-patches@gnu.org)(address . f.sajadi@pantherx.org)
e7c6120c-6980-43e4-9e08-3fd8273d9cdd@www.fastmail.com
* gnu/packages/lxqt.scm (lxqt-config): Add xkeyboard-config in inputs.
---
gnu/packages/lxqt.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 12c92e52d1..e58ec70579 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -379,6 +379,7 @@ the operating system LXQt is running on.")
("qtx11extras" ,qtx11extras)
("solid" ,solid)
("xf86-input-libinput" ,xf86-input-libinput)
+ ("xkeyboard-config" ,xkeyboard-config)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -394,6 +395,15 @@ the operating system LXQt is running on.")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
#t))
+ (add-after 'unpack 'set-xkeyboard-config-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Set the file name to xkeyboard-config and kbd.
+ (let ((xkb (assoc-ref inputs "xkeyboard-config"))
+ (kbd (assoc-ref inputs "kbd")))
+ (substitute* "lxqt-config-input/keyboardlayoutconfig.h"
+ (("/usr/share/X11/xkb/rules/base.lst")
+ (string-append xkb "/share/X11/xkb/rules/base.lst")))
+ #t)))
(add-after 'unpack 'patch-translations-dir
(lambda* (#:key outputs #:allow-other-keys)
(substitute* '("lxqt-config-file-associations/CMakeLists.txt"
Marius Bakke wrote 5 years ago
(address . f.sajadi@pantherx.org)
871rr869ct.fsf@devup.no
"Fakhri Sajadi" <f.sajadi@pantherx.org> writes:

Toggle quote (2 lines)
> * gnu/packages/lxqt.scm (lxqt-config): Add xkeyboard-config in inputs.

Thanks! I edited the commit message to more closely follow our
conventions, and also added a copyright line for you. Let me know if
the information is incorrect.

[...]

Toggle quote (10 lines)
> + (add-after 'unpack 'set-xkeyboard-config-file-name
> + (lambda* (#:key inputs #:allow-other-keys)
> + ;; Set the file name to xkeyboard-config and kbd.
> + (let ((xkb (assoc-ref inputs "xkeyboard-config"))
> + (kbd (assoc-ref inputs "kbd")))
> + (substitute* "lxqt-config-input/keyboardlayoutconfig.h"
> + (("/usr/share/X11/xkb/rules/base.lst")
> + (string-append xkb "/share/X11/xkb/rules/base.lst")))
> + #t)))

I also removed the let binding for 'kbd' as it was unused.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl47LCMACgkQoqBt8qM6
VPqv/gf/Xb9XCMzjbMwL8v1C97hPobW8v/CAiZ/g5n4LZ1JAEsVQWMcaHqW9XGef
GL9/npJtEVGY6FrVw09VVTF8PkVlfo3Le957VEwj1/9Pv1BPy79V4NXllIzwgeX4
4OzOq9+XU9jyH70cMxwbdhsKxTif1QcfRWmInMV17cSXr2eSl16JLsFTdZGE3H20
TmY7tKtsXz6MPP9VTUI48SoDgP6hRPEyqXdMZwDlz5cmk/wVr869NW2krQIeZ6kF
rQpmEdkQGHkTx4+4B26qu9uk29fWHrP7nP7y2e2RwisXSPYAM+++ej7YUKV0xFkt
pBvZKjT/S/LQjkdzX5XkriBgPPLXnA==
=mk/g
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39435@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39435
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help