[PATCH] gnu: Add lf.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Pkill -9
Owner
unassigned
Submitted by
Pkill -9
Severity
normal

Debbugs page

Pkill -9 wrote 5 years ago
(address . bug-guix@gnu.org)(name . Pkill -9)(address . pkill9@runbox.com)
20200130112816.10589-1-pkill9@runbox.com
* gnu/packages/disk.scm (lf): New variable.
---
gnu/packages/disk.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index a28033c0af..dfe6dfb54a 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -62,11 +62,14 @@
#:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages terminals)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages vim)
#:use-module (gnu packages w3m)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix build-system scons)
@@ -822,3 +825,31 @@ on your file system and offers to remove it. @command{rmlint} can find:
@item files with broken user and/or group ID.
@end itemize\n")
(license license:gpl3+)))
+
+(define-public lf
+ (package
+ (name "lf")
+ (version "13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gokcehan/lf.git")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ld3q75v8rvp169w5p85z1vznqs9bhck6bm2f6fykxx16hmpb6ga"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
+ ("go-github.com-nsf-termbox-go" ,go-github.com-nsf-termbox-go)))
+ (arguments
+ `(#:unpack-path "github.com/gokcehan/lf"
+ #:import-path "github.com/gokcehan/lf"))
+ (home-page "https://github.com/gokcehan/lf")
+ (synopsis "Console file browser similar to Ranger")
+ (description "lf (as in \"list files\") is a terminal file manager
+written in Go. It is heavily inspired by ranger with some missing and
+extra features. Some of the missing features are deliberately omitted
+since they are better handled by external tools.")
+ (license license:expat)))
--
2.25.0
Leo Famulari wrote 5 years ago
(name . Pkill -9)(address . pkill9@runbox.com)(address . 39355-done@debbugs.gnu.org)
20200202211933.GA19208@jasmine.lan
On Thu, Jan 30, 2020 at 11:28:16AM +0000, Pkill -9 wrote:
Toggle quote (2 lines)
> * gnu/packages/disk.scm (lf): New variable.

Thanks! I removed the superfluous #:unpack-path and pushed as
d441a6455051d70d7ff0d951c7e68318499b1739

Toggle quote (61 lines)
> ---
> gnu/packages/disk.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
> index a28033c0af..dfe6dfb54a 100644
> --- a/gnu/packages/disk.scm
> +++ b/gnu/packages/disk.scm
> @@ -62,11 +62,14 @@
> #:use-module (gnu packages sphinx)
> #:use-module (gnu packages sqlite)
> #:use-module (gnu packages swig)
> + #:use-module (gnu packages terminals)
> + #:use-module (gnu packages textutils)
> #:use-module (gnu packages vim)
> #:use-module (gnu packages w3m)
> #:use-module (gnu packages web)
> #:use-module (gnu packages xml)
> #:use-module (guix build-system gnu)
> + #:use-module (guix build-system go)
> #:use-module (guix build-system python)
> #:use-module (guix build-system trivial)
> #:use-module (guix build-system scons)
> @@ -822,3 +825,31 @@ on your file system and offers to remove it. @command{rmlint} can find:
> @item files with broken user and/or group ID.
> @end itemize\n")
> (license license:gpl3+)))
> +
> +(define-public lf
> + (package
> + (name "lf")
> + (version "13")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/gokcehan/lf.git")
> + (commit (string-append "r" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1ld3q75v8rvp169w5p85z1vznqs9bhck6bm2f6fykxx16hmpb6ga"))))
> + (build-system go-build-system)
> + (native-inputs
> + `(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
> + ("go-github.com-nsf-termbox-go" ,go-github.com-nsf-termbox-go)))
> + (arguments
> + `(#:unpack-path "github.com/gokcehan/lf"
> + #:import-path "github.com/gokcehan/lf"))
> + (home-page "https://github.com/gokcehan/lf")
> + (synopsis "Console file browser similar to Ranger")
> + (description "lf (as in \"list files\") is a terminal file manager
> +written in Go. It is heavily inspired by ranger with some missing and
> +extra features. Some of the missing features are deliberately omitted
> +since they are better handled by external tools.")
> + (license license:expat)))
> --
> 2.25.0
>
>
>
>
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl43POUACgkQJkb6MLrK
fwhJpA/9FDS03e+UCh+pNbXG6SVxfvZyHRhFXBLXtbMoLcNy1BqTUCRKK2Vtlq5o
XQ4vEAlvEyl7e/XghBw1zoJe1pF7VvCzRB4VrbVjvEemkiXOD0n6s1PtB5MYK/x4
WirLQWoR9t+FZxz5D9RWBQWaLaZzngVSiFDhdwGEB8QRUlbxqyUY1YbHXm+E0U/K
j/tHM2xu6qoUWOSugcgftHMJAse5agPoK/p1fxeTwMehEH2MpbJzhrZ1wlUTOAXk
B1pK2zWVEtK6Nt/uAFEj4YB1me/4PihKjrJvEXXIazLwSBVsI9zn83KtZsLSlWn8
vejqM9imoDqGVSct//cDhA/CaVf4G8T/VxpQhbfB2NCodIc7uyHb3F3u/hA6n7NP
TFMzFOsdVmsnreLTGAyf2jg5WOFCd/NNZ2aCN8ITyaOCjqyp44rPxf1Iq6vUdbiH
lSfYThqBr2iEeG6WjbuHxnWjd8zuiz2NXzAEKMEH/KbazvXSXBZ6Mm6o9TZ9ilr/
/i+RdrhEIHtZmWGzHo4ExGyO+MYyvIxUVkQWmL798ps1i9SISDCcUIuUHkiTGyI1
wMCy/QCxtJ4S6Bs3ZNjulzrGxs4EGafXNnGIDF5ZMHmcLpbK2L4Z3TJot3jAlgFU
KnTBcq2cITuxCSnv3Gc08u44y3E3pHHIluJfQAznn5hN2fpN7Es=
=R5zh
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39355@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39355
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help