[PATCH] gnu: vlc: add fluidsynth as input.

  • Open
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Jesse Gibbons
  • Christopher Baines
Owner
unassigned
Submitted by
Jesse Gibbons
Severity
normal
J
J
Jesse Gibbons wrote on 25 Jan 2020 02:19
(address . guix-patches@gnu.org)
56f17e2eeb450626e36f546d80f0c63a26185c56.camel@gmail.com
* gnu/packages/video.scm (vlc) [inputs]: Add FluidSynth.
---
gnu/packages/video.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (13 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ee7108753f..53d9a794f8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1118,6 +1118,7 @@ videoformats depend on the configuration flags of
ffmpeg.")
("dbus" ,dbus)
("eudev" ,eudev)
("flac" ,flac)
+ ("fluidsynth" ,fluidsynth)
("ffmpeg" ,ffmpeg)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
C
C
Christopher Baines wrote on 25 Jan 2020 09:35
(address . jgibbons2357@gmail.com)(address . 39275@debbugs.gnu.org)
871rro6iis.fsf@cbaines.net
Jesse Gibbons <jgibbons2357@gmail.com> writes:

Toggle quote (19 lines)
> * gnu/packages/video.scm (vlc) [inputs]: Add FluidSynth.
> ---
> gnu/packages/video.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index ee7108753f..53d9a794f8 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -1118,6 +1118,7 @@ videoformats depend on the configuration flags of
> ffmpeg.")
> ("dbus" ,dbus)
> ("eudev" ,eudev)
> ("flac" ,flac)
> + ("fluidsynth" ,fluidsynth)
> ("ffmpeg" ,ffmpeg)
> ("fontconfig" ,fontconfig)
> ("freetype" ,freetype)

Hi Jesse,

It would be good to put something in the commit message about why this
is happening, as it's not obvious to me at least.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl4r/btfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XczQw//b8laG3y8dbmTqN/yifAq7xtLUO0p48yLwAU/7omVl+SSuabLBvgIKlii
z/A/pqVoB8wsbJPK5uSTlYEdXzv811j/1n4LNihe7pVDoOrjf6rvuV1tpMcRiXr6
GN3z1vxiGvXSOznziShvGt91tjW0FXvRtyktppmjqgavbkqTgs4MHvhgPXY9no2u
5iTbJjA52wBJQVJgWhjLBg4tVBKamyP+jvxwEOkTI4wMdGlooX/e2rkqIHNhbh4N
tFO6hs8yDsrANHAqCTbGAoSSUvBc0Af/oJdpv/nJcahvgTaMnAU6HTNMembQ9WPM
qKiP/haDXxntY1j2xaz7rRDh/N4sX4BREEyhm25Oxce0t9BFnx5YeUlBknxBZKQh
M/0W62EZhOr0jFInh+U1pAbrrJEODM84tiYHElvybgf5kdB8x81yKm1Mgvx8BGhS
OHdfkj7ja+weRleqmHnbUqpXEgcp2Orwwo91d2jFV8AKcu5ZxduHkFz03x4UXpI/
e6C56GGuTORrnt0o4OXj6o89CEuXjc5rQYOhOJSOQ4ZGe2caAwKHeI4GyhAKdCxE
Kf2LGf1exg1I2zL+foCcYt2RrmGTAhDgDXiJiTisOfWhHdXkklFfKOaRjYrEjKjO
/CsDlr7EDfQGReJYz5OW1B+NugzKKiiPo4os1BlCEGj9ZbKFe08=
=kq5j
-----END PGP SIGNATURE-----

D
D
Danny Milosavljevic wrote on 25 Jan 2020 12:30
(address . 39275@debbugs.gnu.org)
20200125123027.50a6ab1a@scratchpost.org
Hi,

I'd prefer to change the subject to "gnu: vlc: Add MIDI support.".

Toggle quote (3 lines)
> It would be good to put something in the commit message about why this
> is happening, as it's not obvious to me at least.

I disagree in general because I've seen before what that leads to:
Half the source code (the comments) end up in the commit messages instead.
Eventually (because of some merge or something) those get lost, or
(because of a new commit) those get hidden.
Now someone is going to overlook it.

So I'd put documentation into comments, except when it's ephemeral ("news").

Also, in the special case of Guix the reason why we add an input later is
"we forgot to add it earlier and it was optional to the package and thus the
package built" most of the time. So the commit message would always be
"we forgot earlier".

In this case, vlc got MIDI support with vlc 0.9.0 (long ago) and nobody
noticed.

We could have the subject say "Add MIDI support" because it communicates more
clearly what this commit does for users. And that's the news :)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl4sJtMACgkQ5xo1VCww
uqW6kgf+N9sb5cn0u0bbHONcvsSF8EDZsCFubO2yiQFvQ6TnV2WxWZEOOlI8LuNH
Zuwhg3sFDarX9lp2ol3ZMb/rTrmKR7STm3NRFW4bZeVp8kQYxAt7VW5kl29oRR+n
U77/9rNpyeOd0OOcfG6+6suumMWC2VSlw3DbjtcGrwFxJX0n+Z9y8EPn8/WqXW3p
q82laSqg9X/z8e4FT17e8XQJJkBhPSzcEeT/R0ykxc02SDDVSal53EoRNoIuJZqJ
5/n/S7SXbtxU1DkEUHuDA/eajZZpif9pJIq/xy+sGHOSJ2vJqgpGQ26P7TEJCZ9p
IPXYWDMUpMMTG0VOd/OCqyV85SZngg==
=Nvop
-----END PGP SIGNATURE-----


C
C
Christopher Baines wrote on 26 Jan 2020 11:23
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87r1zmikj6.fsf@cbaines.net
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (13 lines)
> Hi,
>
> I'd prefer to change the subject to "gnu: vlc: Add MIDI support.".
>
>> It would be good to put something in the commit message about why this
>> is happening, as it's not obvious to me at least.
>
> I disagree in general because I've seen before what that leads to:
> Half the source code (the comments) end up in the commit messages instead.
> Eventually (because of some merge or something) those get lost, or
> (because of a new commit) those get hidden.
> Now someone is going to overlook it.

I'm not suggesting documenting code in commit messages, just saying
something about the motivation/intention with the change is useful. The
message you suggest meets this criteria perfectly.

Toggle quote (7 lines)
> So I'd put documentation into comments, except when it's ephemeral ("news").
>
> Also, in the special case of Guix the reason why we add an input later is
> "we forgot to add it earlier and it was optional to the package and thus the
> package built" most of the time. So the commit message would always be
> "we forgot earlier".

So I would say that "we forgot earlier" isn't a motivation, or
descriptive of intent (although maybe it meets the "why this is
happening" I mentioned earlier, but that was maybe poorly explained)..

Toggle quote (6 lines)
> In this case, vlc got MIDI support with vlc 0.9.0 (long ago) and nobody
> noticed.
>
> We could have the subject say "Add MIDI support" because it communicates more
> clearly what this commit does for users. And that's the news :)

Yeah, I think that's good. At least in the context I was looking at
this, trying to review the change, knowing what the intent is allows me
to check if that's been satisfied (trying to play some MIDI content with
VLC before and after).

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl4taI1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdIXA/8DFwiy59RysatwCaD7WUTjwtjcmL50rvaGt4mD+hoxK7RuxJY/9zWEJ8M
ArkgrBby4JeTiV9m5gsu3WSSF/f6mVr6W3lSPsQGLIFL8/5Xs3ZLvIrulM6Lua0c
Q6WnLZtQqaf4Um+5NsVxEUkP+ZgNLawLfwGsCBd52TpBEJXEakx3bw8f2uVt7yFR
lgkdljrRP+DjhbS55ZkJYCqFwH5rA4ohHz8NccjTihdI4vuVhJqSogt/4yLvJgHG
tVzmc1QUG1fecdTgwj04oZ9ntPR83516Ow79Y+9vJ6P+chb0obGgV3eDXUFegQ3o
OvlgpfkvER/seY5CWqrC67MilTG+kD2ANDr1YYLiUithd3szm0ooelD+0jkk12tq
WrZ/Jbp1RhfMuE14jskGst/V17+jzOUeTfjFXATJ76LsOVWY3xzU0EAr74VQsitD
75YQDIFTtENmDHic+wrqqiW/dELC6UGamct38kCJZEzLutU3VbxuOP1VjUuY3pxy
K3Xgesz8HYYURx7tSEvVau+wxT1JOfqalkgkk+v9ND/qviNw59poS6eO99G67b0M
OnxBQV7itLrAPSqhgynIjRvF2pC/05kfe8lNxEr96kB/ddAt55g5GcBVQknpltxz
hFw2T6aY0soDCxlDyYxBVlkP7JdPJSqUQzh79rl9cvgksCIGwg8=
=QQ0Q
-----END PGP SIGNATURE-----

J
J
Jesse Gibbons wrote on 27 Jan 2020 01:56
(address . 39275@debbugs.gnu.org)
999e82b162db35d396932eb2c1d5a20f68c00959.camel@gmail.com
On Sun, 2020-01-26 at 10:23 +0000, Christopher Baines wrote:
Toggle quote (56 lines)
> Error verifying signature: Failed to execute gpg.
> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
> > Hi,
> >
> > I'd prefer to change the subject to "gnu: vlc: Add MIDI support.".
> >
> > > It would be good to put something in the commit message about why
> > > this
> > > is happening, as it's not obvious to me at least.
> >
> > I disagree in general because I've seen before what that leads to:
> > Half the source code (the comments) end up in the commit messages
> > instead.
> > Eventually (because of some merge or something) those get lost, or
> > (because of a new commit) those get hidden.
> > Now someone is going to overlook it.
>
> I'm not suggesting documenting code in commit messages, just saying
> something about the motivation/intention with the change is useful.
> The
> message you suggest meets this criteria perfectly.
>
> > So I'd put documentation into comments, except when it's ephemeral
> > ("news").
> >
> > Also, in the special case of Guix the reason why we add an input
> > later is
> > "we forgot to add it earlier and it was optional to the package and
> > thus the
> > package built" most of the time. So the commit message would
> > always be
> > "we forgot earlier".
>
> So I would say that "we forgot earlier" isn't a motivation, or
> descriptive of intent (although maybe it meets the "why this is
> happening" I mentioned earlier, but that was maybe poorly
> explained)..
>
> > In this case, vlc got MIDI support with vlc 0.9.0 (long ago) and
> > nobody
> > noticed.
> >
> > We could have the subject say "Add MIDI support" because it
> > communicates more
> > clearly what this commit does for users. And that's the news :)
>
> Yeah, I think that's good. At least in the context I was looking at
> this, trying to review the change, knowing what the intent is allows
> me
> to check if that's been satisfied (trying to play some MIDI content
> with
> VLC before and after).
>
> Chris

Sorry for not explaining the intention. Do you want me to send a new
patch mentioning the added MIDI support? Should I put that in the
commit title, or in a comment?
C
C
Christopher Baines wrote on 27 Jan 2020 09:09
(name . Jesse Gibbons)(address . jgibbons2357@gmail.com)
87o8upialv.fsf@cbaines.net
Jesse Gibbons <jgibbons2357@gmail.com> writes:

Toggle quote (61 lines)
> On Sun, 2020-01-26 at 10:23 +0000, Christopher Baines wrote:
>> Error verifying signature: Failed to execute gpg.
>> Danny Milosavljevic <dannym@scratchpost.org> writes:
>>
>> > Hi,
>> >
>> > I'd prefer to change the subject to "gnu: vlc: Add MIDI support.".
>> >
>> > > It would be good to put something in the commit message about why
>> > > this
>> > > is happening, as it's not obvious to me at least.
>> >
>> > I disagree in general because I've seen before what that leads to:
>> > Half the source code (the comments) end up in the commit messages
>> > instead.
>> > Eventually (because of some merge or something) those get lost, or
>> > (because of a new commit) those get hidden.
>> > Now someone is going to overlook it.
>>
>> I'm not suggesting documenting code in commit messages, just saying
>> something about the motivation/intention with the change is useful.
>> The
>> message you suggest meets this criteria perfectly.
>>
>> > So I'd put documentation into comments, except when it's ephemeral
>> > ("news").
>> >
>> > Also, in the special case of Guix the reason why we add an input
>> > later is
>> > "we forgot to add it earlier and it was optional to the package and
>> > thus the
>> > package built" most of the time. So the commit message would
>> > always be
>> > "we forgot earlier".
>>
>> So I would say that "we forgot earlier" isn't a motivation, or
>> descriptive of intent (although maybe it meets the "why this is
>> happening" I mentioned earlier, but that was maybe poorly
>> explained)..
>>
>> > In this case, vlc got MIDI support with vlc 0.9.0 (long ago) and
>> > nobody
>> > noticed.
>> >
>> > We could have the subject say "Add MIDI support" because it
>> > communicates more
>> > clearly what this commit does for users. And that's the news :)
>>
>> Yeah, I think that's good. At least in the context I was looking at
>> this, trying to review the change, knowing what the intent is allows
>> me
>> to check if that's been satisfied (trying to play some MIDI content
>> with
>> VLC before and after).
>>
>> Chris
>
> Sorry for not explaining the intention. Do you want me to send a new
> patch mentioning the added MIDI support? Should I put that in the
> commit title, or in a comment?

Sending a new patch would be great. Adding something anywhere in the
commit message is fine by me.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKSBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl4umsxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xe6Vw/3UBcW3H6i1pLsnSrmqUYyJqcPi4cYF4RoI+MytogkvoWNAdocSyFwS26V
/d486+3WVgTH+iBQjAeFGBBOWk4qaHPqhxbo5ri+xrrlcKH3G4Qm4t4okMai1Y4I
uRcTAQ8ktZzOf0/f7p0pxopTBgf4Hh2no7N8Qa59jRieWc8QDzRr2sC/DPiyC9QE
0iurU4zJGG2NjHx5tUDt/5zuAlhR9HO74ZZHBQx7QPAoafmqJSAhex9pClMYjkEV
irRJCKeI+ylbi+uXtg9LN9yX8HbG6TcFhgSRWp8FFva4i+bV737BQXlcE0sm7p87
5F7cUvE/c2BbbngTqpQ0mxmmz80C1iLvjHUS2iJTjsYXd4k7D5MwnyRIvEKh63Vp
VQPSV0jq0WAwmdXOB816nTjejUZWwBQyJ1y3w4wM2bH2Oc1g0gCNpFhg7pka/Ewk
4yfSQB2OcN927XMRYniKZU5lQ1GdHY8iNO8IQVtFiMDthACMOqqNCYlJjT2pdWW6
PvzXC2ZxWd2ihdPlGZ0CNqHu6BsFkGqUEqanOKBib4mW4NqqobClB7G0qBlA2clr
niGGbdct+W/GoaYocnN7cplW6B5cQmjrszRIDUPm6uYqYt1+U1vV994Oh2gxiPqV
IMv1sK7RW+ksgHV+R88dbv92ByVx7aYJMfQoENlLLycjzqO8NQ==
=yV0R
-----END PGP SIGNATURE-----

?