[PATCH] gnu: Add megacmd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jakub K?dzio?ka
  • Christopher Baines
Owner
unassigned
Submitted by
Jakub K?dzio?ka
Severity
normal
J
J
Jakub K?dzio?ka wrote on 22 Jan 2020 18:47
(address . guix-patches@gnu.org)
20200122174732.k33gbrcru7y43pgp@zdrowyportier.kadziolka.net
* gnu/packages/crypto.scm (megacmd): New variable.
---
gnu/packages/crypto.scm | 47 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 61fa228b9a..cf7cbf44df 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -34,6 +34,7 @@
(define-module (gnu packages crypto)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages adns)
#:use-module (gnu packages aidc)
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
@@ -41,6 +42,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cryptsetup)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages image)
@@ -51,6 +53,7 @@
#:use-module (gnu packages lsof)
#:use-module (gnu packages nettle)
#:use-module (gnu packages password-utils)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
@@ -1009,6 +1012,50 @@ quickly by using all your CPU cores and hardware acceleration.")
(home-page "https://github.com/vstakhov/hpenc")
(license license:bsd-3)))
+(define-public megacmd
+ (package
+ (name "megacmd")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/meganz/MEGAcmd.git")
+ (commit (string-append version "_Linux"))
+ (recursive? #t)))
+ (sha256
+ (base32
+ "004j8m3xs6slx03g2g6wzr97myl2v3zc09wxnfar5c62a625pd53"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ ;; XXX: Disabling tests because they depend on libgtest.la from googletest,
+ ;; which is not installed for unclear reasons.
+ (arguments
+ `(#:tests? #f
+ #:configure-flags '("--with-pcre")))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("c-ares" ,c-ares)
+ ("crypto++" ,crypto++)
+ ("curl" ,curl)
+ ("freeimage" ,freeimage)
+ ("gtest" ,googletest)
+ ("openssl" ,openssl)
+ ("pcre" ,pcre)
+ ("readline" ,readline)
+ ("sodium" ,libsodium)
+ ("sqlite3" ,sqlite)
+ ("zlib" ,zlib)))
+ (home-page "https://mega.nz/cmd")
+ (synopsis "Command Line Interactive and Scriptable Application to access mega.nz")
+ (description "MEGAcmd provides non UI access to MEGA services. It intends to offer all the
+functionality of a MEGA account via commands. It features synchronization, backup of local folders
+into a MEGA account and a webdav/streaming server.")
+ (license '(license:bsd-2 license:gpl3+))))
+
(define-public minisign
(package
(name "minisign")
--
2.25.0
J
J
Jakub K?dzio?ka wrote on 23 Jan 2020 16:20
[PATCH 2/2] gnu: Add megatools.
(address . 39240@debbugs.gnu.org)
20200123152000.o6agvumjmosm6p3n@zdrowyportier.kadziolka.net
* gnu/packages/crypto.scm (megatools): New variable.
(megacmd)[description]: Cross-reference the two packages in the description.
(megacmd)[license]: Use a more syntax form for multiple licenses.
---
Note: sending this to the same bug as the packages are related and would
ideally reference each other in their descriptions, which makes merging
the patches interdependent.

I am updating the license field here, as suggested by guix lint - I
somehow forgot to run it before. I added the possibility of creating a
pre-commit hook for this to my TODO.

[this note shouldn't interfere with git am]
---
gnu/packages/crypto.scm | 49 +++++++++++++++++++++++++++++++++++++----
1 file changed, 45 insertions(+), 4 deletions(-)

Toggle diff (70 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index cf7cbf44df..64c824a082 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -43,7 +43,9 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages cryptsetup)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages image)
#:use-module (gnu packages kerberos)
@@ -1051,10 +1053,49 @@ quickly by using all your CPU cores and hardware acceleration.")
("zlib" ,zlib)))
(home-page "https://mega.nz/cmd")
(synopsis "Command Line Interactive and Scriptable Application to access mega.nz")
- (description "MEGAcmd provides non UI access to MEGA services. It intends to offer all the
-functionality of a MEGA account via commands. It features synchronization, backup of local folders
-into a MEGA account and a webdav/streaming server.")
- (license '(license:bsd-2 license:gpl3+))))
+ (description "MEGAcmd provides non UI access to MEGA services. It intends to offer
+all the functionality of a MEGA account via commands. It features synchronization, backup
+of local folders into a MEGA account and a webdav/streaming server.
+
+See also: megatools, a third-party alternative more commonly packaged in other
+distributions.")
+ (license (list license:bsd-2 license:gpl3+))))
+
+(define-public megatools
+ (package
+ (name "megatools")
+ (version "1.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://megatools.megous.com/builds/megatools-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12n32w5mqvpk0hvh9yg9qkj9i0g2wp7jp9rq28bnqs94iv3897hp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ;; For documentation
+ ("asciidoc" ,asciidoc)))
+ (inputs
+ `(("curl" ,curl)
+ ("glib" ,glib)
+ ("openssl" ,openssl)))
+ (home-page "https://megatools.megous.com/")
+ (synopsis "Command line client application for mega.nz")
+ (description "Megatools is a collection of programs for accessing the mega.nz service
+from the command line.
+
+Megatools allow you to copy individual files as well as entire directory trees to and from
+the cloud. You can also perform streaming downloads for example to preview videos and
+audio files, without needing to download the entire file first.
+
+Megatools are robust and optimized for fast operation - as fast as Mega servers allow.
+Memory requirements and CPU utilization are kept at minimum.
+
+See also: megacmd, the official tool set by MEGA.")
+ (license license:gpl2)))
(define-public minisign
(package
--
2.25.0
C
C
Christopher Baines wrote on 24 Jan 2020 22:35
(address . kuba@kadziolka.net)(address . 39240-done@debbugs.gnu.org)
87ftg4pmfo.fsf@cbaines.net
Jakub K?dzio?ka <kuba@kadziolka.net> writes:

Toggle quote (14 lines)
> * gnu/packages/crypto.scm (megatools): New variable.
> (megacmd)[description]: Cross-reference the two packages in the description.
> (megacmd)[license]: Use a more syntax form for multiple licenses.
> ---
> Note: sending this to the same bug as the packages are related and would
> ideally reference each other in their descriptions, which makes merging
> the patches interdependent.
>
> I am updating the license field here, as suggested by guix lint - I
> somehow forgot to run it before. I added the possibility of creating a
> pre-commit hook for this to my TODO.
>
> [this note shouldn't interfere with git am]

Hi Jakub,

I've pushed both these patches to master now, they're included in [1].

1: 3e67182fb1b928a695718441124bec14a86ec7be

Given you introduced the issue with the license field in the previous
patch, I fixed it there and adjusted the second patch accordingly.

Additionally, I moved these packages to the sync module, rather than the
crypto one, as that seemed a better fit.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl4rYytfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XeF3g//biWarBXPswAsYloJZjf856Cl6i4QZnMP3qNvygtMcWCcYiYgUCMO1pcn
1ZcUseAUnczo4fM2sE1RC3GKHPU+pTdXoG1IxYlRC8ZLaYg9BGAasTz8IEbzXGef
JAUFtpmwQh6O1+0qMziwtWYWGovaMfvYlf+6iSQ9OI8G44WTv2lul80CQfGKnRKj
G5UVXjwuHonJdfBi84wvUJ5NG34oNuqAuNWx5COcQIN7/JrCDhQ9D3/xkXYjOcKP
tCcERnQg7nWK0QrJ6aWgE5cTDgaFRSwCpgxrTVjk+eraAVq4hG5kes7VNw7gcXEO
CcHctfXtT6SQbk7QIIxy5aeA7romjtcqJGzf6KO6Q9Wy8X07H/USb4wOICBMj6ih
NJi4bxyUK8Ry6WUnrbdZUOg/g6wj2wEllBsjj+i7+ayaKkdPe2T1lZ7T1JGgE3Xy
UlOBdFD2+g/qhIy2ASlgz11U2eB+gnVa9DQqILSeBbFG8Q70y1NdziZr3rIRf38l
qTnq2LkVcluWMjfjN8sDQoEgStB/FfbioDaYgJ3DcQeFPg+cSykd4/qBkDLsOtd2
RCCzVEhx9YayKi9GoROWOnnNkSH0MGB3ouRch4tcyjYaCbcdMG/IY3cI6AP1n9GJ
P67zc2iDzIAwZxbkWCPgGOr4VfvFI9lPVmK1nKIF6/HOKC5N7Cw=
=cWUp
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39240@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39240
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch