[PATCH 0/2] Update ruby-sassc and ruby-sqlite3.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
87v9pbox9f.fsf@cbaines.net
Christopher Baines (2):
gnu: ruby-sassc: Update to 2.2.1.
gnu: ruby-sqlite3: Update to 1.4.2.

gnu/packages/ruby.scm | 29 ++++++++++++++++++++---------
1 file changed, 20 insertions(+), 9 deletions(-)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl4g4pxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfDZQ//TXIRi2Bu0seAnKWypX/GoOMorUfUkIZdccKb0L79y7XDHV3guZQuE7Hv
ReR4RI+eUXVp9dhD7OmYhRofKf6+3R/xE+o6FAvIXkdn5wRu01SNw0L5i31qCFmY
EoMxTiKlPZnytJW8YRQo2wyOAzqBCKFQiUmGU/bzwsVhgvWyzlchw7w7D0UBuyCB
48BT87FdG6ceC3VqELUaONb2reEU6l+GYZjFUJ7UfFBFJ0EIO1CQMwy/eUfpJZP/
Nvd0LvGLureWTpI0c6fxGZivcBqlwL0nmyqhyGNglSqEm3Yi/sHRNWfR3XJndg9d
tSnLXQ7+sLvrnTuiOKmhVvRyTzz4rnQbLQ41fcik5TxRMILIEa73m8s84cxOxra0
vxK9mVjrXRfSR+5I6PZ3T3dZC6GgvG6xxmA5wLPQjPseAuVBKXOtZjL/IFlcEVBW
TuO0bsJ3p3s7qm3XJLMiR5Q9Mncr3ozH7ZVOLLTKLBHRwSkSw8OBdBVUNiiGBzT6
TzX2X/s7xCx2tkzkGIn2seKsbBWpz9A7qlRXiybJniSozc2xal1QvKEsg9DjIvK+
Fr3BxbKq97TGyXLMZXZyyxCD7z8WgID2wDkNMloHHlU/mlg/yLyy97XOmNhQvM/x
S8BTJ2Hs/4DYoL038M4+sK8UHkhgP3WNa3CfbISiEDfauHnu88A=
=s+eY
-----END PGP SIGNATURE-----

Christopher Baines wrote 5 years ago
[PATCH 1/2] gnu: ruby-sassc: Update to 2.2.1.
(address . 39157@debbugs.gnu.org)
20200116222840.12308-1-mail@cbaines.net
* gnu/packages/ruby.scm (ruby-sassc): Update to 2.2.1.
[arguments]: Fix using the included libsass copy.
[native-inputs]: Add ruby-rake-compiler.
---
gnu/packages/ruby.scm | 25 ++++++++++++++++++-------
1 file changed, 18 insertions(+), 7 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ad675dc488..bc4752ba29 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7764,23 +7764,34 @@ features that don't exist yet like variables, nesting, mixins and inheritance.")
(define-public ruby-sassc
(package
(name "ruby-sassc")
- (version "2.0.1")
+ (version "2.2.1")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "sassc" version))
(sha256
(base32
- "1sr4825rlwsrl7xrsm0sgalcpf5zgp4i56dbi3qxfa9lhs8r6zh4"))))
+ "09bnid7r5z5hcin5hykvpvv8xig27wbbckxwis60z2aaxq4j9siz"))))
(build-system ruby-build-system)
(arguments
- '(#:phases
+ '(#:modules ((guix build ruby-build-system)
+ (guix build utils)
+ (ice-9 textual-ports))
+ #:phases
(modify-phases %standard-phases
;; TODO: This would be better as a snippet, but the ruby-build-system
;; doesn't seem to support that
(add-after 'unpack 'remove-libsass
(lambda _
(delete-file-recursively "ext")
+ (with-atomic-file-replacement "sassc.gemspec"
+ (lambda (in out)
+ (let* ((gemspec (get-string-all in))
+ (index (string-contains gemspec "libsass_dir")))
+ (display (string-append
+ (string-take gemspec index)
+ "\nend\n")
+ out))))
#t))
(add-after 'unpack 'dont-check-the-libsass-version
(lambda _
@@ -7790,18 +7801,17 @@ features that don't exist yet like variables, nesting, mixins and inheritance.")
(add-after 'unpack 'remove-git-from-gemspec
(lambda _
(substitute* "sassc.gemspec"
- (("`git ls-files -z`") "`find . -type f -print0 |sort -z`")
- (("`git submodule --quiet foreach pwd`") "''"))
+ (("`git ls-files -z`") "`find . -type f -print0 |sort -z`"))
#t))
(add-after 'unpack 'remove-extensions-from-gemspec
(lambda _
(substitute* "sassc.gemspec"
- (("\\[\"ext/Rakefile\"\\]") "[]"))
+ (("\\[\"ext/extconf.rb\"\\]") "[]"))
#t))
(add-after 'unpack 'fix-Rakefile
(lambda _
(substitute* "Rakefile"
- (("test: 'libsass:compile'") ":test"))
+ (("test: 'compile:libsass'") ":test"))
#t))
(add-after 'unpack 'remove-unnecessary-dependencies
(lambda _
@@ -7826,6 +7836,7 @@ features that don't exist yet like variables, nesting, mixins and inheritance.")
`(("libsass" ,libsass)))
(native-inputs
`(("bundler" ,bundler)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)
("ruby-minitest-around" ,ruby-minitest-around)
("ruby-test-construct" ,ruby-test-construct)))
(synopsis "Use libsss from Ruby")
--
2.24.1
Christopher Baines wrote 5 years ago
[PATCH 2/2] gnu: ruby-sqlite3: Update to 1.4.2.
(address . 39157@debbugs.gnu.org)
20200116222840.12308-2-mail@cbaines.net
* gnu/packages/ruby.scm (ruby-sqlite3): Update to 1.4.2.
---
gnu/packages/ruby.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index bc4752ba29..5505a50d37 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6076,14 +6076,14 @@ neither too verbose nor too minimal.")
(define-public ruby-sqlite3
(package
(name "ruby-sqlite3")
- (version "1.3.13")
+ (version "1.4.2")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "sqlite3" version))
(sha256
(base32
- "01ifzp8nwzqppda419c9wcvr8n82ysmisrs0hph9pdmv1lpa4f5i"))))
+ "0lja01cp9xd5m6vmx99zwn4r7s97r1w5cb76gqd8xhbm1wxyzf78"))))
(build-system ruby-build-system)
(arguments
`(#:phases
--
2.24.1
Christopher Baines wrote 5 years ago
Re: [bug#39157] [PATCH 0/2] Update ruby-sassc and ruby-sqlite3.
(address . 39157-done@debbugs.gnu.org)
87y2tphvfe.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (7 lines)
> Christopher Baines (2):
> gnu: ruby-sassc: Update to 2.2.1.
> gnu: ruby-sqlite3: Update to 1.4.2.
>
> gnu/packages/ruby.scm | 29 ++++++++++++++++++++---------
> 1 file changed, 20 insertions(+), 9 deletions(-)

I've pushed these as e7cdba61cf67abb5844c342a7614b9cd871c7a8d.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl4y56VfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfreBAAtMajoxJZG+GQ5FhPviBRvcadX86VOfyyhZB7gSOg/8dlGUJd3A67pcE9
SfvLuQaKrFn5IH+P21QPkfSRvdlhmCgLact5tyPfOsnYu+sphkUhbyhzjDWDtSgu
DuNhvgVCJlBhtbUmBYDqLhwWPE0tDqw4XBpUxUb571O2TUhox3TXzbbMQOOOCpHO
siDmuumrc4fD6K81rh3KekjHc0I8wq1FeoJk8c24CDIw6G/1rDdNAAVfxbh7KbIN
0CRwhDRqO4Qf1SX+8QR1BEt5h6+zrC8qEhWCvU+EGIUu2qT8RytRL8S9iOD91lZF
oT6+MWxAmlcFoDy8gs4UhdaWi4gRvpqZeftlfcz0Y014845SL/7NFN5LFkGkuKaj
TDHNcfHocVw/70CCg3YGD4hUCvCBQtb5STLMufr/eyb5gJ+CcXPulupsRTagP6MW
mHYtwkpHHIf+4rXurReACuIxNCv6lVrJn6S+QZu5lU22FGDW0Ntclv1AY/Daf+pc
ZtpK0goAJhIUAuKiMeLulTtQ2OdCBiSdT0IsprfYlAAONsllbCjngnnGGC0L5VIa
c6b/LMVyZ8EcYaBamXCGXAZjHuuXzyyv28NG43yGp9X4mgWzyMGnv/t4t9jWul4e
rjaPZr+7pCpT4y2zjKvNipYOhp5MgKUc1p+51ARClzDa9d/4xJQ=
=Ezhw
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39157@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39157
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help