[PATCH] gnu: Add gst-editing-services.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Marius Bakke
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
20200112234026.12266-1-leo.prikler@student.tugraz.at
* gnu/packages/gstreamer (gst-editing-services): New variable.
---
gnu/packages/gstreamer.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 323e3ccfee..14dbf5a7ed 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -419,6 +419,37 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
compression formats through the use of the libav library.")
(license license:gpl2+)))
+(define-public gst-editing-services
+ (package
+ (name "gst-editing-services")
+ (version "1.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gstreamer.freedesktop.org/src/" name "/"
+ "gstreamer-editing-services-" version ".tar.xz"))
+ (sha256
+ (base32
+ "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; TODO: 16/22 failing tests with meson, 21 with gnu
+ `(#:tests? #f))
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("flex" ,flex)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "https://gstreamer.freedesktop.org/")
+ (synopsis "GStreamer library for non-linear editors")
+ (description
+ "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+ (license license:gpl2+)))
+
(define-public python-gst
(package
(name "python-gst")
--
2.24.1
Marius Bakke wrote 5 years ago
874kwzvuq5.fsf@devup.no
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (2 lines)
> * gnu/packages/gstreamer (gst-editing-services): New variable.

Thanks!

[...]
Toggle quote (14 lines)
> +(define-public gst-editing-services
> + (package
> + (name "gst-editing-services")
> + (version "1.16.2")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://gstreamer.freedesktop.org/src/" name "/"
> + "gstreamer-editing-services-" version ".tar.xz"))
> + (sha256
> + (base32
> + "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
> + (build-system gnu-build-system)

IIRC gstreamer will no longer support gnu-build-system starting with
1.18. So let's just go straight for Meson here, WDYT?

If you're up for it, it would be good to change the other gstreamer
packages already as well, to make the transition easier.

Toggle quote (4 lines)
> + (arguments
> + ;; TODO: 16/22 failing tests with meson, 21 with gnu
> + `(#:tests? #f))

When so many tests are failing, it is typically a sign that a dependency
or file is missing, e.g. execve("/bin/sh" ...) somewhere. Can you try
to figure out what is causing these failures?

Otherwise LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl4c87IACgkQoqBt8qM6
VPrOzAgAnzonwAH4ewazQBK09VByTxpLk7eEY2nGcd/A+loxHBuQrgVDI/oVRFMG
tNwD0NVyYIJMI3WdObKtP3UK/uE7YWS+zK6MPnqEG34Vd53fjOcs2OjMcI1OR/z5
4H1Ug1u9/PBg5CgTygDVHJJABZpvqxkFdzt8GqtwKdlIhXyTYuokiYQhQeFSxe36
BJT1l6J3fpATLwuyiUTlTbjvRSbaxSguFmzfZOWwTL2K4h44ZUsbap+HW8f3GolC
/t7Xulu1UvfU2ECTejwaAA4JToBVfqxTJmAnJNcdYaawkIQyxDEuAUKTv88kEn4o
r2woJrFU4tYLPuhFk433AIa1omcLyQ==
=BOiP
-----END PGP SIGNATURE-----

Leo Prikler wrote 5 years ago
1dd8b61e8e1435a1e1cd214e30b70f500cf9def5.camel@student.tugraz.at
Am Montag, den 13.01.2020, 23:48 +0100 schrieb Marius Bakke:
Toggle quote (27 lines)
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
>
> > * gnu/packages/gstreamer (gst-editing-services): New variable.
>
> Thanks!
>
> [...]
>
> > +(define-public gst-editing-services
> > + (package
> > + (name "gst-editing-services")
> > + (version "1.16.2")
> > + (source (origin
> > + (method url-fetch)
> > + (uri (string-append
> > + "https://gstreamer.freedesktop.org/src/" name
> > "/"
> > + "gstreamer-editing-services-" version
> > ".tar.xz"))
> > + (sha256
> > + (base32
> > + "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc
> > 1hf"))))
> > + (build-system gnu-build-system)
>
> IIRC gstreamer will no longer support gnu-build-system starting with
> 1.18. So let's just go straight for Meson here, WDYT?
Sure, why not? It would at least build, though I've "tested" only the
gnu version in terms of actual editing capabilities (some lightweight
clip mixing).

Toggle quote (12 lines)
> If you're up for it, it would be good to change the other gstreamer
> packages already as well, to make the transition easier.
>
> > + (arguments
> > + ;; TODO: 16/22 failing tests with meson, 21 with gnu
> > + `(#:tests? #f))
>
> When so many tests are failing, it is typically a sign that a
> dependency
> or file is missing, e.g. execve("/bin/sh" ...) somewhere. Can you
> try
> to figure out what is causing these failures?
Not easily, sadly. Gstreamer 1.16.2 broke for me in some quite
interesting ways, even outside of packaging, and I have little trust in
my ability to fix it – other than applying some kind of workaround for
my personal use. (See 39126 for details.)
From what I recall, most of the failing tests are not even failing,
they are erroring, outputting some critical message and a stack trace.
The problem here is, that you get get critical errors if even just one
element inside a large pipeline behaves badly. Of course, you can get
the same kind of error, but with a different message, if the plugin
can't even be found.

As far as building gstreamer with meson is concerned, I can look into
it, but the gstreamer package itself has 400 dependants and thus
belongs to staging. I'm not quite sure whether we can get
implementation + reviews done before the 19th, but let's see what's
possible.

Regards,
Leo
Leo Prikler wrote 5 years ago
d72c4bd8a24ce4532a040003f8300231bda204d6.camel@student.tugraz.at
I composed a patch in which all of the basic gstreamer stuff (sans
python bindings) are ported to meson. Perhaps someone might want this
patch to be split, so that each package is modified separately, but I
find that we can treat this as a logical unit as-is.

Of particular note is the disabling of the doc output. It appears as
if gstreamer really does not know how to build documentation in meson
without the not-yet packaged hotdoc. However, with there being fewer
dependencies on the plugins rather than gstreamer itself, it should be
possible to port them later.

Finally, I've noticed that gst-plugins-base builds without gl or
wayland support. Should I add a patch for this or is it fine as-is?

Regards,
Leo
Leo Prikler wrote 5 years ago
02823ea592a1cec21c0de7cc7efc1256bc7add09.camel@student.tugraz.at
I've noticed, that staging gstreamer builds with meson now, resolving
this part of the discussion. I've also noticed some cosmetic errors in
my initial patch, so I'm sending updated versions, one for master and
one for staging (only offsets appear to differ), so that the patch
keeps working after an eventual merge.

Regards,
Leo
From 79985310b62219e93ffcc033cddaa6921ceb5182 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 12 Jan 2020 18:42:24 +0100
Subject: [PATCH] gnu: Add gst-editing-services.

* gnu/packages/gstreamer.scm (gst-editing-services): New variable.
---
gnu/packages/gstreamer.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 63b4179..151d222 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -426,6 +426,37 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
compression formats through the use of the libav library.")
(license license:gpl2+)))
+(define-public gst-editing-services
+ (package
+ (name "gst-editing-services")
+ (version "1.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gstreamer.freedesktop.org/src/" name "/"
+ "gstreamer-editing-services-" version ".tar.xz"))
+ (sha256
+ (base32
+ "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; TODO: 16/22 failing tests with meson, 21 with gnu
+ `(#:tests? #f))
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("flex" ,flex)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "https://gstreamer.freedesktop.org/")
+ (synopsis "GStreamer library for non-linear editors")
+ (description
+ "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+ (license license:gpl2+)))
+
(define-public python-gst
(package
(name "python-gst")
--
libgit2 0.28.4
From 76daab1a0085ef5950cde543e6b41f0559d469c2 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 12 Jan 2020 18:42:24 +0100
Subject: [PATCH] gnu: Add gst-editing-services.

* gnu/packages/gstreamer.scm (gst-editing-services): New variable.
---
gnu/packages/gstreamer.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 1e26a3c..85f822d 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -476,6 +476,37 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
compression formats through the use of the libav library.")
(license license:gpl2+)))
+(define-public gst-editing-services
+ (package
+ (name "gst-editing-services")
+ (version "1.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gstreamer.freedesktop.org/src/" name "/"
+ "gstreamer-editing-services-" version ".tar.xz"))
+ (sha256
+ (base32
+ "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; TODO: 16/22 failing tests with meson, 21 with gnu
+ `(#:tests? #f))
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("flex" ,flex)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "https://gstreamer.freedesktop.org/")
+ (synopsis "GStreamer library for non-linear editors")
+ (description
+ "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+ (license license:gpl2+)))
+
(define-public python-gst
(package
(name "python-gst")
--
libgit2 0.28.4
Leo Prikler wrote 5 years ago
e821e0931cdfbdb5787cf554c398f73cd11b67c7.camel@student.tugraz.at
Am Donnerstag, den 23.01.2020, 13:31 +0100 schrieb Leo Prikler:
Toggle quote (6 lines)
> I've noticed, that staging gstreamer builds with meson now, resolving
> this part of the discussion. I've also noticed some cosmetic errors
> in
> my initial patch, so I'm sending updated versions, one for master and
> one for staging (only offsets appear to differ), so that the patch
> keeps working after an eventual merge.
Just ensuring this is not forgotten. Since staging is merged now, the
staging patch is the one to apply.
Marius Bakke wrote 5 years ago
878sl588jt.fsf@devup.no
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (6 lines)
> I've noticed, that staging gstreamer builds with meson now, resolving
> this part of the discussion. I've also noticed some cosmetic errors in
> my initial patch, so I'm sending updated versions, one for master and
> one for staging (only offsets appear to differ), so that the patch
> keeps working after an eventual merge.

Oh no, I missed that you had alredy ported GStreamer to the Meson build
system in a previous email! Sorry for the duplicate work.

I notice in this patch that gst-editing-services still uses
gnu-build-system, can you update it to use meson-build-system instead?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl5Gw7YACgkQoqBt8qM6
VPq2HQgAp+BHNdlhEos2RubPXBpRvWktuUPbUH2WqDCwLiVxq1vyFn90GFqJx8qy
dfmRa5ObUd2j3zbuoiroAlLPhS7DGar+gqjDUaQjyI9MpaH2XQfE0W2tWWY8UrV9
Ct72CPZG6uqNJUu7urLjsclpXBhts9GG8UJ8J3+v1dd9DWyjCM4Zww++v2tWIPMj
dP1gDzHFCne7lclmW32CxLXCasQMJwZKkElZEuRsPkPbdD9PmqtLx0te09Rve4Lm
gdYV62I95m5Y2VKwvqTXYm1Hc8pzoZPx04FnORGo1mJ4Z9/q5BVwuYIQt9i2ru61
b13CvESkVV3FwD7IMYMBbWokf6VUMg==
=/0kz
-----END PGP SIGNATURE-----

Leo Prikler wrote 5 years ago
28a17d6a51b46ed190c544de7f357ec7cff44ae9.camel@student.tugraz.at
Am Freitag, den 14.02.2020, 16:58 +0100 schrieb Marius Bakke:
Toggle quote (7 lines)
> Oh no, I missed that you had alredy ported GStreamer to the Meson
> build
> system in a previous email! Sorry for the duplicate work.
>
> I notice in this patch that gst-editing-services still uses
> gnu-build-system, can you update it to use meson-build-system
> instead?
Ahh, my bad. Updated version is attached.
From b4a43af80e52a63919c3697700f80b73e91bfddb Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 12 Jan 2020 18:42:24 +0100
Subject: [PATCH] gnu: Add gst-editing-services.

* gnu/packages/gstreamer.scm (gst-editing-services): New variable.
---
gnu/packages/gstreamer.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 1e26a3c..f33e125 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -476,6 +476,37 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
compression formats through the use of the libav library.")
(license license:gpl2+)))
+(define-public gst-editing-services
+ (package
+ (name "gst-editing-services")
+ (version "1.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gstreamer.freedesktop.org/src/" name "/"
+ "gstreamer-editing-services-" version ".tar.xz"))
+ (sha256
+ (base32
+ "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+ (build-system meson-build-system)
+ (arguments
+ ;; TODO: 16/22 failing tests
+ `(#:tests? #f))
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("flex" ,flex)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "https://gstreamer.freedesktop.org/")
+ (synopsis "GStreamer library for non-linear editors")
+ (description
+ "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+ (license license:gpl2+)))
+
(define-public python-gst
(package
(name "python-gst")
--
libgit2 0.28.4
Marius Bakke wrote 5 years ago
87y2t56tcc.fsf@devup.no
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (10 lines)
> Am Freitag, den 14.02.2020, 16:58 +0100 schrieb Marius Bakke:
>> Oh no, I missed that you had alredy ported GStreamer to the Meson
>> build
>> system in a previous email! Sorry for the duplicate work.
>>
>> I notice in this patch that gst-editing-services still uses
>> gnu-build-system, can you update it to use meson-build-system
>> instead?
> Ahh, my bad. Updated version is attached.

I'm getting a strange build failure with this patch:


...
Dependency gstreamer-plugins-base-1.0 found: YES 1.16.2
Dependency gstreamer-plugins-bad-1.0 found: NO (tried pkgconfig and cmake)

tests/check/meson.build:41:2: ERROR: 'not-found' is not a pkgconfig dependency

A full log can be found at /tmp/guix-build-gst-editing-services-1.16.2.drv-0/build/meson-logs/meson-log.txt

I suppose it needs 'gst-plugins-bad'?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl5GxvQACgkQoqBt8qM6
VPrw1QgAxsNnGTyB7lpPojG0uB6vR4wfPf2r2msaKdjIej61C5aUJB1Z3IrMkR82
LicknraBplFV8ZxD0bGZ7z/D1lL91vWZKQ43oXbLfP2XyGdWcCnvYxEuEMM83hii
pUry/2yMb1aZ0KN7KAHyX8QISTGqd0Bm5b1gCNBa1L301y/yEzdOn39DwYdZlPw0
T5QQUB6YAiCzK13ARp0L7ng2S0DMFzEl9zfnYaVPjRh4RCLhiH6UPCDrJNajgToK
RKUgRJ1oAHrLNnf3zPVn86otDGqpaXlmMCOAMRw3bngyb+oZVv00D1DnWHwMuV7F
exYlLRDPpvIntQre3DbpewfJF52byw==
=/Z8w
-----END PGP SIGNATURE-----

Leo Prikler wrote 5 years ago
e8689402a142c424bfe780402d4accb943fc62f6.camel@student.tugraz.at
Am Freitag, den 14.02.2020, 17:12 +0100 schrieb Marius Bakke:
Toggle quote (15 lines)
> I'm getting a strange build failure with this patch:
>
>
> ...
> Dependency gstreamer-plugins-base-1.0 found: YES 1.16.2
> Dependency gstreamer-plugins-bad-1.0 found: NO (tried pkgconfig and
> cmake)
>
> tests/check/meson.build:41:2: ERROR: 'not-found' is not a pkgconfig
> dependency
>
> A full log can be found at /tmp/guix-build-gst-editing-services-
> 1.16.2.drv-0/build/meson-logs/meson-log.txt
>
> I suppose it needs 'gst-plugins-bad'?
Indeed, it does, though interestingly just for tests, which are
currently broken. I already had this back when I tried meson, but have
since forgot about it. There are no actual references to it, so I've
made it a native input. As far as using it is concerned, I think one
might be able to do without a certain set of plugins depending on the
codecs used. Either way, I'm not really sure whether it should
propagate the main plugin set.

I also added the good plugins even if they are not mentioned, just to
be on the safe side.
From f9a9c7dec9681cf7d5d646df96cbbe19f98e5de2 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 12 Jan 2020 18:42:24 +0100
Subject: [PATCH] gnu: Add gst-editing-services.

* gnu/packages/gstreamer.scm (gst-editing-services): New variable.
---
gnu/packages/gstreamer.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 1e26a3c..0c824e0 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -476,6 +476,39 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
compression formats through the use of the libav library.")
(license license:gpl2+)))
+(define-public gst-editing-services
+ (package
+ (name "gst-editing-services")
+ (version "1.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gstreamer.freedesktop.org/src/" name "/"
+ "gstreamer-editing-services-" version ".tar.xz"))
+ (sha256
+ (base32
+ "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+ (build-system meson-build-system)
+ (arguments
+ ;; TODO: 16/22 failing tests
+ `(#:tests? #f))
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("flex" ,flex)
+ ("gst-plugins-bad" ,gst-plugins-bad)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "https://gstreamer.freedesktop.org/")
+ (synopsis "GStreamer library for non-linear editors")
+ (description
+ "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+ (license license:gpl2+)))
+
(define-public python-gst
(package
(name "python-gst")
--
libgit2 0.28.4
Marius Bakke wrote 5 years ago
87mu9l6rk4.fsf@devup.no
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (27 lines)
> Am Freitag, den 14.02.2020, 17:12 +0100 schrieb Marius Bakke:
>> I'm getting a strange build failure with this patch:
>>
>>
>> ...
>> Dependency gstreamer-plugins-base-1.0 found: YES 1.16.2
>> Dependency gstreamer-plugins-bad-1.0 found: NO (tried pkgconfig and
>> cmake)
>>
>> tests/check/meson.build:41:2: ERROR: 'not-found' is not a pkgconfig
>> dependency
>>
>> A full log can be found at /tmp/guix-build-gst-editing-services-
>> 1.16.2.drv-0/build/meson-logs/meson-log.txt
>>
>> I suppose it needs 'gst-plugins-bad'?
> Indeed, it does, though interestingly just for tests, which are
> currently broken. I already had this back when I tried meson, but have
> since forgot about it. There are no actual references to it, so I've
> made it a native input. As far as using it is concerned, I think one
> might be able to do without a certain set of plugins depending on the
> codecs used. Either way, I'm not really sure whether it should
> propagate the main plugin set.
>
> I also added the good plugins even if they are not mentioned, just to
> be on the safe side.

OK. I changed the TODO to a FIXME and added a copyright line for you.

Pushed in 64fc4f3705423c83c680a95d8dea81a39fce9a70, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl5Gz/sACgkQoqBt8qM6
VPrVpwf8DohluVagW3FbSMEZOjvMN60qbEqMyE8LPBguY3jy2ZqWYFiLEqd8sk+n
NtiK7U6XRVjOvGotaJ6zFXgDpjG69EOZZQ1PGK+mAhKDTJ4WVw9cr37Ks4ZK3BWT
BR2gzlL5mLqoWKjub1O2RdiE/VDasDrVu/pM1gifCxWy73Y8ccLJ3PShxZh/BvKV
32ARMXwuW7Zoy5U2CGQhc9tdfkBvWyp0HRmuB5O145rjl3lJWNkPTL+I3XMqXtQX
hJnwjrLFGZkkn5I0CE9q83V+n3tahXRP/vi9leU2rZ7nqPy7YfCSlkDDwP+26NFC
kOKzsUlYkc0t5qXbrcLfhOJD375AEg==
=BP/R
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39108@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39108
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help