Danny Milosavljevic wrote 5 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* guix/lint.scm (check-inputs-should-be-native): Add autoconf, automake,
bison, dejagnu, desktop-file-utils, doxygen, flex, gettext,
googletest-source, groff, help2man, libtool, swig, qmake, qttools,
texinfo, xorg-server-for-tests.
---
guix/lint.scm | 19 ++++++++++++++++++-
1 file changed, 18 insertions(+), 1 deletion(-)
Toggle diff (42 lines)
diff --git a/guix/lint.scm b/guix/lint.scm
index e3544bd963..4e3aa2f00d 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -286,11 +286,23 @@ of a package, and INPUT-NAMES, a list of package specifications such as
(let ((inputs (package-inputs package))
(input-names
'("pkg-config"
+ "autoconf"
+ "automake"
+ "bison"
"cmake"
+ "dejagnu"
+ "desktop-file-utils"
+ "doxygen"
"extra-cmake-modules"
+ "flex"
+ "gettext"
"glib:bin"
+ "googletest-source"
+ "groff"
+ "help2man"
"intltool"
"itstool"
+ "libtool"
"qttools"
"yasm" "nasm" "fasm"
"python-coverage" "python2-coverage"
@@ -302,7 +314,12 @@ of a package, and INPUT-NAMES, a list of package specifications such as
"python-pytest" "python2-pytest"
"python-pytest-cov" "python2-pytest-cov"
"python-setuptools-scm" "python2-setuptools-scm"
- "python-sphinx" "python2-sphinx")))
+ "python-sphinx" "python2-sphinx"
+ "swig"
+ "qmake"
+ "qttools"
+ "texinfo"
+ "xorg-server-for-tests")))
(map (lambda (input)
(make-warning
package