[PATCH] lint: Check for more packages which should be native.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 5 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20200109153347.5886-1-dannym@scratchpost.org
* guix/lint.scm (check-inputs-should-be-native): Add autoconf, automake,
bison, dejagnu, desktop-file-utils, doxygen, flex, gettext,
googletest-source, groff, help2man, libtool, swig, qmake, qttools,
texinfo, xorg-server-for-tests.
---
guix/lint.scm | 19 ++++++++++++++++++-
1 file changed, 18 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/guix/lint.scm b/guix/lint.scm
index e3544bd963..4e3aa2f00d 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -286,11 +286,23 @@ of a package, and INPUT-NAMES, a list of package specifications such as
(let ((inputs (package-inputs package))
(input-names
'("pkg-config"
+ "autoconf"
+ "automake"
+ "bison"
"cmake"
+ "dejagnu"
+ "desktop-file-utils"
+ "doxygen"
"extra-cmake-modules"
+ "flex"
+ "gettext"
"glib:bin"
+ "googletest-source"
+ "groff"
+ "help2man"
"intltool"
"itstool"
+ "libtool"
"qttools"
"yasm" "nasm" "fasm"
"python-coverage" "python2-coverage"
@@ -302,7 +314,12 @@ of a package, and INPUT-NAMES, a list of package specifications such as
"python-pytest" "python2-pytest"
"python-pytest-cov" "python2-pytest-cov"
"python-setuptools-scm" "python2-setuptools-scm"
- "python-sphinx" "python2-sphinx")))
+ "python-sphinx" "python2-sphinx"
+ "swig"
+ "qmake"
+ "qttools"
+ "texinfo"
+ "xorg-server-for-tests")))
(map (lambda (input)
(make-warning
package
Danny Milosavljevic wrote 5 years ago
(address . 39056@debbugs.gnu.org)
20200109180446.46276dd6@scratchpost.org
And yelp-tools
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl4XXS4ACgkQ5xo1VCww
uqXuhQf+KypUL0oIqJNrKSv++NUdZNUkwVCX/BQNdxLzdp7jsNfLvnhn46TEQZ8I
UpsOjsUe3/JJlcHcFU1paeVj4VZD0ycPOieohVJmtHJRHBeD0BTRN/ivnKW6p1Y9
pg3M+pUZBC/wUP9onAdbGWUBEsX5WiUDrVtKZgRaRZeFZY9OEFnCXS1zueO/Rvpz
0PSg5nU1/qy6CdxOF3z1Nn8kX+4TYl95/gCeFdF1HfJu4+3UQkOItBdOrrij59wF
u/pMIBppwqnCJ/swZNo4Mn6GlTGXo7Z1IpviwZqlejK4L9lgidf6yW5HJCjAKSEG
QwfQ7JqXcBjOJstuS2LwCkbVPgbZKg==
=Xv5q
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 5 years ago
Re: [bug#39056] [PATCH] lint: Check for more packages which should be native.
(address . 39056@debbugs.gnu.org)
20200109181024.6895681b@scratchpost.org
And gobject-introspection
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl4XXoAACgkQ5xo1VCww
uqX3lAf+IM5Glik/zy0QeGG1zx0oAQf7tZIT4G25YJneOVoVfWgAW+lO44m4/jA2
91naqDfkkU1hu5QdzmOBguFV/+ZmUeq+lmJmX34ERP9nppUoqWlYq/W4DrFkvHve
t1JLqfUkv8N+S+03C0OTWrj4Ik+HWfsxX/h9Jy7in6tnMnQ4uHPyeBXUKmPtYdZ7
SpTMg+ym0SVSzOEhQq+BKz8XIqLc5PRc4ckMwP+ByWrNPyYztJCZYRHA0Pnao+fy
6BGEWNxcXHsmXYGLr2X7cBlyysZM6kegVC1EKAxGLcUMNozGgwVUeIijOCKzQwzX
GTnbTnl9Y5FxE1HdqqEAWoJUglBAmg==
=YLwF
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 5 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 39056@debbugs.gnu.org)
871rs8ti6v.fsf@gnu.org
Hello,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (5 lines)
> * guix/lint.scm (check-inputs-should-be-native): Add autoconf, automake,
> bison, dejagnu, desktop-file-utils, doxygen, flex, gettext,
> googletest-source, groff, help2man, libtool, swig, qmake, qttools,
> texinfo, xorg-server-for-tests.

LGTM!

Toggle quote (3 lines)
> And yelp-tools
> And gobject-introspection

Those too. :-)

Thanks,
Ludo’.
Danny Milosavljevic wrote 5 years ago
20200109231555.21edd366@scratchpost.org
Pushed to guix master as commit bbd9063afcb204b3f81c59d09f5c54d3b67f1e91.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl4XphsACgkQ5xo1VCww
uqVFSAf/TaDircEYv4t8kWFSghQb7rq08v8gdWoD93RF5K1xWW7Jh2p0dIRksx15
7Qkr2AGDJHovgqo41UcgkQFLvoOmaPLV7koL8JxepP/IrVBILrOAtA/92jd0f9EB
sgSLVYWMeKb43HaAtn7kmsedcOGlifTevuvYsd5hVsPxblfErADRNElSdNU1a8Tn
AkfBjcglco7n+kFkT47XernmxStDJABa/H7b6rptXosJbx9284Go08x7YnKzODck
Q3WQwXRhe/jCuZDPhwb+sm+HK2JUIsi4uNr+liC7dy3lsfuFxqZQqa96YrKyQPib
7MirQVsik7rLX0bK9nhjOspeXdt2YA==
=djNs
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39056@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39056
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help