[PATCH] gnu: Add ghc-pwstore-fast.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandru-Sergiu Marton
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandru-Sergiu Marton
Severity
normal
A
A
Alexandru-Sergiu Marton wrote on 8 Jan 2020 10:35
(address . guix-patches@gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@member.fsf.org)
20200108093508.16771-1-brown121407@member.fsf.org
* gnu/packages/haskell-xyz.scm (ghc-pwstore-fast): New variable.
---
gnu/packages/haskell-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3f73c31072..3d841456cb 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9046,6 +9046,37 @@ Typical applications of Priority Search Queues include:
@end itemize")
(license license:bsd-3)))
+(define-public ghc-pwstore-fast
+ (package
+ (name "ghc-pwstore-fast")
+ (version "2.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/pwstore-fast/"
+ "pwstore-fast-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1cpvlwzg3qznhygrr78f75p65mnljd9v5cvnagfxjqppnrkay6bj"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-cryptohash" ,ghc-cryptohash)
+ ("ghc-random" ,ghc-random)
+ ("ghc-byteable" ,ghc-byteable)))
+ (home-page
+ "https://github.com/PeterScott/pwstore")
+ (synopsis "Secure password storage")
+ (description
+ "To store passwords securely, they should be salted, then hashed with
+a slow hash function. This library uses PBKDF1-SHA256, and handles all the
+details. It uses the cryptohash package for speed; if you need a pure
+Haskell library, pwstore-purehaskell has the exact same API, but uses only
+pure Haskell. It is about 25 times slower than this package, but still quite
+usable.")
+ (license license:bsd-3)))
+
(define-public ghc-random
(package
(name "ghc-random")
--
2.24.1
M
M
Marius Bakke wrote on 29 Mar 2020 21:12
(name . Alexandru-Sergiu Marton)(address . brown121407@member.fsf.org)
87eetbx9ea.fsf@devup.no
Alexandru-Sergiu Marton <brown121407@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/haskell-xyz.scm (ghc-pwstore-fast): New variable.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6A8y0ACgkQoqBt8qM6
VPomTwf+KD/OAnCJX9fQ5z6YDuGZC8kZ4fLumA/9oTjX9M6qnrmUED3uirxrFLJ/
Xo9d2EdLbJagfcrWdzhJH4mTHW3xdLgnJIqaS0Df9X5yjJjeZH4kx3wcQiOf0jyI
wXarOyU+QQkflboRkzyBlfAou51+Wo1qEjkk80S2EyAZf8MnMvT5DtXcQxMiVVRp
MdAucf3QD4vwo/jEJ5PMmHnDZjOmSylqtNhky5aD+b/X+d80SlY6Rf4fsHSCqQOz
j25u1RFf25/MaKz020AJt62Y6idbayMVLAouO3hMNqeT6Hnz+l6ruo2jC1X+XJlF
Mg01p4ayEBM2P80H/cnj8BwAx6meww==
=hERs
-----END PGP SIGNATURE-----

Closed
?