EuAndreh wrote 5 years ago
(address . guix-patches@gnu.org)(name . EuAndreh)(address . eu@euandre.org)
* gnu/packages/audio.scm (timidity++)[inputs] Add libvorbis as input
---
Hi Guix!
The current definition of TiMidity++ does include the configure flag for
Ogg Vorbis (--enable-audio=vorbis), but the package definition does not
provide all the required inputs for actually enabling it:
Toggle snippet (5 lines)
$ guix environment --ad-hoc -- timidity -Ov
Playmode `v' is not compiled in.
Try timidity -h for help
From the build log (http://ci.guix.gnu.org/log/qynf65197fp921vz8k03qblz7djaarb0-timidity++-2.14.0):
Toggle snippet (10 lines)
...
checking for Ogg... yes
checking for Vorbis... no
*** Could not run Vorbis test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means Vorbis was incorrectly installed
*** or that you have moved Vorbis since it was installed.
...
This happens because 'libogg' in provided as input, but 'libvorbis'
isn't.
After applying this patch, Ogg Vorbis becomes available like other formats.
Toggle snippet (3 lines)
$ ./pre-inst-env guix environment --ad-hoc -- timidity -Ov
Try timidity -h for help
gnu/packages/audio.scm | 1 +
1 file changed, 1 insertion(+)
Toggle diff (12 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 55a34460b1..f37ebc886e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2574,6 +2574,7 @@ Suil currently supports every combination of Gtk, Qt, and X11.")
("flac" ,flac)
("jack" ,jack-1)
("libogg" ,libogg)
+ ("libvorbis" ,libvorbis)
("speex" ,speex)
("ncurses" ,ncurses)
("freepats" ,freepats)))
--
2.24.1