[PATCH] gnu: timidity++: Add libvorbis as input

  • Done
  • quality assurance status badge
Details
2 participants
  • EuAndreh
  • Ludovic Courtès
Owner
unassigned
Submitted by
EuAndreh
Severity
normal

Debbugs page

EuAndreh wrote 5 years ago
(address . guix-patches@gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20200107110830.25890-1-eu@euandre.org
* gnu/packages/audio.scm (timidity++)[inputs] Add libvorbis as input
---
Hi Guix!

The current definition of TiMidity++ does include the configure flag for
Ogg Vorbis (--enable-audio=vorbis), but the package definition does not
provide all the required inputs for actually enabling it:

Toggle snippet (5 lines)
$ guix environment --ad-hoc -- timidity -Ov
Playmode `v' is not compiled in.
Try timidity -h for help

Toggle snippet (10 lines)
...
checking for Ogg... yes
checking for Vorbis... no
*** Could not run Vorbis test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means Vorbis was incorrectly installed
*** or that you have moved Vorbis since it was installed.
...

This happens because 'libogg' in provided as input, but 'libvorbis'
isn't.

After applying this patch, Ogg Vorbis becomes available like other formats.
Toggle snippet (3 lines)
$ ./pre-inst-env guix environment --ad-hoc -- timidity -Ov
Try timidity -h for help
gnu/packages/audio.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (12 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 55a34460b1..f37ebc886e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2574,6 +2574,7 @@ Suil currently supports every combination of Gtk, Qt, and X11.")
("flac" ,flac)
("jack" ,jack-1)
("libogg" ,libogg)
+ ("libvorbis" ,libvorbis)
("speex" ,speex)
("ncurses" ,ncurses)
("freepats" ,freepats)))
--
2.24.1
Ludovic Courtès wrote 5 years ago
(name . EuAndreh)(address . eu@euandre.org)(address . 39006-done@debbugs.gnu.org)
87ftglu0oy.fsf@gnu.org
Hello,

EuAndreh <eu@euandre.org> skribis:

Toggle quote (12 lines)
> * gnu/packages/audio.scm (timidity++)[inputs] Add libvorbis as input
> ---
> Hi Guix!
>
> The current definition of TiMidity++ does include the configure flag for
> Ogg Vorbis (--enable-audio=vorbis), but the package definition does not
> provide all the required inputs for actually enabling it:
>
> $ guix environment --ad-hoc -- timidity -Ov
> Playmode `v' is not compiled in.
> Try timidity -h for help

Indeed. Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39006@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39006
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help