[PATCH] gnu: pcmanfm-qt: fix open file issue

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Marius Bakke
  • Reza Alizadeh Majd
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal

Debbugs page

Danny Milosavljevic wrote 5 years ago
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 39004@debbugs.gnu.org)
20200107105214.502793d3@scratchpost.org
Hi Reza,

thanks for the patch. I think that it is the right way for now.

But GIO_LAUNCH_DESKTOP is not interpreted as a list by glib.

It would be better to communicate intent by constructing GIO_LAUNCH_DESKTOP as

(wrap-program (string-append out "/bin/pcmanfm-qt")
`("GIO_LAUNCH_DESKTOP" =
(,(string-append glib "/bin/gio-launch-desktop"))))

.

Otherwise, with ":" and "prefix" it very much sounded like a list.

Also, could you make it check whether /bin/gio-launch-desktop exists and
error out otherwise? That is in order for us to notice the workaround
later when we move the gio-launch-desktop executable.

(if (file-exists? ".........../bin/gio-launch-desktop")
(wrap-program ........)
(error "Could not find gio-launch-desktop"))
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl4UVM4ACgkQ5xo1VCww
uqXYjAgAoM1NyG8zzLGjIwqFl9Zsr9LvgzCy+mYQjwjxKHXJCLRfrrpHhI/mc8IG
hN+bOqBL0wVTxNMnL+4p44uUF9ufr6exRtzny7LKwiaKEUl+T8Lr0RMCc+T47piC
g6e2njvo3Zt/Jj8+9gyOFmvJ+Fxf7RSl4BVECcpkBa9z69zJuFE8wwdKlbwlWdV1
O79P2kYppqh71J+iiQDYkLIu9kxvbiS+SwSyGC7Q1qv0Y8qWxhsXSG7p711Rrgjf
vuGcHw6lkAvqSgxLYB4GaATnbk+t2Wvgky2ZKTo4yG2sNPGQKp6mkQ4UF4+XGNTT
7tLs3dsdTfZ0Kvv2AD5zdb8Q51bfAQ==
=82Dc
-----END PGP SIGNATURE-----


Reza Alizadeh Majd wrote 5 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 39004@debbugs.gnu.org)
fa543e31-1607-41bb-a6e2-fb2294d830a5@www.fastmail.com
Hi Danny,

On Tue, Jan 7, 2020, at 1:22 PM, Danny Milosavljevic wrote:
Toggle quote (26 lines)
> Hi Reza,
>
> thanks for the patch. I think that it is the right way for now.
>
> But GIO_LAUNCH_DESKTOP is not interpreted as a list by glib.
>
> It would be better to communicate intent by constructing GIO_LAUNCH_DESKTOP as
>
> (wrap-program (string-append out "/bin/pcmanfm-qt")
> `("GIO_LAUNCH_DESKTOP" =
> (,(string-append glib "/bin/gio-launch-desktop"))))
>
> .
>
> Otherwise, with ":" and "prefix" it very much sounded like a list.
>
> Also, could you make it check whether /bin/gio-launch-desktop exists and
> error out otherwise? That is in order for us to notice the workaround
> later when we move the gio-launch-desktop executable.
>
> (if (file-exists? ".........../bin/gio-launch-desktop")
> (wrap-program ........)
> (error "Could not find gio-launch-desktop"))
>


Thanks for your guidance, I updated the patch and applied both of

- GIO_LAUNCH_DESKTOP variable format
- gio-launch-desktop existence check

to this new patch.


--
Regards
Reza Alizadeh Majd
PantherX Team
Reza Alizadeh Majd wrote 5 years ago
(address . 39004@debbugs.gnu.org)
5f053064-6a89-4568-a475-98fc088d7607@www.fastmail.com
Hi,

it could be great to have this patch merged, if there is no other issues
existed with this change.

--
Regards
Reza Alizadeh Majd
PantherX Team
Marius Bakke wrote 5 years ago
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 39004-done@debbugs.gnu.org)(address . 38926-done@debbugs.gnu.org)
871rs5zqit.fsf@devup.no
Hi Reza,

"Reza Alizadeh Majd" <r.majd@pantherx.org> writes:

Toggle quote (3 lines)
> it could be great to have this patch merged, if there is no other issues
> existed with this change.

I've applied the patch, with minor cosmetic adjustments (fixing typo,
naming the input "glib:bin" as we usually do), as well as a commit
message following our guidelines.

Thanks for the bug report and fix!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl4aL/oACgkQoqBt8qM6
VPqayAgAvVYEzfh2Vx4mfXQ7oaD/jqQ+/IEkjP3vlP+LpEoHpfHeAzKrNYlUcAWP
3qHH4shzjhn/eYiV8C8NlGRBJiAkvmK4kKNAdwpl5FC8vBROnl8pA6MPJTk9NzQ/
10qh0fE3AgS4tn26MJjBaYhLTNzulvhjq7I7OlrKgBiuC1kA8JV7A0C+VbEDYIZe
Z6pCGiFanR70QrzhHaFoGtRhM1q3Iyuypdsc64utZgLt5qehQpeUFrB77mHuA6IF
98XZWZyTqmJbTVreLVqe8wKTQXYEn8Q2INyLuYr/4YKgZtB6eW0A2LabkXTI/b4K
nQpRCmDE5rS3ZsiDfkfRqGJV8HN7RQ==
=r9c7
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39004@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39004
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help