[PATCH] gnu: Add python-git-multimail.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
20200106201030.4520-1-mail@cbaines.net
* gnu/packages/version-control.scm (python-git-multimail): New variable.
---
gnu/packages/version-control.scm | 43 ++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index d354a807a3..9188e642a7 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -72,6 +72,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages mail)
#:use-module (gnu packages maths)
#:use-module (gnu packages nano)
#:use-module (gnu packages ncurses)
@@ -782,6 +783,48 @@ collaboration using typical untrusted file hosts or services.")
a built-in cache to decrease server I/O pressure.")
(license license:gpl2)))
+(define-public python-git-multimail
+ (package
+ (name "python-git-multimail")
+ (version "1.5.0.post1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "git-multimail" version))
+ (sha256
+ (base32
+ "1zkrbsa70anwpw86ysfwalrb7nsr064kygfiyikyq1pl9pcl969y"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "git-multimail/git_multimail.py"
+ (("GIT_EXECUTABLE = 'git'")
+ (string-append "GIT_EXECUTABLE = '"
+ (assoc-ref inputs "git") "/bin/git"
+ "'"))
+ (("/usr/sbin/sendmail")
+ (string-append (assoc-ref inputs "sendmail")
+ "/usr/sbin/sendmail',
+ '/usr/sbin/sendmail")))
+ #t)))))
+ (inputs
+ `(("git" ,git)
+ ("sendmail" ,sendmail)))
+ (home-page "https://github.com/git-multimail/git-multimail")
+ (synopsis "Send notification emails for Git pushes")
+ (description
+ "This hook sends emails describing changes introduced by pushes to a Git
+repository. For each reference that was changed, it emits one ReferenceChange
+email summarizing how the reference was changed, followed by one Revision
+email for each new commit that was introduced by the reference change.
+
+This script is designed to be used as a post-receive hook in a Git
+repository")
+ (license license:gpl2)))
+
(define-public python-ghp-import
(package
(name "python-ghp-import")
--
2.24.1
Ludovic Courtès wrote 5 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 38995@debbugs.gnu.org)
87k15xu0tx.fsf@gnu.org
Hi Chris!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/version-control.scm (python-git-multimail): New variable.

[...]

Toggle quote (10 lines)
> + (substitute* "git-multimail/git_multimail.py"
> + (("GIT_EXECUTABLE = 'git'")
> + (string-append "GIT_EXECUTABLE = '"
> + (assoc-ref inputs "git") "/bin/git"
> + "'"))
> + (("/usr/sbin/sendmail")
> + (string-append (assoc-ref inputs "sendmail")
> + "/usr/sbin/sendmail',
> + '/usr/sbin/sendmail")))

The second clause is intriguing, but as long as it has the intended
effect, LGTM! :-)

Ludo’.
Christopher Baines wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38995-done@debbugs.gnu.org)
87y2u7ozot.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (21 lines)
> Hi Chris!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/version-control.scm (python-git-multimail): New variable.
>
> [...]
>
>> + (substitute* "git-multimail/git_multimail.py"
>> + (("GIT_EXECUTABLE = 'git'")
>> + (string-append "GIT_EXECUTABLE = '"
>> + (assoc-ref inputs "git") "/bin/git"
>> + "'"))
>> + (("/usr/sbin/sendmail")
>> + (string-append (assoc-ref inputs "sendmail")
>> + "/usr/sbin/sendmail',
>> + '/usr/sbin/sendmail")))
>
> The second clause is intriguing, but as long as it has the intended
> effect, LGTM! :-)

I was thinking something about preserving the existing behaviour when I
kept /usr/sbin/sendmail in the list, but that doesn't make sense, as the
list is searched in order, and sendmail from the Guix package will
always be present.

I've removed the odd bit, and pushed this as
add8d50911f55464a1ecd003521997d6c7d912f3 now.

Thanks for taking a look!

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl4g1lNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdUHA/8CoXksL8R/1HYniSFuWCqVBHnVICi6vmbTeW/PmPsbzI9i1l4DTqX7VeW
/Vb6kvTpikG1zFX5YsssANpYeTw9JISn1LolBWkraeH16VcJ5ySpJiTN8nbAAQWO
t7nXozcGA+mY2ZmOofSUGwTMzRoUllrLb/cnG/u1kpBbWtM7BHGOyrJ7+8rs6Q4w
cXXCTvciBak8G8wtDXlxjWhHi0Q7Tqt11QGW+ZiTz17Vi94ebRx90jpeU6VX2fM3
hb5WDB2mMhmjeY8gML3s8iqwAaFa0ujp3H3+yBBGhH9pjuhfeBtnXNC8GIHpngCv
5vJKuAjsO+61QtnRp/ogcKufbq2JMuvBlW+muvztPGy6Wbiq67IXi5YCH3Hp5sFG
klaAWF2KDinyk1IjXJSQckNs9MIkPjNVqq2g1+NgifE0bNgIo0+gQRRwWR+eo3gK
lf11NjLJA0ityWF7dR4gMyP+geRK+oCOgfiqyKqlQ/10ZljphivrUyCthlejOiFO
zgf7B17EZOkTCSa0cSrS1pFkPAOTxuMfCw8Jwaxe+GKnaDT+DwuWv2LJ/a3JgaLd
ES0c3+6AB1qJyhqoD9crzGL4i43BbEGc9cFGKmh9Md13uVgPAeO+EIyDCeMGGGO6
LwqwBzMtAzdRd6V80d+vVolYAPNfDY+GtaQ/2sYkVnyMvZ1eVOE=
=HtoN
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38995@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38995
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help