[PATCH core-updates] gnu: glib: Fix g_app_info_get_default_for_type.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Jonathan Brielmaier
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 5 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20200106193751.725-1-dannym@scratchpost.org
Reported by Reza Alizadeh Majd <r.majd@pantherx.org>.

* gnu/packages/glib.scm (glib)[arguments]<#:phases>[patch-gio-launch-desktop]:
New phase.
[move-executables]: Modify.
---
gnu/packages/glib.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 369bd373ac..9551509a53 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -213,6 +213,15 @@ shared NFS home directories.")
(string-append "command_line = g_strdup_printf (\""
dbus "/bin/dbus-launch")))
#t)))
+ (add-after 'unpack 'patch-gio-launch-desktop
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; See also <https://gitlab.gnome.org/GNOME/glib/issues/1633>
+ ;; for another future fix.
+ (substitute* "gio/gdesktopappinfo.c"
+ (("gio-launch-desktop")
+ (string-append out "/bin/gio-launch-desktop")))
+ #t)))
(add-before 'build 'pre-build
(lambda* (#:key inputs outputs #:allow-other-keys)
;; For tests/gdatetime.c.
@@ -321,6 +330,13 @@ shared NFS home directories.")
(mkdir-p bin)
(rename-file (string-append out "/bin")
(string-append bin "/bin"))
+ ;; This one is an implementation detail of glib.
+ ;; It is wrong that that's in "/bin" in the first place,
+ ;; but that's what upstream does right now.
+ ;; See <https://gitlab.gnome.org/GNOME/glib/issues/1633>.
+ (mkdir (string-append out "/bin"))
+ (rename-file (string-append bin "/bin/gio-launch-desktop")
+ (string-append out "/bin/gio-launch-desktop"))
;; Do not refer to "bindir", which points to "${prefix}/bin".
;; We don't patch "bindir" to point to "$bin/bin", because that
;; would create a reference cycle between the "out" and "bin"
Jonathan Brielmaier wrote 5 years ago
(address . guix-patches@gnu.org)
dcb6ecd9-2a4b-469a-09e7-8928318a47f9@web.de
Hey Danny,

On 06.01.20 20:37, Danny Milosavljevic wrote:
Toggle quote (3 lines)
> Reported by Reza Alizadeh Majd <r.majd@pantherx.org>.

I think the bug link is wrong (it's about dhcp services).

Toggle quote (43 lines)
>
> * gnu/packages/glib.scm (glib)[arguments]<#:phases>[patch-gio-launch-desktop]:
> New phase.
> [move-executables]: Modify.
> ---
> gnu/packages/glib.scm | 16 ++++++++++++++++
> 1 file changed, 16 insertions(+)
>
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index 369bd373ac..9551509a53 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -213,6 +213,15 @@ shared NFS home directories.")
> (string-append "command_line = g_strdup_printf (\""
> dbus "/bin/dbus-launch")))
> #t)))
> + (add-after 'unpack 'patch-gio-launch-desktop
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out")))
> + ;; See also <https://gitlab.gnome.org/GNOME/glib/issues/1633>
> + ;; for another future fix.
> + (substitute* "gio/gdesktopappinfo.c"
> + (("gio-launch-desktop")
> + (string-append out "/bin/gio-launch-desktop")))
> + #t)))
> (add-before 'build 'pre-build
> (lambda* (#:key inputs outputs #:allow-other-keys)
> ;; For tests/gdatetime.c.
> @@ -321,6 +330,13 @@ shared NFS home directories.")
> (mkdir-p bin)
> (rename-file (string-append out "/bin")
> (string-append bin "/bin"))
> + ;; This one is an implementation detail of glib.
> + ;; It is wrong that that's in "/bin" in the first place,
> + ;; but that's what upstream does right now.
> + ;; See <https://gitlab.gnome.org/GNOME/glib/issues/1633>.
> + (mkdir (string-append out "/bin"))
> + (rename-file (string-append bin "/bin/gio-launch-desktop")
> + (string-append out "/bin/gio-launch-desktop"))
> ;; Do not refer to "bindir", which points to "${prefix}/bin".
> ;; We don't patch "bindir" to point to "$bin/bin", because that
> ;; would create a reference cycle between the "out" and "bin"

I would personally like, if we can update to 2.62. Because that is
needed for updating gnome to 3.34

~Jonathan
Danny Milosavljevic wrote 5 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 38994@debbugs.gnu.org)
20200107004510.176c34d8@scratchpost.org
Hey,

On Tue, 7 Jan 2020 00:04:32 +0100
Jonathan Brielmaier <jonathan.brielmaier@web.de> wrote:

Toggle quote (2 lines)
> I think the bug link is wrong (it's about dhcp services).

whoops, should have been a reference to bug 38926. Thanks!

Toggle quote (4 lines)
> I would personally like, if we can update to 2.62. Because that is
> needed for updating gnome to 3.34
> (https://gitlab.com/jonsger/Guix/commits/wip-gnome-3.34). What do you think?

Sure, why not (on core-updates)? There's glib 2.63 released upstream.

Right now, core-updates has glib 2.60.6 still (as has master).

If you try to update glib, be advised that core-updates is broken right now[1].

On the other hand that means that we could update glib on core-updates right
away since core-updates could not built anything using it anyway :P

(The bug upstream is still open, so it will not improve things in that regard)

[1] texlive-bin build error https://bugs.gnu.org/38999; texlive is required for glib-with-documentation.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl4TxoYACgkQ5xo1VCww
uqXuOQf+K5xDO0G01O9fediu6H2QF3NJ0A1PUtJwSpIeKC3dQNi9Q4vPqvok2a9F
cV4nNGzajbprOH8YS+AcujWh5/grkIb//xWN2DDSsmju81VA6GZwGwIWGMs+GAQE
x3FJrvkg283ruKrLz4ETnwHUNQZQ7rPeSxptWjeTEnuhvuYMlAfC3JfgCD3CsssL
tjQh+Bafs5i/fRDX0UNiTtY4d8D0EG7Io2DaI+qHHVhV/9dl8S1JczQ09G39A/JC
BMS6vXnmjpb2++/ny+tQSuUU92xoEpUoLFEmXlaQldg2AyyckhiKAXAq+PJeFx8R
bmR1Qr4wxqj+chxVtoDtcsbzFLN3VQ==
=rjJM
-----END PGP SIGNATURE-----


Jonathan Brielmaier wrote 5 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 38994@debbugs.gnu.org)
8a1cd5ae-003b-e912-69ae-a3504c5fc039@web.de
On 07.01.20 00:45, Danny Milosavljevic wrote:
Toggle quote (6 lines)
>> I would personally like, if we can update to 2.62. Because that is
>> needed for updating gnome to 3.34
>> (https://gitlab.com/jonsger/Guix/commits/wip-gnome-3.34). What do you think?
>
> Sure, why not (on core-updates)? There's glib 2.63 released upstream.

I wonder if uneven release numbers at glib mark development/unstable
releases. As it's the case in the rest of GNOME.

Toggle quote (10 lines)
> Right now, core-updates has glib 2.60.6 still (as has master).
>
> If you try to update glib, be advised that core-updates is broken right now[1].
>
> On the other hand that means that we could update glib on core-updates right
> away since core-updates could not built anything using it anyway :P
>
> (The bug upstream is still open, so it will not improve things in that regard)
>
> [1] texlive-bin build error <https://bugs.gnu.org/38999>; texlive is required for glib-with-documentation.
Marius Bakke wrote 5 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87d0bnvxen.fsf@devup.no
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (42 lines)
> Reported by Reza Alizadeh Majd <r.majd@pantherx.org>.
>
> * gnu/packages/glib.scm (glib)[arguments]<#:phases>[patch-gio-launch-desktop]:
> New phase.
> [move-executables]: Modify.
> ---
> gnu/packages/glib.scm | 16 ++++++++++++++++
> 1 file changed, 16 insertions(+)
>
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index 369bd373ac..9551509a53 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -213,6 +213,15 @@ shared NFS home directories.")
> (string-append "command_line = g_strdup_printf (\""
> dbus "/bin/dbus-launch")))
> #t)))
> + (add-after 'unpack 'patch-gio-launch-desktop
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out")))
> + ;; See also <https://gitlab.gnome.org/GNOME/glib/issues/1633>
> + ;; for another future fix.
> + (substitute* "gio/gdesktopappinfo.c"
> + (("gio-launch-desktop")
> + (string-append out "/bin/gio-launch-desktop")))
> + #t)))
> (add-before 'build 'pre-build
> (lambda* (#:key inputs outputs #:allow-other-keys)
> ;; For tests/gdatetime.c.
> @@ -321,6 +330,13 @@ shared NFS home directories.")
> (mkdir-p bin)
> (rename-file (string-append out "/bin")
> (string-append bin "/bin"))
> + ;; This one is an implementation detail of glib.
> + ;; It is wrong that that's in "/bin" in the first place,
> + ;; but that's what upstream does right now.
> + ;; See <https://gitlab.gnome.org/GNOME/glib/issues/1633>.
> + (mkdir (string-append out "/bin"))
> + (rename-file (string-append bin "/bin/gio-launch-desktop")
> + (string-append out "/bin/gio-launch-desktop"))

It is moved to "out" to avoid a circular reference between "bin" and
"out", right? IMO we might as well "beat upstream to it" here and use
$out/libexec, since nothing else is supposed to depend on it.

LGTM with that change.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl4c5iAACgkQoqBt8qM6
VPpsUAgAkzdU3OUI2uEXiLDkmR2AF16aTlJvrj/uuMjVr339WY5iHko2LrC7cBkU
O/bOrdJAphS0KSQJzrcSMxIiOFVcwLucSX88/qmqA3aVTOhgle7W2eWnPzP3sVly
6w5Zv/6+FUpz7M0Oe348dhPXIBb6FmIk35gKFyJgodFmeTF2r5GkbixCsurkbHiw
mXo3FhjXWwELji3hO/Ry4u89/9amzYNBzipiM+8ybqwgF87yHnhihzKUl9IQ+/qw
SdeFCtTUBOk/IXEEWN0cG8p4RoJ5Nop5GqgpUH/Ls62dNGiJZwlzEy3tnimc+spx
Ut4ORou+kpt7XpYS84s8Gwb+Hj51Ug==
=wGgr
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 5 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 38994-done@debbugs.gnu.org)
20200114015938.03bfc234@scratchpost.org
Hi Marius,

On Mon, 13 Jan 2020 22:50:24 +0100
Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (3 lines)
> It is moved to "out" to avoid a circular reference between "bin" and
> "out", right?

Yes.

Toggle quote (3 lines)
>IMO we might as well "beat upstream to it" here and use
> $out/libexec, since nothing else is supposed to depend on it.

Okay.

Pushed to guix core-updates as commit 0bcc1b14fc3e2382406b97577c56e2292b96b8d4.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl4dEnoACgkQ5xo1VCww
uqW7GAf/cmUYUQt67EbQA6CS02p8K/Jbwcl3/Sy6Yv07wmXYlTfCBn3di8UUXGBo
fuxEQuFhy+kZ5jqn/6GLqNzldi1yi47H4z7awg3/M7aodOFkp+n/ymcrmA/Q870T
mD6m4UIeEdZKtTnsjR5Z8m3PJ7h7IdaMTM4PYhooWauDu7rnWnOInn7nZ5r7NTkD
AoIHvEXNuSeJXWuNS5x6Yo7hgGfK9CZGVNwvxf1ykcpLLktJUOr48ooco5EMc5sR
hZf2Ur9vUQTy2NYZfIuWw4Mq8DwJPyO3JkwZkYtYm3vxzSmew6JAz8QEjqXMr0/X
vwkC3zD+yuLEQRPNhQiWGoFc/SCQ8g==
=ITeU
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38994@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38994
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help