Toggle diff (302 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index af017e108d..9a26ef45ac 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages finance)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages glib)
@@ -54,136 +55,139 @@
(define-public gnucash
;; TODO: Unbundle libraries such as guile-json found under the "borrowed/"
;; directory.
- (package
- (name "gnucash")
- (version "3.7")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
- version "/gnucash-" version ".tar.bz2"))
- (sha256
- (base32
- "1d2qi3ny0bxa16ifh3465z1jgn1l0fmqk9dkph4ialw076gv13kb"))))
- (build-system cmake-build-system)
- (inputs
- `(("guile" ,guile-2.2)
- ("boost" ,boost)
- ("icu4c" ,icu4c)
- ("glib" ,glib)
- ("gtk" ,gtk+)
- ("libdbi" ,libdbi)
- ("libdbi-drivers" ,libdbi-drivers)
- ("libgnomecanvas" ,libgnomecanvas)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)
- ("webkitgtk" ,webkitgtk)
- ("aqbanking" ,aqbanking)
- ("perl-date-manip" ,perl-date-manip)
- ("perl-finance-quote" ,perl-finance-quote)
- ("tzdata" ,tzdata-for-tests)))
- (native-inputs
- `(("glib" ,glib "bin") ; glib-compile-schemas, etc.
- ("intltool" ,intltool)
- ("googlemock" ,(package-source googletest))
- ("googletest" ,googletest)
- ("gnucash-docs" ,gnucash-docs)
- ("pkg-config" ,pkg-config)))
- (outputs '("out" "doc" "debug"))
- (arguments
- `(#:test-target "check"
- #:configure-flags
- (list "-DWITH_OFX=OFF") ; libofx is not available yet
- #:make-flags '("GUILE_AUTO_COMPILE=0")
- #:modules ((guix build cmake-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
- (guix build utils))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build cmake-build-system)
- (guix build glib-or-gtk-build-system))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'unpack-gmock
- (lambda* (#:key inputs #:allow-other-keys)
- (mkdir "gmock")
- (copy-recursively (assoc-ref inputs "googlemock") "gmock")
- (setenv "GMOCK_ROOT" (string-append (getcwd) "/gmock/googlemock"))
- #t))
- (add-after 'unpack 'set-env-vars
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((tzdata (assoc-ref inputs "tzdata")))
- ;; At least one test is time-related and requires this
- ;; environment variable.
- (setenv "TZDIR"
- (string-append tzdata
- "/share/zoneinfo"))
- (substitute* "CMakeLists.txt"
- (("set\\(SHELL /bin/bash\\)")
- (string-append "set(SHELL " (which "bash") ")")))
- #t)))
- ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
- ;; execute them with perl, so execute them directly instead.
- (add-after 'unpack 'fix-finance-quote-check
- (lambda _
- (substitute* "libgnucash/scm/price-quotes.scm"
- (("\"perl\" \"-w\" ") ""))
- #t))
- ;; The qof test requires the en_US, en_GB, and fr_FR locales.
- (add-before 'check 'install-locales
- (lambda _
- (setenv "LOCPATH" (getcwd))
- (invoke "localedef" "-i" "en_US" "-f" "UTF-8" "./en_US.UTF-8")
- (invoke "localedef" "-i" "en_GB" "-f" "UTF-8" "./en_GB.UTF-8")
- (invoke "localedef" "-i" "fr_FR" "-f" "UTF-8" "./fr_FR.UTF-8")
- #t))
- ;; There are about 100 megabytes of documentation.
- (add-after 'install 'install-docs
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((docs (assoc-ref inputs "gnucash-docs"))
- (doc-output (assoc-ref outputs "doc")))
- (mkdir-p (string-append doc-output "/share"))
- (symlink (string-append docs "/share/gnome")
- (string-append doc-output "/share/gnome"))
- #t)))
- (add-after 'install-docs 'wrap-programs
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (for-each (lambda (prog)
- (wrap-program (string-append (assoc-ref outputs "out")
- "/bin/" prog)
- `("GNC_DBD_DIR" =
- (,(string-append
- (assoc-ref inputs "libdbi-drivers")
- "/lib/dbd")))
- `("PERL5LIB" ":" prefix
- ,(map (lambda (o)
- (string-append o "/lib/perl5/site_perl/"
- ,(package-version perl)))
- (if (string=? prog "gnc-fq-helper")
- (list
- ,@(transitive-input-references
- 'inputs
- (map (lambda (l)
- (assoc l (package-inputs this-package)))
- '("perl-finance-quote"
- "perl-date-manip"))))
- (list
- ,@(transitive-input-references
- 'inputs
- (map (lambda (l)
- (assoc l (package-inputs this-package)))
- '("perl-finance-quote")))))))))
- '("gnucash"
- "gnc-fq-check"
- "gnc-fq-helper"
- "gnc-fq-dump"))))
- (add-after 'install 'glib-or-gtk-compile-schemas
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
- (add-after 'install 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
- (home-page "https://www.gnucash.org/")
- (synopsis "Personal and small business financial accounting software")
- (description
- "GnuCash is personal and professional financial-accounting software.
+ (let ((revision "b"))
+ (package
+ (name "gnucash")
+ (version "3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
+ version "/gnucash-" version revision ".tar.bz2"))
+ (sha256
+ (base32
+ "0dvzm3bib7jcj685sklpzyy9mrak9mxyvih2k9fk4sl3v21wlphg"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("boost" ,boost)
+ ("icu4c" ,icu4c)
+ ("glib" ,glib)
+ ("gtk" ,gtk+)
+ ("libdbi" ,libdbi)
+ ("libdbi-drivers" ,libdbi-drivers)
+ ("libgnomecanvas" ,libgnomecanvas)
+ ("libofx" ,libofx)
+ ("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
+ ("webkitgtk" ,webkitgtk)
+ ("aqbanking" ,aqbanking)
+ ("perl-date-manip" ,perl-date-manip)
+ ("perl-finance-quote" ,perl-finance-quote)
+ ("tzdata" ,tzdata-for-tests)))
+ (native-inputs
+ `(("glib" ,glib "bin") ; glib-compile-schemas, etc.
+ ("intltool" ,intltool)
+ ("googlemock" ,(package-source googletest))
+ ("googletest" ,googletest)
+ ("gnucash-docs" ,gnucash-docs)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ ;; dconf is required at runtime according to README.dependencies.
+ `(("dconf" ,dconf)))
+ (outputs '("out" "doc" "debug"))
+ (arguments
+ `(#:test-target "check"
+ #:make-flags '("GUILE_AUTO_COMPILE=0")
+ #:modules ((guix build cmake-build-system)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (guix build utils))
+ #:imported-modules (,@%gnu-build-system-modules
+ (guix build cmake-build-system)
+ (guix build glib-or-gtk-build-system))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-gmock
+ (lambda* (#:key inputs #:allow-other-keys)
+ (mkdir "gmock")
+ (copy-recursively (assoc-ref inputs "googlemock") "gmock")
+ (setenv "GMOCK_ROOT" (string-append (getcwd) "/gmock/googlemock"))
+ #t))
+ (add-after 'unpack 'set-env-vars
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((tzdata (assoc-ref inputs "tzdata")))
+ ;; At least one test is time-related and requires this
+ ;; environment variable.
+ (setenv "TZDIR"
+ (string-append tzdata
+ "/share/zoneinfo"))
+ (substitute* "CMakeLists.txt"
+ (("set\\(SHELL /bin/bash\\)")
+ (string-append "set(SHELL " (which "bash") ")")))
+ #t)))
+ ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
+ ;; execute them with perl, so execute them directly instead.
+ (add-after 'unpack 'fix-finance-quote-check
+ (lambda _
+ (substitute* "libgnucash/scm/price-quotes.scm"
+ (("\"perl\" \"-w\" ") ""))
+ #t))
+ ;; The qof test requires the en_US, en_GB, and fr_FR locales.
+ (add-before 'check 'install-locales
+ (lambda _
+ (setenv "LOCPATH" (getcwd))
+ (invoke "localedef" "-i" "en_US" "-f" "UTF-8" "./en_US.UTF-8")
+ (invoke "localedef" "-i" "en_GB" "-f" "UTF-8" "./en_GB.UTF-8")
+ (invoke "localedef" "-i" "fr_FR" "-f" "UTF-8" "./fr_FR.UTF-8")
+ #t))
+ ;; There are about 100 megabytes of documentation.
+ (add-after 'install 'install-docs
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((docs (assoc-ref inputs "gnucash-docs"))
+ (doc-output (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc-output "/share"))
+ (symlink (string-append docs "/share/gnome")
+ (string-append doc-output "/share/gnome"))
+ #t)))
+ (add-after 'install-docs 'wrap-programs
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (for-each (lambda (prog)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/" prog)
+ `("GNC_DBD_DIR" =
+ (,(string-append
+ (assoc-ref inputs "libdbi-drivers")
+ "/lib/dbd")))
+ `("PERL5LIB" ":" prefix
+ ,(map (lambda (o)
+ (string-append o "/lib/perl5/site_perl/"
+ ,(package-version perl)))
+ (if (string=? prog "gnc-fq-helper")
+ (list
+ ,@(transitive-input-references
+ 'inputs
+ (map (lambda (l)
+ (assoc l (package-inputs this-package)))
+ '("perl-finance-quote"
+ "perl-date-manip"))))
+ (list
+ ,@(transitive-input-references
+ 'inputs
+ (map (lambda (l)
+ (assoc l (package-inputs this-package)))
+ '("perl-finance-quote")))))))))
+ '("gnucash"
+ "gnc-fq-check"
+ "gnc-fq-helper"
+ "gnc-fq-dump"))))
+ (add-after 'install 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (add-after 'install 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ (home-page "https://www.gnucash.org/")
+ (synopsis "Personal and small business financial accounting software")
+ (description
+ "GnuCash is personal and professional financial-accounting software.
It can be used to track bank accounts, stocks, income and expenses, based on
the double-entry accounting practice. It includes support for QIF/OFX/HBCI
import and transaction matching. It also automates several tasks, such as
@@ -191,7 +195,7 @@ financial calculations or scheduled transactions.
To make the GnuCash documentation available, its doc output must be
installed as well as Yelp, the Gnome help browser.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
;; This package is not public, since we use it to build the "doc" output of
;; the gnucash package (see above). It would be confusing if it were public.
@@ -207,7 +211,7 @@ installed as well as Yelp, the Gnome help browser.")
version "/gnucash-docs-" version revision ".tar.gz"))
(sha256
(base32
- "1h4hm58ikffbhplx4gm8pzm9blfwqa1sz8yc2fqi21vs5v0ijf9r"))))
+ "19v6kchda724xkkgwlw5rg21jcpirhch12j9sr6ibnv61sd4ql52"))))
(build-system gnu-build-system)
;; These are native-inputs because they are only required for building the
;; documentation.
--
2.24.1