[PATCH 1/3] gnu: Add opensp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal
K
K
Kei Kebreau wrote on 5 Jan 2020 17:13
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20200105161329.1455-1-kkebreau@posteo.net
* gnu/packages/finance.scm (opensp): New variable.
---
gnu/packages/finance.scm | 52 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (73 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index ce3033c054..b66d8b89a1 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -51,10 +51,12 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages dns)
#:use-module (gnu packages emacs)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
@@ -1218,3 +1220,53 @@ offers confimations after less than 5 seconds and have significantly lower
fees that BTC. Bitcoin ABC is the reference implementation of the Bitcoin
Cash protocol. This package provides the Bitcoin Cash command line client and
a client based on Qt. This is a fork of Bitcoin Core.")))
+
+(define-public opensp
+ (package
+ (name "opensp")
+ (version "1.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/openjade/opensp/"
+ version "/OpenSP-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1khpasr6l0a8nfz6kcf3s81vgdab8fm2dj291n5r2s53k228kx2p"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("docbook-xml" ,docbook-xml-4.1.2)
+ ("docbook-xsl" ,docbook-xsl)
+ ("xmlto" ,xmlto)))
+ (arguments
+ `(;; TODO: Fix and enable tests.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook"))
+ (xsldoc (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl))))
+ (substitute* (find-files "docsrc" "\\.xml$")
+ (("/usr/share/sgml/docbook/xml-dtd-4.1.2") xmldoc)
+ (("http://.*/docbookx\\.dtd")
+ (string-append xmldoc "/docbookx.dtd")))
+ ;; Directly pass the path to the stylesheet to xmlto.
+ (substitute* "docsrc/Makefile.in"
+ (("\\$\\(XMLTO\\)")
+ (string-append "$(XMLTO) -x " xsldoc
+ "/manpages/docbook.xsl")))
+ #t))))))
+ (home-page "http://openjade.sourceforge.net/")
+ (synopsis "Suite of SGML/XML processing tools")
+ (description "OpenSP is an object-oriented toolkit for SGML parsing and
+entity management.")
+ (license
+ ;; expat license with added clause regarding advertising
+ (license:non-copyleft
+ "file://COPYING"
+ "See COPYING in the distribution."))))
--
2.24.1
K
K
Kei Kebreau wrote on 5 Jan 2020 17:17
[PATCH 2/3] gnu: Add libofx.
(address . 38947@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20200105161706.1841-1-kkebreau@posteo.net
* gnu/packages/finance.scm (libofx): New variable.
---
gnu/packages/finance.scm | 46 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index b66d8b89a1..5881f375ca 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -68,9 +69,11 @@
#:use-module (gnu packages libunwind)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages man)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages networking)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
@@ -1221,6 +1224,49 @@ fees that BTC. Bitcoin ABC is the reference implementation of the Bitcoin
Cash protocol. This package provides the Bitcoin Cash command line client and
a client based on Qt. This is a fork of Bitcoin Core.")))
+(define-public libofx
+ (package
+ (name "libofx")
+ (version "0.9.15")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libofx/libofx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jx56ma351p8af8dvavygjwf6ipa7qbgq7bpdsymwj27apdnixfy"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list (string-append "--with-opensp-includes="
+ (assoc-ref %build-inputs "opensp")
+ "/include/OpenSP"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gengetopt" ,gengetopt)
+ ("help2man" ,help2man)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)
+ ("libxml++-2" ,libxml++-2)
+ ("opensp" ,opensp)))
+ (home-page "http://libofx.sourceforge.net/")
+ (synopsis "Library supporting the Open Financial Exchange format")
+ (description
+ "The LibOFX library is a API designed to allow applications to very easily
+support OFX command responses, usually provided by financial institutions. The
+following three utilities are included with the library:
+@enumerate
+@item @code{ofxdump}
+@item @code{ofx2qif}
+@item @code{ofxconnect}
+@end enumerate")
+ (license license:gpl2+)))
+
(define-public opensp
(package
(name "opensp")
--
2.24.1
K
K
Kei Kebreau wrote on 5 Jan 2020 17:18
[PATCH 3/3] gnu: gnucash: Update to 3.8b.
(address . 38947@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20200105161806.1982-1-kkebreau@posteo.net
* gnu/packages/gnucash.scm (gnucash): Update to 3.8b.
[arguments]: Remove '-DWITH_OFX=OFF' configure flag to enable libofx support.
[inputs]: Add libofx.
[propagated-inputs]: Add dconf.
(gnucash-docs): Update to 3.8.
---
gnu/packages/gnucash.scm | 268 ++++++++++++++++++++-------------------
1 file changed, 136 insertions(+), 132 deletions(-)

Toggle diff (302 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index af017e108d..9a26ef45ac 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages finance)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages glib)
@@ -54,136 +55,139 @@
(define-public gnucash
;; TODO: Unbundle libraries such as guile-json found under the "borrowed/"
;; directory.
- (package
- (name "gnucash")
- (version "3.7")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
- version "/gnucash-" version ".tar.bz2"))
- (sha256
- (base32
- "1d2qi3ny0bxa16ifh3465z1jgn1l0fmqk9dkph4ialw076gv13kb"))))
- (build-system cmake-build-system)
- (inputs
- `(("guile" ,guile-2.2)
- ("boost" ,boost)
- ("icu4c" ,icu4c)
- ("glib" ,glib)
- ("gtk" ,gtk+)
- ("libdbi" ,libdbi)
- ("libdbi-drivers" ,libdbi-drivers)
- ("libgnomecanvas" ,libgnomecanvas)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)
- ("webkitgtk" ,webkitgtk)
- ("aqbanking" ,aqbanking)
- ("perl-date-manip" ,perl-date-manip)
- ("perl-finance-quote" ,perl-finance-quote)
- ("tzdata" ,tzdata-for-tests)))
- (native-inputs
- `(("glib" ,glib "bin") ; glib-compile-schemas, etc.
- ("intltool" ,intltool)
- ("googlemock" ,(package-source googletest))
- ("googletest" ,googletest)
- ("gnucash-docs" ,gnucash-docs)
- ("pkg-config" ,pkg-config)))
- (outputs '("out" "doc" "debug"))
- (arguments
- `(#:test-target "check"
- #:configure-flags
- (list "-DWITH_OFX=OFF") ; libofx is not available yet
- #:make-flags '("GUILE_AUTO_COMPILE=0")
- #:modules ((guix build cmake-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
- (guix build utils))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build cmake-build-system)
- (guix build glib-or-gtk-build-system))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'unpack-gmock
- (lambda* (#:key inputs #:allow-other-keys)
- (mkdir "gmock")
- (copy-recursively (assoc-ref inputs "googlemock") "gmock")
- (setenv "GMOCK_ROOT" (string-append (getcwd) "/gmock/googlemock"))
- #t))
- (add-after 'unpack 'set-env-vars
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((tzdata (assoc-ref inputs "tzdata")))
- ;; At least one test is time-related and requires this
- ;; environment variable.
- (setenv "TZDIR"
- (string-append tzdata
- "/share/zoneinfo"))
- (substitute* "CMakeLists.txt"
- (("set\\(SHELL /bin/bash\\)")
- (string-append "set(SHELL " (which "bash") ")")))
- #t)))
- ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
- ;; execute them with perl, so execute them directly instead.
- (add-after 'unpack 'fix-finance-quote-check
- (lambda _
- (substitute* "libgnucash/scm/price-quotes.scm"
- (("\"perl\" \"-w\" ") ""))
- #t))
- ;; The qof test requires the en_US, en_GB, and fr_FR locales.
- (add-before 'check 'install-locales
- (lambda _
- (setenv "LOCPATH" (getcwd))
- (invoke "localedef" "-i" "en_US" "-f" "UTF-8" "./en_US.UTF-8")
- (invoke "localedef" "-i" "en_GB" "-f" "UTF-8" "./en_GB.UTF-8")
- (invoke "localedef" "-i" "fr_FR" "-f" "UTF-8" "./fr_FR.UTF-8")
- #t))
- ;; There are about 100 megabytes of documentation.
- (add-after 'install 'install-docs
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((docs (assoc-ref inputs "gnucash-docs"))
- (doc-output (assoc-ref outputs "doc")))
- (mkdir-p (string-append doc-output "/share"))
- (symlink (string-append docs "/share/gnome")
- (string-append doc-output "/share/gnome"))
- #t)))
- (add-after 'install-docs 'wrap-programs
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (for-each (lambda (prog)
- (wrap-program (string-append (assoc-ref outputs "out")
- "/bin/" prog)
- `("GNC_DBD_DIR" =
- (,(string-append
- (assoc-ref inputs "libdbi-drivers")
- "/lib/dbd")))
- `("PERL5LIB" ":" prefix
- ,(map (lambda (o)
- (string-append o "/lib/perl5/site_perl/"
- ,(package-version perl)))
- (if (string=? prog "gnc-fq-helper")
- (list
- ,@(transitive-input-references
- 'inputs
- (map (lambda (l)
- (assoc l (package-inputs this-package)))
- '("perl-finance-quote"
- "perl-date-manip"))))
- (list
- ,@(transitive-input-references
- 'inputs
- (map (lambda (l)
- (assoc l (package-inputs this-package)))
- '("perl-finance-quote")))))))))
- '("gnucash"
- "gnc-fq-check"
- "gnc-fq-helper"
- "gnc-fq-dump"))))
- (add-after 'install 'glib-or-gtk-compile-schemas
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
- (add-after 'install 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
- (home-page "https://www.gnucash.org/")
- (synopsis "Personal and small business financial accounting software")
- (description
- "GnuCash is personal and professional financial-accounting software.
+ (let ((revision "b"))
+ (package
+ (name "gnucash")
+ (version "3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
+ version "/gnucash-" version revision ".tar.bz2"))
+ (sha256
+ (base32
+ "0dvzm3bib7jcj685sklpzyy9mrak9mxyvih2k9fk4sl3v21wlphg"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("boost" ,boost)
+ ("icu4c" ,icu4c)
+ ("glib" ,glib)
+ ("gtk" ,gtk+)
+ ("libdbi" ,libdbi)
+ ("libdbi-drivers" ,libdbi-drivers)
+ ("libgnomecanvas" ,libgnomecanvas)
+ ("libofx" ,libofx)
+ ("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
+ ("webkitgtk" ,webkitgtk)
+ ("aqbanking" ,aqbanking)
+ ("perl-date-manip" ,perl-date-manip)
+ ("perl-finance-quote" ,perl-finance-quote)
+ ("tzdata" ,tzdata-for-tests)))
+ (native-inputs
+ `(("glib" ,glib "bin") ; glib-compile-schemas, etc.
+ ("intltool" ,intltool)
+ ("googlemock" ,(package-source googletest))
+ ("googletest" ,googletest)
+ ("gnucash-docs" ,gnucash-docs)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ ;; dconf is required at runtime according to README.dependencies.
+ `(("dconf" ,dconf)))
+ (outputs '("out" "doc" "debug"))
+ (arguments
+ `(#:test-target "check"
+ #:make-flags '("GUILE_AUTO_COMPILE=0")
+ #:modules ((guix build cmake-build-system)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (guix build utils))
+ #:imported-modules (,@%gnu-build-system-modules
+ (guix build cmake-build-system)
+ (guix build glib-or-gtk-build-system))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-gmock
+ (lambda* (#:key inputs #:allow-other-keys)
+ (mkdir "gmock")
+ (copy-recursively (assoc-ref inputs "googlemock") "gmock")
+ (setenv "GMOCK_ROOT" (string-append (getcwd) "/gmock/googlemock"))
+ #t))
+ (add-after 'unpack 'set-env-vars
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((tzdata (assoc-ref inputs "tzdata")))
+ ;; At least one test is time-related and requires this
+ ;; environment variable.
+ (setenv "TZDIR"
+ (string-append tzdata
+ "/share/zoneinfo"))
+ (substitute* "CMakeLists.txt"
+ (("set\\(SHELL /bin/bash\\)")
+ (string-append "set(SHELL " (which "bash") ")")))
+ #t)))
+ ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
+ ;; execute them with perl, so execute them directly instead.
+ (add-after 'unpack 'fix-finance-quote-check
+ (lambda _
+ (substitute* "libgnucash/scm/price-quotes.scm"
+ (("\"perl\" \"-w\" ") ""))
+ #t))
+ ;; The qof test requires the en_US, en_GB, and fr_FR locales.
+ (add-before 'check 'install-locales
+ (lambda _
+ (setenv "LOCPATH" (getcwd))
+ (invoke "localedef" "-i" "en_US" "-f" "UTF-8" "./en_US.UTF-8")
+ (invoke "localedef" "-i" "en_GB" "-f" "UTF-8" "./en_GB.UTF-8")
+ (invoke "localedef" "-i" "fr_FR" "-f" "UTF-8" "./fr_FR.UTF-8")
+ #t))
+ ;; There are about 100 megabytes of documentation.
+ (add-after 'install 'install-docs
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((docs (assoc-ref inputs "gnucash-docs"))
+ (doc-output (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc-output "/share"))
+ (symlink (string-append docs "/share/gnome")
+ (string-append doc-output "/share/gnome"))
+ #t)))
+ (add-after 'install-docs 'wrap-programs
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (for-each (lambda (prog)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/" prog)
+ `("GNC_DBD_DIR" =
+ (,(string-append
+ (assoc-ref inputs "libdbi-drivers")
+ "/lib/dbd")))
+ `("PERL5LIB" ":" prefix
+ ,(map (lambda (o)
+ (string-append o "/lib/perl5/site_perl/"
+ ,(package-version perl)))
+ (if (string=? prog "gnc-fq-helper")
+ (list
+ ,@(transitive-input-references
+ 'inputs
+ (map (lambda (l)
+ (assoc l (package-inputs this-package)))
+ '("perl-finance-quote"
+ "perl-date-manip"))))
+ (list
+ ,@(transitive-input-references
+ 'inputs
+ (map (lambda (l)
+ (assoc l (package-inputs this-package)))
+ '("perl-finance-quote")))))))))
+ '("gnucash"
+ "gnc-fq-check"
+ "gnc-fq-helper"
+ "gnc-fq-dump"))))
+ (add-after 'install 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (add-after 'install 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ (home-page "https://www.gnucash.org/")
+ (synopsis "Personal and small business financial accounting software")
+ (description
+ "GnuCash is personal and professional financial-accounting software.
It can be used to track bank accounts, stocks, income and expenses, based on
the double-entry accounting practice. It includes support for QIF/OFX/HBCI
import and transaction matching. It also automates several tasks, such as
@@ -191,7 +195,7 @@ financial calculations or scheduled transactions.
To make the GnuCash documentation available, its doc output must be
installed as well as Yelp, the Gnome help browser.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
;; This package is not public, since we use it to build the "doc" output of
;; the gnucash package (see above). It would be confusing if it were public.
@@ -207,7 +211,7 @@ installed as well as Yelp, the Gnome help browser.")
version "/gnucash-docs-" version revision ".tar.gz"))
(sha256
(base32
- "1h4hm58ikffbhplx4gm8pzm9blfwqa1sz8yc2fqi21vs5v0ijf9r"))))
+ "19v6kchda724xkkgwlw5rg21jcpirhch12j9sr6ibnv61sd4ql52"))))
(build-system gnu-build-system)
;; These are native-inputs because they are only required for building the
;; documentation.
--
2.24.1
L
L
Ludovic Courtès wrote on 17 Jan 2020 14:02
Re: [bug#38947] [PATCH 2/3] gnu: Add libofx.
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 38947@debbugs.gnu.org)
87d0bi2q44.fsf@gnu.org
Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/finance.scm (libofx): New variable.

[...]

Toggle quote (3 lines)
> + (synopsis "Library supporting the Open Financial Exchange format")
> + (description
> + "The LibOFX library is a API designed to allow applications to very easily
^
“an”

LGTM!

Ludo’.
L
L
Ludovic Courtès wrote on 17 Jan 2020 14:02
Re: [bug#38947] [PATCH 1/3] gnu: Add opensp.
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 38947@debbugs.gnu.org)
878sm62q3p.fsf@gnu.org
Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/finance.scm (opensp): New variable.

LGTM!
L
L
Ludovic Courtès wrote on 17 Jan 2020 14:02
Re: [bug#38947] [PATCH 3/3] gnu: gnucash: Update to 3.8b.
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 38947@debbugs.gnu.org)
874kwu2q2o.fsf@gnu.org
Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (6 lines)
> * gnu/packages/gnucash.scm (gnucash): Update to 3.8b.
> [arguments]: Remove '-DWITH_OFX=OFF' configure flag to enable libofx support.
> [inputs]: Add libofx.
> [propagated-inputs]: Add dconf.
> (gnucash-docs): Update to 3.8.

In the meantime Gnucash was updated to 3.8. But anyway, LGTM!

Ludo’.
K
K
Kei Kebreau wrote on 17 Jan 2020 21:21
Re: [bug#38947] [PATCH 1/3] gnu: Add opensp.
(address . 38947-done@debbugs.gnu.org)
87r1zxu957.fsf@posteo.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (6 lines)
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/finance.scm (opensp): New variable.
>
> LGTM!

Pushed to master as 63ca1a89086574c52eeab8f223687e8614e33ffe.
Closed
K
K
Kei Kebreau wrote on 17 Jan 2020 21:28
Re: [bug#38947] [PATCH 3/3] gnu: gnucash: Update to 3.8b.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38947@debbugs.gnu.org)
87k15pu8st.fsf@posteo.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/gnucash.scm (gnucash): Update to 3.8b.
>> [arguments]: Remove '-DWITH_OFX=OFF' configure flag to enable libofx support.
>> [inputs]: Add libofx.
>> [propagated-inputs]: Add dconf.
>> (gnucash-docs): Update to 3.8.
>
> In the meantime Gnucash was updated to 3.8. But anyway, LGTM!
>
> Ludo’.

Pushed to master as commits 63ca1a89 through 8b08cf4f. Thanks for
reviewing!

Kei
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38947@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38947
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch