[PATCH] gnu: Add swh-plugins.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Oleg Pykhalov
Owner
unassigned
Submitted by
Oleg Pykhalov
Severity
normal

Debbugs page

Oleg Pykhalov wrote 5 years ago
(address . guix-patches@gnu.org)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20200105051745.7845-1-go.wigust@gmail.com
* gnu/packages/audio.scm (swh-plugins): New variable.
---
gnu/packages/audio.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a26fbed461..acc443839f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
@@ -722,6 +722,36 @@ performances. The plugins include a cellular automaton synthesizer, an
envelope follower, distortion effects, tape effects and more.")
(license license:gpl2+)))
+(define-public swh-plugins
+ (package
+ (name "swh-plugins")
+ (version "0.4.17")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swh/ladspa.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c98z2xxz9pgcb4dg99gz8qrylh5cnag0j18a52d88ifsy24isvq"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal) ;for autopoint
+ ("libtool" ,libtool)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("fftwf" ,fftwf)
+ ("perl-xml-parser" ,perl-xml-parser)))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/swh/ladspa/")
+ (synopsis "The SWH Plugins package for the LADSPA plugin system")
+ (description "This package provides Steve Harris's LADSPA plugins.")
+ (license license:gpl2+)))
+
(define-public swh-plugins-lv2
(package
(name "swh-plugins-lv2")
--
2.24.1
Danny Milosavljevic wrote 5 years ago
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 38939@debbugs.gnu.org)
20200105112233.7b733b7d@scratchpost.org
LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl4RuOkACgkQ5xo1VCww
uqUtEgf/ROg98z/9HQnv211cUB4tswJ23tNpBhRbRLm4koOnOObZaDkUmTGwrzoQ
yA2n5Y9A+DuGb3gVbkY31MMuCX3S+ppHjMmFi49nhcWXF0MsimtfNso3cYP8U+pX
tySMSH5XiToBSOdD80FBiBscNsLW27B+1Occ4QFZszCwEAbwjNfEHqj8RkZxT9oI
R2FFKcqle5LlUrDO8ok3l4LUNzgSeDCBAaY8Sxu205N1cGvGpedmMpIaDPcnYUG+
/M1/82CrmRFB/QM1rG1+uLS9bLzp10MzamFkwK6oRnOpess6iJiPBQIkoqBDD9qB
3yZCCn7JKY8JLPNoS/M0aTeL5UnK5w==
=ZuD6
-----END PGP SIGNATURE-----


Oleg Pykhalov wrote 5 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 38939-done@debbugs.gnu.org)
87blri9dpk.fsf@gmail.com
Hi,

Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (2 lines)
> LGTM!

Thank you for review. Pushed to master as
7366d83191e4cdebc0fb81728f79a3d576fef73b.

Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl4R81cACgkQFn+OpQAa
+pzCLg//ZxiJt1HjjXGfQFgmE51AHtz6GilUFZG/pVT9moAb+6KHD2qkyxfnzqsT
2nlMU1Zs8fqm9WBuuN7e0dsOSGzhyz2G4zVwODwh73pVkcFkFsoe0YBLByRorwZS
1CIWcztcnxp6E9eWKzNBthMrwn21xIGR9lz20ck4wCkIM44lntmQQXO5p5hsC7S8
Fjk/YB6TGvmZvAEWzwf+aCNAzMhyilsPJ3O3n+HRcojsO+j9yb9wMjBtnSQ8grJS
ypWgleq0w5j1qC4u7HCQZhXNAfmNpEUqudgvSfGOZd607iHeCl6FMkJEidU7xMTu
bzyIT8/cRCiTnVygWcXC3GHrtrSgbJrsrsk17xoa+dEev6XMQ+nqGVrSMjwu6hWF
+rsuFLd4S2KBREJgBPWsmzkUHaeNaV4Izkm0EFw2/adOJ62jEqZk1vnQc1Zx8+PC
Ja1ekXVrB2e3BYCqPyHzEdn/jp1L96/6jNs/U4EuBU6femI4QJ9j7lVC2mLsX2XH
oCglGzR8IT2RFlPkwjAx6jBhfM2VDGDYEr08eJ5+YwYU0dClKZde5DEG1PWPgU1Y
cpEOAhBTFAdyxG05f3BNR5rLwPaWsBpAZyVF7jFOAIAT9YL/t8r99oi5iaz6VZUY
RAcjjH506jQPpQOE2i5B9cxlGkb1h9KU1I4Nv3PdVBdwafUx2/Y=
=+sGQ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38939@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38939
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help