[PATCH] gnu: Add xcur2png.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Leo Prikler
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
20200102202336.20617-1-leo.prikler@student.tugraz.at
* gnu/packages/xorg.scm (xcur2png): New variable.
---
gnu/packages/xorg.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fda61aff67..1c21a1cf86 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6425,3 +6425,29 @@ Thai).")
;; by simple permissive licenses. See the 'COPYRIGHT' file.
(license (list license:gpl2+
license:expat))))
+
+(define-public xcur2png
+ (package
+ (name "xcur2png")
+ (version "0.7.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eworm-de/xcur2png.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0858wn2p14bxpv9lvaz2bz1rk6zk0g8zgxf8iy595m8fqv4q2fya"))))
+ (build-system gnu-build-system)
+ (synopsis "Decode X cursors")
+ (description
+ "xcur2png is a program decomposes an X cursor into a set of PNG images and
+a configuration file reusable by xcursorgen.")
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libpng" ,libpng)
+ ("libxcursor" ,libxcursor)))
+ (home-page "https://github.com/eworm-de/xcur2png")
+ (license license:gpl3+)))
--
2.24.1
Brett Gilio wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 38877@debbugs.gnu.org)
87k167zvs0.fsf@gnu.org
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (40 lines)
> * gnu/packages/xorg.scm (xcur2png): New variable.
> ---
> gnu/packages/xorg.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
> index fda61aff67..1c21a1cf86 100644
> --- a/gnu/packages/xorg.scm
> +++ b/gnu/packages/xorg.scm
> @@ -6425,3 +6425,29 @@ Thai).")
> ;; by simple permissive licenses. See the 'COPYRIGHT' file.
> (license (list license:gpl2+
> license:expat))))
> +
> +(define-public xcur2png
> + (package
> + (name "xcur2png")
> + (version "0.7.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/eworm-de/xcur2png.git")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0858wn2p14bxpv9lvaz2bz1rk6zk0g8zgxf8iy595m8fqv4q2fya"))))
> + (build-system gnu-build-system)
> + (synopsis "Decode X cursors")
> + (description
> + "xcur2png is a program decomposes an X cursor into a set of PNG images and
> +a configuration file reusable by xcursorgen.")
> + (native-inputs
> + `(("pkg-config" ,pkg-config)))
> + (inputs
> + `(("libpng" ,libpng)
> + ("libxcursor" ,libxcursor)))
> + (home-page "https://github.com/eworm-de/xcur2png")
> + (license license:gpl3+)))

Hey Leo! It doesn't really matter all that much, but I am curious about
the ordering of the package declaration. Why did you put the inputs
/after/ the synopsis and description? It's a fine looking package otherwise!

--
Brett M. Gilio
GNU Guix, Contributor | GNU Project, Webmaster
[DFC0 C7F7 9EE6 0CA7 AE55 5E19 6722 43C4 A03F 0EEE]
<brettg@gnu.org> <brettg@posteo.net>
Leo Prikler wrote 5 years ago
[PATCH] gnu: Add xcur2png
(address . guix-patches@gnu.org)(address . 38877@debbugs.gnu.org)
20200104165430.18747-1-leo.prikler@student.tugraz.at
* gnu/packages/xorg.scm (xcur2png): New variable.
---
gnu/packages/xorg.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fda61aff67..63a84bb2ef 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6425,3 +6425,29 @@ Thai).")
;; by simple permissive licenses. See the 'COPYRIGHT' file.
(license (list license:gpl2+
license:expat))))
+
+(define-public xcur2png
+ (package
+ (name "xcur2png")
+ (version "0.7.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eworm-de/xcur2png.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0858wn2p14bxpv9lvaz2bz1rk6zk0g8zgxf8iy595m8fqv4q2fya"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libpng" ,libpng)
+ ("libxcursor" ,libxcursor)))
+ (synopsis "Decode X cursors")
+ (description
+ "xcur2png is a program decomposes an X cursor into a set of PNG images and
+a configuration file reusable by xcursorgen.")
+ (home-page "https://github.com/eworm-de/xcur2png")
+ (license license:gpl3+)))
--
2.24.1
Nicolas Goaziou wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 38877-done@debbugs.gnu.org)
87pnfyu2y5.fsf@nicolasgoaziou.fr
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (2 lines)
> * gnu/packages/xorg.scm (xcur2png): New variable.

Applied. I also added a copyright line for you.

Thank you!

Regards,

--
Nicolas Goaziou
Closed
Brett Gilio wrote 5 years ago
Re: [bug#38922] [PATCH] gnu: Add xcur2png
87ftgtuebv.fsf@gnu.org
This package was signed-off by Nicolas Goaziou (cc) with commit
fe0686864dc57ecdda7ecbb318d2618ac46169ae.

Closing, thanks!

--
Brett M. Gilio
GNU Guix, Contributor | GNU Project, Webmaster
[DFC0 C7F7 9EE6 0CA7 AE55 5E19 6722 43C4 A03F 0EEE]
<brettg@gnu.org> <brettg@posteo.net>
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38877@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38877
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help