[PATCH] add package definition for liquid-dsp-1.3.2

  • Done
  • quality assurance status badge
Details
4 participants
  • Brett Gilio
  • Christopher Howard
  • Evan Straw
  • Ludovic Courtès
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 5 years ago
(address . guix-patches@gnu.org)
937849de433222cab5f2da618529ce3aad559546.camel@librehacker.com
Patch is attached for a new package definition. It passed all guix lint
checks, except that I received an error from guix lint that it could
not find the CVE json URL. Package builds and passes all tests on x86-
64.

--
Christopher Howard
p: +1 (907) 374-0257
gpg: ADDEAADE5D607C8D (keys.gnupg.net)
From 3c8ccf400dbbf23191b958dfdcef986d1927719c Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Wed, 1 Jan 2020 19:58:25 -0900
Subject: [PATCH] Adds new package liquid-dsp

---
gnu/packages/liquid-dsp.scm | 53 +++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)
create mode 100644 gnu/packages/liquid-dsp.scm

Toggle diff (61 lines)
diff --git a/gnu/packages/liquid-dsp.scm b/gnu/packages/liquid-dsp.scm
new file mode 100644
index 0000000000..dbf40bf821
--- /dev/null
+++ b/gnu/packages/liquid-dsp.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Christopher Howard <christopher@librehacker.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages liquid-dsp)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools))
+
+(define-public liquid-dsp
+ (package
+ (name "liquid-dsp")
+ (version "1.3.2")
+ (source
+ (origin (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/jgaeddert/liquid-dsp.git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)))
+ (inputs
+ `(("fftw" ,fftw)
+ ("fftwf" ,fftwf)))
+ (home-page "https://liquidsdr.org")
+ (synopsis "Signal processing library for software-defined radios written in C")
+ (description
+ "Liquid DSP provides a set of extensible DSP modules that do not
+rely on external dependencies or cumbersome frameworks")
+ (license license:expat)))
--
2.24.1
Ludovic Courtès wrote 5 years ago
(name . Christopher Howard)(address . christopher@librehacker.com)(address . 38865@debbugs.gnu.org)
87d0bss243.fsf@gnu.org
Hi,

Christopher Howard <christopher@librehacker.com> skribis:

Toggle quote (5 lines)
> Patch is attached for a new package definition. It passed all guix lint
> checks, except that I received an error from guix lint that it could
> not find the CVE json URL. Package builds and passes all tests on x86-
> 64.

Oh, the CVE error is weird; could you paste it?

Toggle quote (8 lines)
> From 3c8ccf400dbbf23191b958dfdcef986d1927719c Mon Sep 17 00:00:00 2001
> From: Christopher Howard <christopher@librehacker.com>
> Date: Wed, 1 Jan 2020 19:58:25 -0900
> Subject: [PATCH] Adds new package liquid-dsp
>
> ---
> gnu/packages/liquid-dsp.scm | 53 +++++++++++++++++++++++++++++++++++++

Could you provide a commit log? (See

Overall the patch LGTM; minor comments:

Toggle quote (3 lines)
> --- /dev/null
> +++ b/gnu/packages/liquid-dsp.scm

Packages are usually grouped together in a file that reflect the
category they belong to. Would it make sense to call this file
‘sdr.scm’, and it would eventually include other packages related to
software-defined ratio, or perhaps dsp.scm?

Toggle quote (9 lines)
> +(define-public liquid-dsp
> + (package
> + (name "liquid-dsp")
> + (version "1.3.2")
> + (source
> + (origin (method git-fetch)
> + (uri (git-reference
> + (url (string-append "https://github.com/jgaeddert/liquid-dsp.git"))

No need for ‘string-append’ here. :-)

Toggle quote (2 lines)
> + (synopsis "Signal processing library for software-defined radios written in C")

I’d dropped “written in C” from the synopsis.

Toggle quote (2 lines)
> + (description
> + "Liquid DSP provides a set of extensible DSP modules that do not
^
Please write: “@dfn{digital signal processing} (DSP) modules”, for clarity.

Toggle quote (2 lines)
> +rely on external dependencies or cumbersome frameworks")

Please add a period at the end. Bonus point if you can expound a bit.

Could you send an updated patch?

Thank you!

Ludo’.
Brett Gilio wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87tv52n4ae.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (66 lines)
> Hi,
>
> Christopher Howard <christopher@librehacker.com> skribis:
>
>> Patch is attached for a new package definition. It passed all guix lint
>> checks, except that I received an error from guix lint that it could
>> not find the CVE json URL. Package builds and passes all tests on x86-
>> 64.
>
> Oh, the CVE error is weird; could you paste it?
>
>> From 3c8ccf400dbbf23191b958dfdcef986d1927719c Mon Sep 17 00:00:00 2001
>> From: Christopher Howard <christopher@librehacker.com>
>> Date: Wed, 1 Jan 2020 19:58:25 -0900
>> Subject: [PATCH] Adds new package liquid-dsp
>>
>> ---
>> gnu/packages/liquid-dsp.scm | 53 +++++++++++++++++++++++++++++++++++++
>
> Could you provide a commit log? (See
> <https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html>.)
>
> Overall the patch LGTM; minor comments:
>
>> --- /dev/null
>> +++ b/gnu/packages/liquid-dsp.scm
>
> Packages are usually grouped together in a file that reflect the
> category they belong to. Would it make sense to call this file
> ‘sdr.scm’, and it would eventually include other packages related to
> software-defined ratio, or perhaps dsp.scm?
>
>> +(define-public liquid-dsp
>> + (package
>> + (name "liquid-dsp")
>> + (version "1.3.2")
>> + (source
>> + (origin (method git-fetch)
>> + (uri (git-reference
>> + (url (string-append "https://github.com/jgaeddert/liquid-dsp.git"))
>
> No need for ‘string-append’ here. :-)
>
>> + (synopsis "Signal processing library for software-defined radios written in C")
>
> I’d dropped “written in C” from the synopsis.
>
>> + (description
>> + "Liquid DSP provides a set of extensible DSP modules that do not
> ^
> Please write: “@dfn{digital signal processing} (DSP) modules”, for clarity.
>
>> +rely on external dependencies or cumbersome frameworks")
>
> Please add a period at the end. Bonus point if you can expound a bit.
>
> Could you send an updated patch?
>
> Thank you!
>
> Ludo’.
>
>
>
>

There is also a liquid-dsp patch in #38842 by Evan Straw (cc).

--
Brett M. Gilio
GNU Guix, Contributor | GNU Project, Webmaster
[DFC0 C7F7 9EE6 0CA7 AE55 5E19 6722 43C4 A03F 0EEE]
<brettg@gnu.org> <brettg@posteo.net>
Christopher Howard wrote 5 years ago
87c412487b95a94fcbb7b9cbc133ddb1bd9b7819.camel@librehacker.com
I went ahead and attached the updated patch as originally requested, in
case it is needed. I copied in the description the other uploader had
used since that seemed much better. One difference between my
definition and the other one, is that I include fftw and fftwf as
package inputs. fftw is an optional dependency of liquid-dsp, which I
think does not change the API of liquid-dsp, but does affects the
backend performance.

As far as sdr.scm vs. ham-radio.scm: I am a licensed ham radio operator
(US General Class), but nevertheless SDR and DSP are really not
exclusive to ham radio. Liquid DSP, e.g., could be used in a lot of
non-licensed or commercial-licensed applications (referring to the
frequency license).

--
Christopher Howard
p: +1 (907) 374-0257
gpg: ADDEAADE5D607C8D (keys.gnupg.net)

On Fri, 2020-01-10 at 19:57 -0600, Brett Gilio wrote:
Toggle quote (83 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
> > Hi,
> >
> > Christopher Howard <christopher@librehacker.com> skribis:
> >
> > > Patch is attached for a new package definition. It passed all
> > > guix lint
> > > checks, except that I received an error from guix lint that it
> > > could
> > > not find the CVE json URL. Package builds and passes all tests on
> > > x86-
> > > 64.
> >
> > Oh, the CVE error is weird; could you paste it?
> >
> > > From 3c8ccf400dbbf23191b958dfdcef986d1927719c Mon Sep 17 00:00:00
> > > 2001
> > > From: Christopher Howard <christopher@librehacker.com>
> > > Date: Wed, 1 Jan 2020 19:58:25 -0900
> > > Subject: [PATCH] Adds new package liquid-dsp
> > >
> > > ---
> > > gnu/packages/liquid-dsp.scm | 53
> > > +++++++++++++++++++++++++++++++++++++
> >
> > Could you provide a commit log? (See
> > <
> > https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html>
> > ;.)
> >
> > Overall the patch LGTM; minor comments:
> >
> > > --- /dev/null
> > > +++ b/gnu/packages/liquid-dsp.scm
> >
> > Packages are usually grouped together in a file that reflect the
> > category they belong to. Would it make sense to call this file
> > ‘sdr.scm’, and it would eventually include other packages related
> > to
> > software-defined ratio, or perhaps dsp.scm?
> >
> > > +(define-public liquid-dsp
> > > + (package
> > > + (name "liquid-dsp")
> > > + (version "1.3.2")
> > > + (source
> > > + (origin (method git-fetch)
> > > + (uri (git-reference
> > > + (url (string-append "
> > > https://github.com/jgaeddert/liquid-dsp.git"))
> >
> > No need for ‘string-append’ here. :-)
> >
> > > + (synopsis "Signal processing library for software-defined
> > > radios written in C")
> >
> > I’d dropped “written in C” from the synopsis.
> >
> > > + (description
> > > + "Liquid DSP provides a set of extensible DSP modules that
> > > do not
> > ^
> > Please write: “@dfn{digital signal processing} (DSP) modules”, for
> > clarity.
> >
> > > +rely on external dependencies or cumbersome frameworks")
> >
> > Please add a period at the end. Bonus point if you can expound a
> > bit.
> >
> > Could you send an updated patch?
> >
> > Thank you!
> >
> > Ludo’.
> >
> >
> >
> >
>
> There is also a liquid-dsp patch in #38842 by Evan Straw (cc).
>
From 0064c61e7884c6f7d6356dfa22b04279bc460b2a Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Fri, 10 Jan 2020 21:19:24 -0900
Subject: [PATCH] gnu: Add liquid-dsp.

* gnu/packages/sdr.scm (liquid-dsp): New variable
---
gnu/packages/sdr.scm | 58 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 58 insertions(+)
create mode 100644 gnu/packages/sdr.scm

Toggle diff (66 lines)
diff --git a/gnu/packages/sdr.scm b/gnu/packages/sdr.scm
new file mode 100644
index 0000000000..f6c9050503
--- /dev/null
+++ b/gnu/packages/sdr.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Christopher Howard <christopher@librehacker.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages sdr)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools))
+
+(define-public liquid-dsp
+ (package
+ (name "liquid-dsp")
+ (version "1.3.2")
+ (source
+ (origin (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jgaeddert/liquid-dsp.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)))
+ (inputs
+ `(("fftw" ,fftw)
+ ("fftwf" ,fftwf)))
+ (home-page "https://liquidsdr.org")
+ (synopsis "Signal processing library for software-defined radios")
+ (description
+ "Liquid DSP is a @dfn{digital signal processing} (DSP) library designed
+specifically for software-defined radios on embedded platforms. The aim is to
+provide a lightweight DSP library that does not rely on a myriad of external
+dependencies or proprietary and otherwise cumbersome frameworks. All signal
+processing elements are designed to be flexible, scalable, and dynamic,
+including filters, filter design, oscillators, modems, synchronizers, complex
+mathematical operations, and much more.")
+ (license license:expat)))
--
2.24.1
Ludovic Courtès wrote 5 years ago
(name . Christopher Howard)(address . christopher@librehacker.com)
87imlcph38.fsf@gnu.org
Hello,

Christopher Howard <christopher@librehacker.com> skribis:

Toggle quote (7 lines)
> From 0064c61e7884c6f7d6356dfa22b04279bc460b2a Mon Sep 17 00:00:00 2001
> From: Christopher Howard <christopher@librehacker.com>
> Date: Fri, 10 Jan 2020 21:19:24 -0900
> Subject: [PATCH] gnu: Add liquid-dsp.
>
> * gnu/packages/sdr.scm (liquid-dsp): New variable

Thanks, I’ve added the file to ‘gnu/local.mk’ and committed.

Evan, I hope that’s fine with you! The changes I noticed between both
patches are: Evan’s did not include a dependency on FFTW, and
Christopher’s lives in sdr.scm while Evan’s in ham-radio.scm.

Evan, let us know if it’s fine for the rest of your patches!

Thanks everyone,
Ludo’.
Closed
Evan Straw wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
ca311c53-d0db-4570-bb25-3d7b57161dcb@localhost
Hi,
I think the only problem that this will introduce is that my redsea package definition in my third patch depends on the definition for liquid-dsp being in the same file, so an import will have to be added. I can submit a revision for this in a few hours when I get back on my PC, if needed.

--Evan

Jan 15, 2020 1:04:00 PM Ludovic Courtès <ludo@gnu.org>:

Toggle quote (24 lines)
> Hello,
>
> Christopher Howard <christopher@librehacker.com> skribis:
>
>
> > From 0064c61e7884c6f7d6356dfa22b04279bc460b2a Mon Sep 17 00:00:00 2001
> > From: Christopher Howard <christopher@librehacker.com>
> > Date: Fri, 10 Jan 2020 21:19:24 -0900
> > Subject: [PATCH] gnu: Add liquid-dsp.
> >
> > * gnu/packages/sdr.scm (liquid-dsp): New variable
> >
>
> Thanks, I’ve added the file to ‘gnu/local.mk’ and committed.
>
> Evan, I hope that’s fine with you! The changes I noticed between both
> patches are: Evan’s did not include a dependency on FFTW, and
> Christopher’s lives in sdr.scm while Evan’s in ham-radio.scm.
>
> Evan, let us know if it’s fine for the rest of your patches!
>
> Thanks everyone,
> Ludo’.
>
Attachment: signature.asc
Closed
Ludovic Courtès wrote 5 years ago
(name . Evan Straw)(address . evan.straw99@gmail.com)
87h80vg4js.fsf@gnu.org
Hi Evan,

Evan Straw <evan.straw99@gmail.com> skribis:

Toggle quote (2 lines)
> I think the only problem that this will introduce is that my redsea package definition in my third patch depends on the definition for liquid-dsp being in the same file, so an import will have to be added. I can submit a revision for this in a few hours when I get back on my PC, if needed.

Sure, no rush. An option would be to move all your packages to sdr.scm
(“SDR” is a superset of “ham radio”, after all). WDYT?

Thanks,
Ludo’.
Closed
Christopher Howard wrote 5 years ago
27914b6c6988025b381f18431f5dbddc28fa6ea4.camel@librehacker.com
Most of the things currently in and proposed for ham-radio.scm would
fit also under the category of SDR. The one exception would be the
"chirp" package, which is not precisely an SDR application, but a tool
for reprogramming radios. But it might be close enough to be
practically lumped into that file. Strickly speaking, chirp is not
exclusively a ham radio tool other, but could be used by anyone
commercial or otherwise who needed to reprogram a radio.

--
Christopher Howard
p: +1 (907) 374-0257
gpg: ADDEAADE5D607C8D (keys.gnupg.net)

On Thu, 2020-01-16 at 09:59 +0100, Ludovic Courtès wrote:
Toggle quote (16 lines)
> Hi Evan,
>
> Evan Straw <evan.straw99@gmail.com> skribis:
>
> > I think the only problem that this will introduce is that my redsea
> > package definition in my third patch depends on the definition for
> > liquid-dsp being in the same file, so an import will have to be
> > added. I can submit a revision for this in a few hours when I get
> > back on my PC, if needed.
>
> Sure, no rush. An option would be to move all your packages to
> sdr.scm
> (“SDR” is a superset of “ham radio”, after all). WDYT?
>
> Thanks,
> Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38865@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38865
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help