Christopher Howard wrote 5 years ago
(address . guix-patches@gnu.org)
Patch is attached for a new package definition. It passed all guix lint
checks, except that I received an error from guix lint that it could
not find the CVE json URL. Package builds and passes all tests on x86-
64.
--
Christopher Howard
p: +1 (907) 374-0257
gpg: ADDEAADE5D607C8D (keys.gnupg.net)
From 3c8ccf400dbbf23191b958dfdcef986d1927719c Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Wed, 1 Jan 2020 19:58:25 -0900
Subject: [PATCH] Adds new package liquid-dsp
---
gnu/packages/liquid-dsp.scm | 53 +++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)
create mode 100644 gnu/packages/liquid-dsp.scm
Toggle diff (61 lines)
diff --git a/gnu/packages/liquid-dsp.scm b/gnu/packages/liquid-dsp.scm
new file mode 100644
index 0000000000..dbf40bf821
--- /dev/null
+++ b/gnu/packages/liquid-dsp.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Christopher Howard <christopher@librehacker.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages liquid-dsp)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools))
+
+(define-public liquid-dsp
+ (package
+ (name "liquid-dsp")
+ (version "1.3.2")
+ (source
+ (origin (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/jgaeddert/liquid-dsp.git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)))
+ (inputs
+ `(("fftw" ,fftw)
+ ("fftwf" ,fftwf)))
+ (home-page "https://liquidsdr.org")
+ (synopsis "Signal processing library for software-defined radios written in C")
+ (description
+ "Liquid DSP provides a set of extensible DSP modules that do not
+rely on external dependencies or cumbersome frameworks")
+ (license license:expat)))
--
2.24.1