[PATCH] gnu: arandr: Fix build.

  • Done
  • quality assurance status badge
Details
One participant
  • Kei Kebreau
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 5 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20191230174205.18101-1-kkebreau@posteo.net
This is a follow-up to commit 218c785850d5ecf3a7646d81ce90445419a5103b.

[arguments]: Remove unnecessary #:python flag. Add 'wrap-gi-typelib' phase.
[inputs]: Remove python2-pygtk and add gtk+, python-pycairo, and
python-pygobject.
[native-inputs]: Replace python2-docutils with python-docutils.
---
gnu/packages/xdisorg.scm | 16 ++++++++++++----
1 file changed, 12 insertions(+), 4 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9b198a02da..ecf8973a82 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -115,20 +115,28 @@
#t))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2 ;incompatible with python 3
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-before 'build 'configure
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "screenlayout/xrandr.py"
(("\"xrandr\"") (string-append "\"" (assoc-ref inputs "xrandr")
"/bin/xrandr\"")))
+ #t))
+ (add-after 'install 'wrap-gi-typelib
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (wrap-program (string-append out "/bin/arandr")
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
#t)))
#:tests? #f)) ;no tests
- (inputs `(("pygtk" ,python2-pygtk)
+ (inputs `(("gtk+" ,gtk+)
+ ("pycairo" ,python-pycairo)
+ ("pygobject" ,python-pygobject)
("xrandr" ,xrandr)))
(native-inputs `(("gettext" ,gettext-minimal)
- ("python-docutils" ,python2-docutils)))
+ ("python-docutils" ,python-docutils)))
(home-page "https://christian.amsuess.com/tools/arandr/")
(synopsis "Another RandR graphical user interface")
;; TRANSLATORS: "X11 resize-and-rotate" should not be translated.
--
2.24.1
Kei Kebreau wrote 5 years ago
(address . 38820-done@debbugs.gnu.org)
878smllvmw.fsf@posteo.net
Since there have been no complaints and this is a minor change, I've
pushed it as commit 06c8e87224decebc0a3d5bdc7d2ca13cb2b08299 on master.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38820@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38820
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help