[PATCH] gnu: Add ghc-filepath-bytestring.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Kyle Meyer
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 5 years ago
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20191229060905.769-1-kyle@kyleam.com
* gnu/packages/haskell-xyz.scm (ghc-filepath-bytestring): New variable.
---
The next release of git-annex (the current is 7.20191218) will depend on this
package.

gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fb6833207d..13e313820c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3998,6 +3998,30 @@ (define-public ghc-filemanip
file contents, and more.")
(license license:bsd-3)))
+(define-public ghc-filepath-bytestring
+ (package
+ (name "ghc-filepath-bytestring")
+ (version "1.4.2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/filepath-bytestring/"
+ "filepath-bytestring-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06shdskjj391hb9295slm9gg2rbn5fdq5v6fg0mgn3yl5dv8q5dx"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "http://hackage.haskell.org/package/filepath-bytestring")
+ (synopsis "Library for manipulating RawFilePaths in a cross-platform way")
+ (description "This package provides a drop-in replacement for the standard
+@code{filepath} library, operating on @code{RawFilePath} values rather than
+@code{FilePath} values to get the speed benefits of using
+@code{ByteStrings}.")
+ (license license:bsd-3)))
+
(define-public ghc-findbin
(package
(name "ghc-findbin")

base-commit: 34085eabccb8a0ca280f8d1605fdf369a94dd88a
--
2.24.1
Efraim Flashner wrote 5 years ago
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 38787-done@debbugs.gnu.org)
20191229075723.GA23018@E5400
Looks good. Patch pushed!


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl4IXGMACgkQQarn3Mo9
g1Eqjw/8DytsPBuhnpQfxF0JdLkpArF018ErkcdpQXGeBPXvqf0gasT3Hr6j6s8C
xMqmS4M2dUTY9oXN+5NAWRawi1Zw92wxXxai8ODbidVvQbMclqEDJ5vbnPERnjBu
XAPWGDI86DpeQQyyrMErLyehg7SqDYtSbJnzdcBLxrQJ0BceSGg/hPn252VmHmtD
1CrXmwcGsS0wFxYF9kEA9aBStz6K3+WINoJOCxXAvixvzgr5gaLhzb92ohQmODJC
duY/Gjgcz7O7VbWYwI21XA02nccrvtG4JFWR2BPj0XeG+6YHaR41Iw34+qAuA9UZ
+y/sx2p3PryD5MnxFRO7PX6Bc1u7vlpnhTrf9REnX869+PqjldrwbMszB9LIdl2S
TIPU+Y45+/zlW4gGF2PDiLrwD5zL3pblocn94SCsrX4sIZE4gugJm6KMWqcPkJJp
9eI1mJUy3g7hChPqBsbBOIqvMXRRsqX/yJMph+d681BOc99Qqy9KTkwpV4UL53v4
oxZVxKBuCPdqV87dyOTLfrPSh7bToaE9kM9hSDTP/2KZc3czVjlHYK6aRMSrMFat
TuWACe7cPIkcQhSsUG3DVe7I4KuF96mtalCPlmF4IbhIgasWDxQ94NknyaEqeG68
12pbhA1awbPkih4USA2P2dhPcNzY3txaOsdGyYBCcGrw8JBjf7c=
=ncgu
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38787@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38787
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help