[PATCH] Add C++ bindings to Portaudio

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal

Debbugs page

Nicolas Goaziou wrote 5 years ago
(address . guix-patches@gnu.org)
87a77d3957.fsf@nicolasgoaziou.fr
Hello,

The following patch enables C++ bindings for our Portaudio package.

Regards,

--
Nicolas Goaziou
From a771f96fc319e1ece917532253c44b57494d0e32 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Fri, 27 Dec 2019 19:33:50 +0100
Subject: [PATCH] gnu: portaudio: Add C++ bindings.

* gnu/packages/audio.scm (portaudio): Add C++ bindings, aka "portaudiocpp".
---
gnu/packages/audio.scm | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 76c59f33cc..73235ef292 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2872,8 +2872,13 @@ portions of LAME.")
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(arguments
- '(#:tests? #f ;no 'check' target
- #:configure-flags '("--with-pic")
+ '(#:tests? #f ;no 'check' target
+ #:configure-flags '("--with-pic"
+ "--enable-cxx"
+ ;; XXX: The following prevents a build error
+ ;; because of missing depcomp when C++ bindings are
+ ;; requested.
+ "--disable-dependency-tracking")
#:phases
(modify-phases %standard-phases
;; This is needed for linking the static libraries
--
2.24.1
Efraim Flashner wrote 5 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 38765@debbugs.gnu.org)
20191228195423.GS23018@E5400
LGTM!


On Fri, Dec 27, 2019 at 07:39:48PM +0100, Nicolas Goaziou wrote:
Toggle quote (44 lines)
> Hello,
>
> The following patch enables C++ bindings for our Portaudio package.
>
> Regards,
>
> --
> Nicolas Goaziou

> From a771f96fc319e1ece917532253c44b57494d0e32 Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Fri, 27 Dec 2019 19:33:50 +0100
> Subject: [PATCH] gnu: portaudio: Add C++ bindings.
>
> * gnu/packages/audio.scm (portaudio): Add C++ bindings, aka "portaudiocpp".
> ---
> gnu/packages/audio.scm | 9 +++++++--
> 1 file changed, 7 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 76c59f33cc..73235ef292 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -2872,8 +2872,13 @@ portions of LAME.")
> ("libtool" ,libtool)
> ("pkg-config" ,pkg-config)))
> (arguments
> - '(#:tests? #f ;no 'check' target
> - #:configure-flags '("--with-pic")
> + '(#:tests? #f ;no 'check' target
> + #:configure-flags '("--with-pic"
> + "--enable-cxx"
> + ;; XXX: The following prevents a build error
> + ;; because of missing depcomp when C++ bindings are
> + ;; requested.
> + "--disable-dependency-tracking")
> #:phases
> (modify-phases %standard-phases
> ;; This is needed for linking the static libraries
> --
> 2.24.1
>


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl4Hsu4ACgkQQarn3Mo9
g1HkmQ/9FFrUUkshy1PMeBKid0YowO+T9O/CW3Hp6b1KP0Pp5rSeH4Mzf/3dKc5h
LjPbI8rv6qSzBv0Uqx6UX6GYHvRx8QDDZ/aMBPdVeQ1/N4WpHjh5fqIkuSraLRH5
y90AGmmk6APz8o7qs26uJivGtei2Ui0zjvckF73Au6uNf5SWetUZQM5StRwOHxKq
6ki0NekSN6Ov0nSQHkysLM6B5TCQQ9KPRLs6QaTtnhD9TO8bOMyH7esP5XBTjU3r
qI+s1/Lt0m4cjn3ul4o6ulL40ErI/HD7qkd9EfA0ED0hNJKPaRW/q7Wo2hiNxIFz
wuyskmq/7StmeKanSlowt8x6oQFid1DESOVlixIRCFSsNLNwiu5DXSFliPrAures
5en9w3gOGACPWwp+X6javVUYdy5+ltfp/ANk4ZzQqWExdRINfLwIQ6O4WCdRlduA
PCnDvPI0qijcgX3toSxfX+HxqNc+yguqRSmzYWGMeyKdYLeS4qPw6KXt7tRiH6hx
jym0rDiSSAI6k/4KuxzMzudUjlmp8mQQDw+7xVEUyQzNYhNiMfCmD6GXWR3yrKHY
iigBvGHBqqw70NwtLOUiLXK7UEKJJK4gjeioHfuAR2PeYXA5kX6hEAkk2/sNuFss
E8uAtO4osvR5FiwCEFRYtJeQEFttCQaXTARM68aC9hiJAcvmzS0=
=1a4a
-----END PGP SIGNATURE-----


Nicolas Goaziou wrote 5 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38765-done@debbugs.gnu.org)
87fth419pu.fsf@nicolasgoaziou.fr
Hello,

Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (2 lines)
> LGTM!

Pushed as 1ce6bfc21ce328d787df76c6ee132f9f828d098b. Thank you.

Regards,

--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38765@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38765
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help