icecat retains reference on clang

  • Open
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Julien Lepiller
  • Ludovic Courtès
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 26 Dec 2019 21:49
(address . bug-guix@gnu.org)
87sgl6olru.fsf@elephly.net
Icecat retains a reference on clang. This is because the file
./chrome/toolkit/content/global/buildconfig.html (inside of
lib/icecat/omni.ja) records configuration options, which include the
location of clang.

This should be removed.

--
Ricardo
R
R
Ricardo Wurmus wrote on 27 Dec 2019 00:08
(address . 38755@debbugs.gnu.org)
87r20qofcb.fsf@elephly.net
This should do the trick:
Toggle diff (17 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index d5d9839e1a..e9458037a5 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1023,7 +1023,11 @@ from forcing GEXP-PROMISE."
(format #t "configure flags: ~s~%" flags)
(apply invoke bash
(string-append srcdir "/configure")
- flags))))
+ flags)
+ ;; Remove references to store items
+ (substitute* "toolkit/content/buildconfig.html"
+ (("/gnu/store") ""))
+ #t)))
(replace 'build
;; The build system often spuriously fails. See
;; <https://bugs.gentoo.org/show_bug.cgi?id=680934>. To
--
Ricardo
L
L
Ludovic Courtès wrote on 28 Dec 2019 01:25
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 38755@debbugs.gnu.org)
8736d5cn3l.fsf@gnu.org
Hi,

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (16 lines)
> This should do the trick:
>
> diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
> index d5d9839e1a..e9458037a5 100644
> --- a/gnu/packages/gnuzilla.scm
> +++ b/gnu/packages/gnuzilla.scm
> @@ -1023,7 +1023,11 @@ from forcing GEXP-PROMISE."
> (format #t "configure flags: ~s~%" flags)
> (apply invoke bash
> (string-append srcdir "/configure")
> - flags))))
> + flags)
> + ;; Remove references to store items
> + (substitute* "toolkit/content/buildconfig.html"
> + (("/gnu/store") ""))

This should not be a literal “/gnu/store”, though. Perhaps we should
just use ‘remove-store-references’ instead of ‘substitute*’?

Thanks,
Ludo’.
E
E
Efraim Flashner wrote on 28 Dec 2019 20:47
(name . Ludovic Courtès)(address . ludo@gnu.org)
20191228194740.GR23018@E5400
On Sat, Dec 28, 2019 at 01:25:50AM +0100, Ludovic Courtès wrote:
Toggle quote (24 lines)
> Hi,
>
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
> > This should do the trick:
> >
> > diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
> > index d5d9839e1a..e9458037a5 100644
> > --- a/gnu/packages/gnuzilla.scm
> > +++ b/gnu/packages/gnuzilla.scm
> > @@ -1023,7 +1023,11 @@ from forcing GEXP-PROMISE."
> > (format #t "configure flags: ~s~%" flags)
> > (apply invoke bash
> > (string-append srcdir "/configure")
> > - flags))))
> > + flags)
> > + ;; Remove references to store items
> > + (substitute* "toolkit/content/buildconfig.html"
> > + (("/gnu/store") ""))
>
> This should not be a literal “/gnu/store”, though. Perhaps we should
> just use ‘remove-store-references’ instead of ‘substitute*’?
>

This way we still get a listing of exactly which store items were used
without needing to refer to them exactly.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl4HsVwACgkQQarn3Mo9
g1HpyRAAoUbnkBRjpnP9HxO46KPi5JnKL35m2KAq7458Sfu1yveIfeK8EQ1MEmw9
ac445LzeY3Bcu/AL6Ez9sHNTbNrrFznJhIwrs6sDqDjhbEZZOBE10Zxh/wLvFow9
zaPQbFDqo+ixdL+UL3V8G9cwfj7WvYJLayXO8uFnthZRa2RA339npHLVBiW6Wrqn
6gru74KTapoNrcRD10IdJDmsfi0B2WKI8TFwTk2IMtHYaOAnZDYGkstSdOgl8Uqq
CjTNsSI4Xb+fpSJZhLsdjmJlr/0mBZGTSyeoxyNMNsSOIfR0ApkeNe+iv8hK3Pkp
WTNqLNRpDtkuUPyLXl9F4sxnN/AAHdDgorzE+xrlZkUYbP+cZxpb7ujxITQMri2n
lLS7mVdEKvgmb1JxQbRuua2K0TwHV4S6tDdW5vy0w7hAx8Y1GGTLL0zfKzTkjXUH
bndQ+n9W4lBBIAxdKgD3fXbwivj4nzOpsas1G9wF6ViZKgV91bpQ9pkmv6F7zV7A
shrKpVraRQt0aQ+Elq7QRmTkBcrnkAxwsL2XLknF2mvJihaQP9rrT3Z6Pr5zzhpe
5ZZwIjfvh38qQQQA2HyXT/MXKE8lNuUVupEuAu9/JTOg5iP9IMOKk29cQC05uHH7
9sWir0aGIqem57TiSosT579SY0GPUYDdDhIizkD8aQDSLstaPiU=
=UVBn
-----END PGP SIGNATURE-----


J
J
Julien Lepiller wrote on 29 Dec 2019 00:05
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38755@debbugs.gnu.org)
FD59D6BF-035A-4F2A-9E48-17176405D0C4@lepiller.eu
Le 28 décembre 2019 20:47:40 GMT+01:00, Efraim Flashner <efraim@flashner.co.il> a écrit :
Toggle quote (28 lines)
>On Sat, Dec 28, 2019 at 01:25:50AM +0100, Ludovic Courtès wrote:
>> Hi,
>>
>> Ricardo Wurmus <rekado@elephly.net> skribis:
>>
>> > This should do the trick:
>> >
>> > diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
>> > index d5d9839e1a..e9458037a5 100644
>> > --- a/gnu/packages/gnuzilla.scm
>> > +++ b/gnu/packages/gnuzilla.scm
>> > @@ -1023,7 +1023,11 @@ from forcing GEXP-PROMISE."
>> > (format #t "configure flags: ~s~%" flags)
>> > (apply invoke bash
>> > (string-append srcdir "/configure")
>> > - flags))))
>> > + flags)
>> > + ;; Remove references to store items
>> > + (substitute* "toolkit/content/buildconfig.html"
>> > + (("/gnu/store") ""))
>>
>> This should not be a literal “/gnu/store”, though. Perhaps we should
>> just use ‘remove-store-references’ instead of ‘substitute*’?
>>
>
>This way we still get a listing of exactly which store items were used
>without needing to refer to them exactly.

It shouldn't be literaly /gnu/store, because one could use a different store path. Can we access the store path from a phase code?
E
E
Efraim Flashner wrote on 29 Dec 2019 08:16
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 38755@debbugs.gnu.org)
20191229071650.GX23018@E5400
On Sun, Dec 29, 2019 at 12:05:28AM +0100, Julien Lepiller wrote:
Toggle quote (31 lines)
> Le 28 décembre 2019 20:47:40 GMT+01:00, Efraim Flashner <efraim@flashner.co.il> a écrit :
> >On Sat, Dec 28, 2019 at 01:25:50AM +0100, Ludovic Courtès wrote:
> >> Hi,
> >>
> >> Ricardo Wurmus <rekado@elephly.net> skribis:
> >>
> >> > This should do the trick:
> >> >
> >> > diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
> >> > index d5d9839e1a..e9458037a5 100644
> >> > --- a/gnu/packages/gnuzilla.scm
> >> > +++ b/gnu/packages/gnuzilla.scm
> >> > @@ -1023,7 +1023,11 @@ from forcing GEXP-PROMISE."
> >> > (format #t "configure flags: ~s~%" flags)
> >> > (apply invoke bash
> >> > (string-append srcdir "/configure")
> >> > - flags))))
> >> > + flags)
> >> > + ;; Remove references to store items
> >> > + (substitute* "toolkit/content/buildconfig.html"
> >> > + (("/gnu/store") ""))
> >>
> >> This should not be a literal “/gnu/store”, though. Perhaps we should
> >> just use ‘remove-store-references’ instead of ‘substitute*’?
> >>
> >
> >This way we still get a listing of exactly which store items were used
> >without needing to refer to them exactly.
>
> It shouldn't be literaly /gnu/store, because one could use a different store path. Can we access the store path from a phase code?

Good point. Perhaps 'remove-store-references' would just be best.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl4IUt4ACgkQQarn3Mo9
g1G0axAAqopA3iejYZxmiBjU49atqi40Qk0ddw78H1jaHqLegyjEWDZwSSR8QM1A
oNxdOMJyvjND8IQAAIHIafhUeZs9xrDMj4tov2QouskraUXU8vRFVoWg+5wyCemo
Xj8Unu7U/t1SuEaUEGWdz9cU9YpEzI4SWp75i79gjWrSjRxY1ShAsgzIV2AxrF4m
l83eL8nuY/Ild67IOx5xPF7ZwAq7fH4YnDI8Mi1FBxMca6vujjniUBpyUnIEOKSq
m6Ik3UImzYE4/q2MCwek0UL5yinplF3fA62D17fT1ilim6+78hpawJhh1JWyTh8I
1/PL69jpQacT1WX5Vps5/TUAUPqkW6hLS9qiB4eypwbQP8PxQqNpmmFx0T+ZtBkT
esnFKzQq23FrJjudoCUxn5Clie6QoeOZyQQ80pM/CgZWFKdJSUxb5oWCDU3mRbPY
siP6MZC5pniNh0RBIE+Ts8Tp8B0M/aMHqMo1JTqS/WwagQuA8RPyWvuXu1SrbED5
NHAV4L/11x1cVBr/3TBnGlc18wcawBW62PZfcM5btxqvOKI8Ceq4+pdKiq9W7OcD
k44nOLxrRf/aN+v7YG5hDTbbXQZwaDd1HuZ2J0P7oiiS84z1swNLEpCCOoKUzGyd
y8zf65NJtRpDx6wv9sxjaR/lE0Ui8cnrUTzUd7sYH89VApJA6Uc=
=uuM9
-----END PGP SIGNATURE-----


?