[PATCH] gnu: tophat: Build with GCC 5

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mădălin Ionel Patrașcu
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 5 years ago
(address . guix-patches@gnu.org)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20191219185331.19702-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/python-xyz.scm (tophat)[native-inputs]: Add gcc-5.
(tophat)[inputs]: Reorder alphabetically the dependencies.
(tophat)[home-page]: Swapp to https.
---
gnu/packages/bioinformatics.scm | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 528b603476..0f6c120687 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;;
@@ -1615,7 +1615,7 @@ genome (2.9 GB for paired-end).")
#t))))
(build-system gnu-build-system)
(arguments
- '(#:parallel-build? #f ; not supported
+ '(#:parallel-build? #f ; not supported
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'use-system-samtools
@@ -1639,16 +1639,18 @@ genome (2.9 GB for paired-end).")
(("#include <bam.h>") "#include <samtools/bam.h>")
(("#include <sam.h>") "#include <samtools/sam.h>"))
#t)))))
+ (native-inputs
+ `(("gcc" ,gcc-5))) ;; doesn't build with later versions
(inputs
`(("boost" ,boost)
("bowtie" ,bowtie)
- ("samtools" ,samtools-0.1)
("ncurses" ,ncurses)
- ("python" ,python-2)
("perl" ,perl)
- ("zlib" ,zlib)
- ("seqan" ,seqan-1)))
- (home-page "http://ccb.jhu.edu/software/tophat/index.shtml")
+ ("python" ,python-2)
+ ("samtools" ,samtools-0.1)
+ ("seqan" ,seqan-1)
+ ("zlib" ,zlib)))
+ (home-page "https://ccb.jhu.edu/software/tophat/index.shtml")
(synopsis "Spliced read mapper for RNA-Seq data")
(description
"TopHat is a fast splice junction mapper for nucleotide sequence
--
2.24.1
Ludovic Courtès wrote 5 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38674-done@debbugs.gnu.org)
87blryj3kq.fsf@gnu.org
Hi,

Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> skribis:

Toggle quote (4 lines)
> * gnu/packages/python-xyz.scm (tophat)[native-inputs]: Add gcc-5.
> (tophat)[inputs]: Reorder alphabetically the dependencies.
> (tophat)[home-page]: Swapp to https.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38674@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38674
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help