[PATCH] gnu: Add python-pathos.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Ludovic Courtès
  • mpatras
  • Ricardo Wurmus
Owner
unassigned
Submitted by
mpatras
Severity
normal

Debbugs page

mpatras wrote 5 years ago
(no subject)
(address . guix-patches@gnu.org)
95665076-db11-fa3e-2d65-853bc061f6b8@mdc-berlin.de
--
Mădălin Ionel Patrașcu

System Administrator
Bioinformatics and Omics Data Science
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Hannoversche Str. 28, 10115 Berlin
House 101, room 1.60
Mădălin Ionel Patrașcu wrote 5 years ago
[PATCH 1/5] gnu: python-dill: Update to 0.3.1.1.
(address . 38652@debbugs.gnu.org)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20191217172437.21217-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/python-xyz.scm (python-dill): Update to 0.3.1.1.
---
gnu/packages/python-xyz.scm | 18 +++++++++++++-----
1 file changed, 13 insertions(+), 5 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f0490f248c..9075dfeb49 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15651,17 +15651,25 @@ object-oriented library such as @code{scikit-learn}.")
(define-public python-dill
(package
(name "python-dill")
- (version "0.2.9")
+ (version "0.3.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "dill" version))
(sha256
- (base32 "0vwqyi6hyz2r29zydc78dqymkbc5y7gia16xcdh215cikxph9mpn"))))
+ (base32 "1704g8z70d210ksgbccs2v545v9w0wc6lx15m296alb7jf0yzn22"))))
(build-system python-build-system)
- ;; FIXME: The check phase fails with "don't know how to make test from: …".
- (arguments '(#:tests? #f))
- (home-page "https://pypi.org/project/dill")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "/tmp"
+ (invoke "nosetests" "-v"))
+ #t)))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://pypi.org/project/dill/")
(synopsis "Serialize all of Python")
(description "Dill extends Python's @code{pickle} module for serializing
and de-serializing Python objects to the majority of the built-in Python
--
2.24.1
Mădălin Ionel Patrașcu wrote 5 years ago
[PATCH 2/5] gnu: python-multiprocess: Update to 0.70.9.
(address . 38652@debbugs.gnu.org)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20191217172437.21217-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/python-xyz.scm (python-multiprocess): Update to 0.70.9.
---
gnu/packages/python-xyz.scm | 16 +++++++++++++---
1 file changed, 13 insertions(+), 3 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9075dfeb49..acc030fb9b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15685,18 +15685,28 @@ the saved state of the original interpreter session.")
(define-public python-multiprocess
(package
(name "python-multiprocess")
- (version "0.70.6.1")
+ (version "0.70.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "multiprocess" version))
(sha256
(base32
- "1ip5caz67b3q0553mr8gm8xwsb8x500jn8ml0gihgyfy52m2ypcq"))))
+ "1r882nvd44xqwbrclwqx5rhs80l6809rcvpc7pkpgnij06cvvmcz"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "/tmp"
+ (invoke "nosetests" "-v"))
+ #t)))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
(propagated-inputs
`(("python-dill" ,python-dill)))
- (home-page "https://pypi.org/project/multiprocess")
+ (home-page "https://pypi.org/project/multiprocess/")
(synopsis "Multiprocessing and multithreading in Python")
(description
"This package is a fork of the multiprocessing Python package, a package
--
2.24.1
Mădălin Ionel Patrașcu wrote 5 years ago
[PATCH 3/5] gnu: Add python-ppft.
(address . 38652@debbugs.gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20191217172437.21217-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/python-xyz.scm (python-ppft): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acc030fb9b..f5b2ff16e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16899,3 +16899,38 @@ always possible to declare a command with the highest possible (and least
flexible) layer and then tune the behaviour with any of the lower layers
including the native API of @code{python-argparse}.")
(license license:lgpl3+))))
+
+(define-public python-ppft
+ (package
+ (name "python-ppft")
+ (version "1.6.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ppft" version))
+ (sha256
+ (base32
+ "1z1invkhszc5d2mvgr221v7cszzifcc77mz0pv3wjp6x5q2768cy"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "/tmp"
+ (invoke "nosetests" "-v"))
+ #t)))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://pypi.org/project/ppft/")
+ (synopsis "Fork of Parallel Python")
+ (description
+ "This package phython-ppft is a fork of Parallel Python, and is developed
+as part of python-pathos. Parallel Python module (pp) provides an easy and
+efficient way to create parallel-enabled applications for SMP (symmetric
+multiprocessing) computers and clusters. pp module features cross-platform
+portability and dynamic load balancing.")
+ ;; looks like bsd-3 https://github.com/uqfoundation/ppft/blob/master/LICENSE
+ (license license:bsd-3)))
--
2.24.1
Mădălin Ionel Patrașcu wrote 5 years ago
[PATCH 4/5] gnu: Add python-pox.
(address . 38652@debbugs.gnu.org)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20191217172437.21217-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/python-xyz.scm (python-pox): New variable.
---
gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f5b2ff16e7..2287903d0b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16934,3 +16934,27 @@ multiprocessing) computers and clusters. pp module features cross-platform
portability and dynamic load balancing.")
;; looks like bsd-3 https://github.com/uqfoundation/ppft/blob/master/LICENSE
(license license:bsd-3)))
+
+(define-public python-pox
+ (package
+ (name "python-pox")
+ (version "0.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pox" version))
+ (sha256
+ (base32
+ "0y17ckc2p6i6709s279sjdj4q459mpcc38ymg9zv9y6vl6jf3bq6"))))
+ (build-system python-build-system)
+ (home-page "https://pypi.org/project/pox/")
+ (synopsis "Python utilities for filesystem exploration and automated builds")
+ (description
+ "Python-pox provides a collection of utilities for navigating and
+manipulating filesystems. This module is designed to facilitate some of the
+low level operating system interactions that are useful when exploring a
+filesystem on a remote host. Python-pox provides python equivalents of several
+unix shell commands such as which and find. These commands allow automated
+discovery of what has been installed on an operating system, and where the
+essential tools are located.")
+ (license license:bsd-3)))
--
2.24.1
Mădălin Ionel Patrașcu wrote 5 years ago
[PATCH 5/5] gnu: Add python-pathos.
(address . 38652@debbugs.gnu.org)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20191217172437.21217-5-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/python-xyz.scm (python-pathos, python2-pathos): New variables.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2287903d0b..edaefe7575 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16958,3 +16958,34 @@ unix shell commands such as which and find. These commands allow automated
discovery of what has been installed on an operating system, and where the
essential tools are located.")
(license license:bsd-3)))
+
+(define-public python-pathos
+ (package
+ (name "python-pathos")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pathos" version))
+ (sha256
+ (base32
+ "0in8hxdz7k081ijn6q94gr39ycy7363sx4zysmbwyvd7snqjrbi1"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dill" ,python-dill)
+ ("python-multiprocess" ,python-multiprocess)
+ ("python-pox" ,python-pox)
+ ("python-ppft" ,python-ppft)))
+ (home-page "https://pypi.org/project/pathos/")
+ (synopsis
+ "Parallel graph management and execution in heterogeneous computing")
+ (description
+ "Python-pathos is a framework for heterogenous computing. It provides a
+consistent high-level interface for configuring and launching parallel
+computations across heterogenous resources. Python-pathos provides configurable
+launchers for parallel and distributed computing, where each launcher contains
+the syntactic logic to configure and launch jobs in an execution environment.")
+ (license license:bsd-3)))
+
+(define-public python2-pathos
+ (package-with-python2 python-pathos))
--
2.24.1
Ricardo Wurmus wrote 5 years ago
Re: [PATCH 3/5] gnu: Add python-ppft.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38652@debbugs.gnu.org)
878sn9bnty.fsf@elephly.net
Hi Mădălin,

Toggle quote (1 lines)
> * gnu/packages/python-xyz.scm (python-ppft): New variable.
[…]
Toggle quote (9 lines)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (replace 'check
> + (lambda _
> + (with-directory-excursion "/tmp"
> + (invoke "nosetests" "-v"))
> + #t)))))

This has the effect of not running the tests at all.

--
Ricardo
Ricardo Wurmus wrote 5 years ago
Re: [bug#38652] [PATCH 5/5] gnu: Add python-pathos.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38652@debbugs.gnu.org)
87mubpqlws.fsf@elephly.net
Hi Mădălin,

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-pathos, python2-pathos): New variables.

I can’t seem to get the tests to run. I tried this:

Toggle snippet (38 lines)
(define-public python-pathos
(package
(name "python-pathos")
(version "0.2.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pathos" version))
(sha256
(base32
"0in8hxdz7k081ijn6q94gr39ycy7363sx4zysmbwyvd7snqjrbi1"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
(invoke "py.test" "-vvv" "tests")
#t)))))
(propagated-inputs
`(("python-dill" ,python-dill)
("python-multiprocess" ,python-multiprocess)
("python-pox" ,python-pox)
("python-ppft" ,python-ppft)))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://pypi.org/project/pathos/")
(synopsis "Parallel graph management and execution in heterogeneous computing")
(description
"Pathos is a framework for heterogenous computing. It provides a
consistent high-level interface for configuring and launching parallel
computations across heterogenous resources. Pathos provides configurable
launchers for parallel and distributed computing, where each launcher contains
the syntactic logic to configure and launch jobs in an execution
environment.")
(license license:bsd-3)))

…but after collecting 15 tests it just hangs, doing nothing.

Toggle quote (3 lines)
> +(define-public python2-pathos
> + (package-with-python2 python-pathos))

If you define a Python 2 variant you should also define Python 2
variants for all its inputs.

--
Ricardo
Efraim Flashner wrote 5 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38652@debbugs.gnu.org)
20191219073103.GC917@E5400
On Tue, Dec 17, 2019 at 06:24:37PM +0100, Mădălin Ionel Patrașcu wrote:
Toggle quote (7 lines)
> * gnu/packages/python-xyz.scm (python-pathos, python2-pathos): New variables.
> ---
> +
> +(define-public python2-pathos
> + (package-with-python2 python-pathos))
>

With the impending end of life on python2 we're not automatically adding
python2 variants of packages unless they're actually used.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl37JzcACgkQQarn3Mo9
g1H5ZA//WyVyyywL1F06aRFWPJohYg4KhX4OUcvx8oxpe+/Ffj6Mc+ASjmLNmzXj
glJU14q4KOPiUDvufkfIztdZwVfXBWCwIdM97a0nc5BMkRjIk8wG8S/W1TFHC1hq
2IXDO1GnjIubhP24LDWqjoxzofOgFY0ApeC7MBhBWwclNOFTF4hQ6FP2NMcLet9p
ulCjJkAwAlvhmReNoVFhGsUu1dXjq4g5AkIp6TOdq4Gh9+UeoU4VN3NyEF93cpUs
lOkOJFWT9x1B/86yssjwbNxkxYXrbAAjcLiR8pOoWkCNjX1i6XDBn9xA3q/ezHf3
MwgZ3EM8f10Z4pd99nunTvf03VCixEMCMjOmcdUe//6GNkVmz1Rn6tprzOkkg588
4xZfLT9Oz5Qq8DopJWhvwX3j0MRxLWBoWCZ8Hx6SiYwv47eW33oPGbIId3RSLiAa
nfAQ53eAM7IoZI2Phvd4YD/q1u+N7SwvVafaAjueZXkP97bVxVsUZOjHLONVwW2K
kUSFlQLUvytH5qBcH929HBDtgcbUuyo0gfSYPAHXbZMmEr4RN884dKtD7ecOCh9A
bonyoITeXyBRCMWsVvjBPtbLgu8g+hj2rznRPw8J31NwbN8zbdm14426OdK6Nj+6
Xl744/fxPH+0gA8mEZGkWTI5o5pl2OCirHYf8cZbqIp4G3e4keY=
=QFCT
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 5 years ago
control message for bug #38652
(address . control@debbugs.gnu.org)
87eewxmgqx.fsf@gnu.org
retitle 38652 [PATCH] gnu: Add python-pathos.
quit
Efraim Flashner wrote 5 years ago
Re: [bug#38652] [PATCH 5/5] gnu: Add python-pathos.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38652-done@debbugs.gnu.org)
20191226074036.GK23018@E5400
I pushed this patch and managed to get the test suite to run.


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl4EY/QACgkQQarn3Mo9
g1EcXg//WvlwBlMTLkHffUDWgymBb0ISOCLCLZM18SQ8AaP5qcadT3sto+lwmyGV
U++b2Bq840xSuFjLotxAJPWKMUyWqcZxNgAHM2OhxR/rblq+jg3K6k+kZer1xjah
Uh0348TwwV4E5jJENBZF7a7MhefuQf7Kr64gnVz+4tpfLWzcIN5vhwOeW6g6wibA
2gpG+BedGFVzdbGkuOLncH3RQgezvgypyJkEKwssQ7x60m0vURlTMpQwPeGwLnTF
p3IwUF6rDm+My8q4i27mZibbUnEIs2NIW3Bg8EFCa0o6LTgHDtD38bTqTJK70fTH
4nXTThk/Zm7SJ1RXgGnm8jldzV8PupIxr5JaNJCNXFvXjxQKwqE4qaAslFGTAa58
EzIBaVaQHFTqLFYT37cB/ypFvXQx+TqxJgN6XDAFrgRLhLmqYvOY5kncYVgcvwxC
Vqjw6CtZ5aTMlFSg/rRjnOzZifMOXsIUo2UuQnBP1IA8HWb28t97E34hbAzAu/dP
0PoHrfYZJwhG/gKW+ERlBAlJEjP76hdgD2O81onHTV+dbysVjWN6FtGmyyMMk7sP
Su/EI4bQsLaHJOWZmNBTxAZm5t+uxllfFFXWXhCNIis1byKnHtov74Nqza3jMitF
oH9pCXskIVdXX9mdJ6QhVQoMoZGOKWG/gGMoC4E0ZukQN0SVzm0=
=cOMU
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38652@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38652
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help