connman integration issue after recent updates

  • Open
  • quality assurance status badge
Details
One participant
  • Reza Alizadeh Majd
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal
R
R
Reza Alizadeh Majd wrote on 17 Dec 2019 17:42
(address . bug-guix@gnu.org)
ee90f368-4411-4ad8-b1ee-a95f6aaf4b3a@www.fastmail.com
Hi Guix,

I'm using `connman` + `cmst` for network management on my guix machine, recently after I updated the system, I receive following message after login and `cmst` can't communicate with `connman`. I also tried with `econnman` interface and received same error:

```
Error Name: org.freedesktop.DBus.Error.AccessDenied

Error Message: Rejected send message, 3 matched rules; type="method_call", sender=":1.108" (uid=1000 pid=3870 comm="cmst ") interface="net.connman.Manager" member="GetTechnologies" error name="(unset)" requested_reply="0" destination="net.connman" (uid=0 pid=369 comm="/gnu/store/1ld7hpvnhcr5wjxd15bvgbwvd50j8i04-connma")
```

I also tried to modify `connman` package and add

<allow send_interface="net.connman.Manager"/>

policy to connman debus config, based on suggested details in:

but the problem still occurs.

--
Regards
Reza Alizadeh Majd
PantherX Team
R
R
Reza Alizadeh Majd wrote on 17 Dec 2019 18:07
(address . 38651@debbugs.gnu.org)
ec7ac1c6-353b-4889-91e5-3f2a68476687@www.fastmail.com
here is a sample configuration file that I used to reproduce the issue:

(use-modules (gnu)
(gnu system nss)
(gnu packages gnome)
(gnu packages vim)
(srfi srfi-1))

(use-service-modules desktop networking ssh xorg)
(use-package-modules screen ssh certs tls connman)

(operating-system
(host-name "panther")
(timezone "Asia/Tehran")
(locale "en_US.utf8")

;; Boot in "legacy" BIOS mode
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sda")))
(file-systems (cons (file-system
(device (file-system-label "my-root"))
(mount-point "/")
(type "ext4"))
%base-file-systems))

(users (cons (user-account
(name "user")
(comment "default user")
(group "users")
(supplementary-groups '("wheel" "audio" "video"))
(home-directory "/home/user"))
%base-user-accounts))

(packages (cons* openssh nss-certs gnutls cmst
%base-packages))

(services (cons* (service gnome-desktop-service-type)
(service openssh-service-type
(openssh-configuration
(port-number 22)
(permit-root-login #t)
(authorized-keys
`(("user" ,(local-file "/etc/vagrant.pub"))
("root" ,(local-file "/etc/vagrant.pub"))))))
(service connman-service-type)
(remove (lambda (service)
(eq? (service-kind service) network-manager-service-type))
%desktop-services)))

(name-service-switch %mdns-host-lookup-nss))

--
Regards
Reza Alizadeh Majd
PantherX Team
?