[PATCH] Add Polari

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Leo Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
a24e4ac79927a4ff08cc55ad8e0c9f3e452cddb0.camel@student.tugraz.at
Hey Guix,

After my second attempt at doing so, I finally have a "working" build
for Polari. As far as I'm aware, it needs to be installed in some
profile along with its propagated inputs (due to D-Bus) and there may
be some races due to honestly strange behaviour of telepathy-idle.
However, I've been chatting with it on #guix for some while, so at
least that appears to function as intended.

Regards,
Leo
From 2c06da35ab21681712152df5eb87c0e5d4d3141c Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Mon, 16 Dec 2019 15:33:22 +0100
Subject: [PATCH] gnu: Add polari.

* gnu/packages/gnome.scm (gspell) [native-inputs]: Add gobject-introspection.
(polari): New package.
---
gnu/packages/gnome.scm | 57 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1d4d756..12e4688 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2019 Leo Prikler <leoprikler@student.tugraz.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8159,6 +8160,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
("iso-codes" ,iso-codes)))
(native-inputs
`(("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("xmllint" ,libxml2)
@@ -8957,3 +8959,58 @@ tile-matching game Mahjong. It features multiple board layouts, tile themes,
and a high score table.")
(home-page "https://wiki.gnome.org/Apps/Mahjongg")
(license license:gpl2+)))
+
+(define-public polari
+ (package
+ (name "polari")
+ (version "3.32.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version)
+ "/polari-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0h0w9j3y067l911gpj446b3a2w1i2vzr1w2a7cz7i5rhn6qkf2sp"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson/meson-postinstall.sh"
+ (("gtk-update-icon-cache") (which "true")))
+ #t))
+ (add-after 'glib-or-gtk-wrap 'wrap-typelib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/polari")))
+ (wrap-program prog
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (inputs
+ `(("glib" ,glib)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell)
+ ("gtk+" ,gtk+)
+ ("gjs" ,gjs)
+ ("libsecret" ,libsecret)
+ ("libsoup" ,libsoup)
+ ("telepathy-glib" ,telepathy-glib)
+ ("telepathy-logger" ,telepathy-logger)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("yelp-tools" ,yelp-tools)))
+ (propagated-inputs
+ `(("telepathy-idle" ,telepathy-idle)
+ ("telepathy-mission-control" ,telepathy-mission-control)))
+ (synopsis "Simple IRC Client")
+ (description
+ "Polari is a simple Internet Relay Chat (IRC) client that is designed to
+integrate seamlessly with the GNOME desktop.")
+ (home-page "https://wiki.gnome.org/Apps/Polari")
+ (license license:gpl2+)))
--
libgit2 0.28.4
Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
0e2c4491339fecc580ba40bbe8c8cab1a0daa97b.camel@student.tugraz.at
Am Montag, den 16.12.2019, 16:55 +0100 schrieb Leo Prikler:
Toggle quote (11 lines)
> Hey Guix,
>
> After my second attempt at doing so, I finally have a "working" build
> for Polari. As far as I'm aware, it needs to be installed in some
> profile along with its propagated inputs (due to D-Bus) and there may
> be some races due to honestly strange behaviour of telepathy-idle.
> However, I've been chatting with it on #guix for some while, so at
> least that appears to function as intended.
>
> Regards,
> Leo
My previous patch appears to no longer apply cleanly, so I've rebased
it on current master.
From bb5ac4780ddde253c03267550f2930f57d350c44 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Mon, 16 Dec 2019 15:33:22 +0100
Subject: [PATCH] gnu: Add polari.

* gnu/packages/gnome.scm (gspell) [native-inputs]: Add gobject-introspection.
(polari): New package.
---
gnu/packages/gnome.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6ee5187da6..f170f22082 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2019 Leo Prikler <leoprikler@student.tugraz.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8167,6 +8168,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
("iso-codes" ,iso-codes)))
(native-inputs
`(("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("xmllint" ,libxml2)
@@ -8966,3 +8968,58 @@ tile-matching game Mahjong. It features multiple board layouts, tile themes,
and a high score table.")
(home-page "https://wiki.gnome.org/Apps/Mahjongg")
(license license:gpl2+)))
+
+(define-public polari
+ (package
+ (name "polari")
+ (version "3.32.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version)
+ "/polari-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0h0w9j3y067l911gpj446b3a2w1i2vzr1w2a7cz7i5rhn6qkf2sp"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson/meson-postinstall.sh"
+ (("gtk-update-icon-cache") (which "true")))
+ #t))
+ (add-after 'glib-or-gtk-wrap 'wrap-typelib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/polari")))
+ (wrap-program prog
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (inputs
+ `(("glib" ,glib)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell)
+ ("gtk+" ,gtk+)
+ ("gjs" ,gjs)
+ ("libsecret" ,libsecret)
+ ("libsoup" ,libsoup)
+ ("telepathy-glib" ,telepathy-glib)
+ ("telepathy-logger" ,telepathy-logger)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("yelp-tools" ,yelp-tools)))
+ (propagated-inputs
+ `(("telepathy-idle" ,telepathy-idle)
+ ("telepathy-mission-control" ,telepathy-mission-control)))
+ (synopsis "Simple IRC Client")
+ (description
+ "Polari is a simple Internet Relay Chat (IRC) client that is designed to
+integrate seamlessly with the GNOME desktop.")
+ (home-page "https://wiki.gnome.org/Apps/Polari")
+ (license license:gpl2+)))
--
2.24.1
Efraim Flashner wrote 5 years ago
Re: [bug#38638] [PATCH] Add Polari
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 38638-done@debbugs.gnu.org)
20191222130208.GG1115@E5400
I split it up into two patches and applied them.


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl3/aVAACgkQQarn3Mo9
g1HFlhAAiZ1cP3DGAhrA0oOVR+eED6EADO4X63C1thsDjRvaf7IasDaBm5E9fQBm
56G5FClG2g+Q45IkXRFhNWxDFlpYP/NKTgu5cX4Q+5mMJTTolE6kAGqftlg61Udk
7GAg3lrhFOAbBwRyPEscK4ejsVe75NFOrLRTUh+t1UvUnqrf1c5aL6KyAgs+QaPH
4IYBtBKsDhGdBhhsfto5UQC/HfOSXp1W4CAkPogNNd8Nltyd2Dsq/Ysb7Vxs0u3x
HvovbWmeXRKbu+WmHH3ZktD+egs5mSMt/LpK2s/32Pge3zzZvv2tvNRAON93tWBd
3QE5k8iC/ggc46u+mnFkPmcxwtTwnPtxJ1Iab+n3flkNHuiCA5OMxT/flYhn3O1f
UhV2a6nxCzSwK9Hs4HloxElUAguT4Qvrnnyg50LDkYCr0O3e/+IC1GB7/Z5q84mY
nxoQTYMusSNbfYdBfc5a53aBFsX3ZOUIWB2uDyfb21DV+f3wW5IUZ4nIsj1hOVYN
PtrsW1b1iuGfApXLbTcOzzX+BvnklXK8ZjaYvZoIm4uWKQuGZ9hWKT6qcMJTQeNM
87vAcHWP30ND/aKxZ00YIofdiKlUVXbf6X1IZTUi6lRm8MnpoKL8mwfETs0FFdeB
uSgVG+bEohQ6ClzCDTmlWQxpgDIz2gHKzXhIWjUy6K3iOs1dlfM=
=muyC
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38638@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38638
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help