(no subject)

  • Done
  • quality assurance status badge
Details
2 participants
  • mpatras
  • Ricardo Wurmus
Owner
unassigned
Submitted by
mpatras
Severity
normal
M
M
mpatras wrote on 16 Dec 2019 16:23
(address . guix-patches@gnu.org)
326bca30-7d18-a02b-9400-2f12bc0e5c21@mdc-berlin.de
--
M?d?lin Ionel Patra?cu

System Administrator
Bioinformatics and Omics Data Science
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Hannoversche Str. 28, 10115 Berlin
House 101, room 1.60
M
M
M?d?lin Ionel Patra?cu wrote on 16 Dec 2019 16:25
[PATCH 1/4] gnu: Add python-iocapture.
(address . 38637@debbugs.gnu.org)(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)
20191216152519.3595-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/python-xyz.scm (python-iocapture): New variable.
---
gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 03dddcde43..f26bc7719b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -67,6 +67,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16795,3 +16796,32 @@ services to what you expect in your tests.")
(define-public python2-ujson
(package-with-python2 python-ujson))
+
+(define-public python-iocapture
+ ;; the latest is more than year newer than the latest realease
+ (let ((commit "fdc021c431d0840303908dfc3ca8769db383595c")
+ (revision "1"))
+ (package
+ (name "python-iocapture")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/oinume/iocapture.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mkbhqibxvgwg0p7slr8dfraa3g2s6bsayladhax2jccwj4kcndz"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flexmock" ,python-flexmock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/oinume/iocapture")
+ (synopsis "Phython capuring tool for stdout and stderr")
+ (description
+ "python-iocapture helps you to capture the standard out (stdout) and the
+standard error channel (stderr) in your program.")
+ (license license:expat)))) ; MIT license
\ No newline at end of file
--
2.17.1
M
M
M?d?lin Ionel Patra?cu wrote on 16 Dec 2019 16:25
[PATCH 2/4] gnu: Add python-argh.
(address . 38637@debbugs.gnu.org)(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)
20191216152519.3595-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/python-xyz.scm (python-argh): New variable.
---
gnu/packages/python-xyz.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f26bc7719b..1f2149c9c4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16824,4 +16824,39 @@ services to what you expect in your tests.")
(description
"python-iocapture helps you to capture the standard out (stdout) and the
standard error channel (stderr) in your program.")
- (license license:expat)))) ; MIT license
\ No newline at end of file
+ (license license:expat)))) ; MIT license
+
+(define-public python-argh
+ ;; there are 21 commits after the latest release
+ ;; those contains important improvements
+ (let ((commit "dcd3253f2994400a6a58a700c118c53765bc50a4")
+ (revision "1"))
+ (package
+ (name "python-argh")
+ (version "0.26.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/neithere/argh.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1p5h3dnpbsjmqrvil96s71asc6i3gpinmbrabqmwnrsxprz7r3ns"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-iocapture" ,python-iocapture)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-xdist" ,python-pytest-xdist)
+ ("python-tox" ,python-tox)))
+ (home-page "https://github.com/neithere/argh/")
+ (synopsis "Argparse wrapper with natural syntax")
+ (description
+ "python-argh is a small library that provides several layers of
+abstraction on top of python-argparse. The layers can be mixed. It is always
+possible to declare a command with the highest possible (and least flexible)
+layer and then tune the behaviour with any of the lower layers including the
+native API of python-argparse.")
+ (license license:lgpl3))))
--
2.17.1
M
M
M?d?lin Ionel Patra?cu wrote on 16 Dec 2019 16:25
[PATCH 3/4] gnu: python-pyfaidx: Update to 0.5.7.
(address . 38637@debbugs.gnu.org)(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)
20191216152519.3595-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-pyfaidx): Update to 0.5.7.
---
gnu/packages/bioinformatics.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bdb3ff761b..c8396a33dd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13419,14 +13419,14 @@ bgzipped text file that contains a pair of genomic coordinates per line.")
(define-public python-pyfaidx
(package
(name "python-pyfaidx")
- (version "0.5.4.2")
+ (version "0.5.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyfaidx" version))
(sha256
(base32
- "0y5zyjksj1rdglj601xd2bbni5abhdh622y3ck76chyzxz9z4rx8"))))
+ "02jvdx3ksy6w5gd29i1d0g0zsabbz7c14qg482ff7pza6sdl0b2i"))))
(build-system python-build-system)
(propagated-inputs
`(("python-six" ,python-six)))
--
2.17.1
M
M
M?d?lin Ionel Patra?cu wrote on 16 Dec 2019 16:25
[PATCH 4/4] gnu: Add python-gffutils.
(address . 38637@debbugs.gnu.org)(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)
20191216152519.3595-4-madalinionel.patrascu@mdc-berlin.de
Co-authored-by: Ricardo Wurmus <rekado@elephly.net>

* gnu/packages/bioinformatics.scm (python-gffutils): New variable.
---
gnu/packages/bioinformatics.scm | 51 +++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c8396a33dd..14c0b59067 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15370,3 +15370,54 @@ methylation metrics from them. MethylDackel requires an indexed fasta file
containing the reference genome as well.")
;; See https://github.com/dpryan79/MethylDackel/issues/85
(license license:expat)))
+
+(define-public python-gffutils
+ ;; The latest release is older more than a year than the latest commit
+ (let ((commit "4034c54600813b1402945e12faa91b3a53162cf1")
+ (revision "1"))
+ (package
+ (name "python-gffutils")
+ (version (git-version "0.9" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/daler/gffutils.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rwafjdnbir5wnk0ap06ww4lra3p5frhy7mfs03rlldgfnwxymsn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; Tests need to access the HOME directory
+ (setenv "HOME" "/tmp")
+ (invoke "nosetests" "-a" "!slow")))
+ (add-after 'unpack 'make-gz-files-writable
+ (lambda _
+ (for-each make-file-writable
+ (find-files "." "\\.gz"))
+ #t)))))
+ (propagated-inputs
+ `(("python-argcomplete" ,python-argcomplete)
+ ("python-argh" ,python-argh)
+ ("python-biopython" ,python-biopython)
+ ("python-pybedtools" ,python-pybedtools)
+ ("python-pyfaidx" ,python-pyfaidx)
+ ("python-simplejson" ,python-simplejson)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-nose" , python-nose)))
+ (home-page "https://github.com/daler/gffutils")
+ (synopsis "Tool for manipulation of GFF and GTF files")
+ (description
+ "python-gffutils is a Python package for working with and manipulating the
+GFF and GTF format files typically used for genomic annotations. The files are
+loaded into a sqlite3 database, allowing much more complex manipulation of
+hierarchical features (e.g., genes, transcripts, and exons) than is possible
+with plain-text methods alone.")
+ (license license:expat)))) ;; MIT license
--
2.17.1
R
R
Ricardo Wurmus wrote on 16 Dec 2019 17:27
Re: [bug#38637] [PATCH 1/4] gnu: Add python-iocapture.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38637@debbugs.gnu.org)
87woawb5h5.fsf@elephly.net
Hi M?d?lin,

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-iocapture): New variable.

thanks for the patch!

Toggle quote (3 lines)
> +(define-public python-iocapture
> + ;; the latest is more than year newer than the latest realease

I know what you mean but that’s not what the comment says ;) I
changed it.

Toggle quote (23 lines)
> + (let ((commit "fdc021c431d0840303908dfc3ca8769db383595c")
> + (revision "1"))
> + (package
> + (name "python-iocapture")
> + (version "0.1.2")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference (url "https://github.com/oinume/iocapture.git")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1mkbhqibxvgwg0p7slr8dfraa3g2s6bsayladhax2jccwj4kcndz"))))
> + (build-system python-build-system)
> + (propagated-inputs
> + `(("python-flexmock" ,python-flexmock)
> + ("python-pytest" ,python-pytest)
> + ("python-pytest-cov" ,python-pytest-cov)
> + ("python-six" ,python-six)))
> + (home-page "https://github.com/oinume/iocapture")
> + (synopsis "Phython capuring tool for stdout and stderr")

Typos: Phython –> Python; capuring –> capturing

Toggle quote (5 lines)
> + (description
> + "python-iocapture helps you to capture the standard out (stdout) and the
> +standard error channel (stderr) in your program.")
> + (license license:expat)))) ; MIT license

The term “MIT license” is ambiguous, so we don’t use it, not even in a
comment.

I noticed that the tests were not actually run, so I overrode the check
phase.

I pushed this with modifications to the “master” branch with commit
dbcef44a0b.

Thanks again!

--
Ricardo
R
R
Ricardo Wurmus wrote on 16 Dec 2019 17:31
Re: [bug#38637] [PATCH 2/4] gnu: Add python-argh.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38637@debbugs.gnu.org)
87v9qgb5a8.fsf@elephly.net
M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-argh): New variable.

Pushed to the “master” branch (commit db6bd842aa) with minor changes,
such as this one:

Toggle quote (2 lines)
> + (license license:lgpl3))))

It’s actually LGPLv3+.

Thank you!

--
Ricardo
R
R
Ricardo Wurmus wrote on 16 Dec 2019 23:26
Re: [bug#38637] [PATCH 3/4] gnu: python-pyfaidx: Update to 0.5.7.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38637@debbugs.gnu.org)
87lfrbc3fg.fsf@elephly.net
M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioinformatics.scm (python-pyfaidx): Update to 0.5.7.

I pushed this after upgrading some other packages to ensure that
dependent packages still build.

Thank you!

--
Ricardo
R
R
Ricardo Wurmus wrote on 16 Dec 2019 23:33
Re: [bug#38637] [PATCH 4/4] gnu: Add python-gffutils.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38637-done@debbugs.gnu.org)
87k16vc34g.fsf@elephly.net
M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (4 lines)
> Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
>
> * gnu/packages/bioinformatics.scm (python-gffutils): New variable.

I’ve pushed this to the “master” branch with commit cfd83f3282.

Thank you!

--
Ricardo
Closed
?