(address . guix-patches@gnu.org)
Glyr contains a C library and a CLI tool for fetching album art and
metadata about music.
For example, abcde can use it to automatically download cover art.
diff a/guix/gnu/packages/music.scm b/guix/gnu/packages/music.scm
27a28
Toggle quote (1 lines)
> ;;; Copyright © 2019 Riku Viitanen <riku.viitanen0@gmail.com>
5108a5110,5166
Toggle quote (24 lines)
>
> (define-public glyr
> (package
> (name "glyr")
> (version "1.0.10")
> (source
> (origin
> (method url-fetch)
> (uri (string-append "https://github.com/sahib/glyr/archive/"
> version ".tar.gz"))
> (sha256
> (base32 "1s06m1619j3kqgmnh9qv9bbqwvzjd4h4hdja5rhjg38w49hdms3p"))))
> (build-system cmake-build-system)
> (arguments
> '(#:tests? #f)) ; no check target))
> (inputs
> `(("glib" ,glib)
> ("curl" ,curl)
> ("sqlite" ,sqlite)
> ("pkg-config" ,pkg-config)))
> (home-page "https://github.com/sahib/glyr")
> (synopsis "Search engine for music related metadata")
> (description
> "It comes both in a command-line interface tool (@command{glyrc})
and as a C library (libglyr), both
Toggle quote (1 lines)
> with an easy to use interface. The sort of metadata glyr is searching
(and
Toggle quote (2 lines)
> downloading) is usually the data you see in your musicplayer. And indeed,
> originally it was written to serve as internally library for a
musicplayer,
Toggle quote (1 lines)
> but has been extended to work as a standalone program which is able to
download:
Toggle quote (29 lines)
> @table @code
> @item cover
> Coverart (front images supported only)
> @item lyrics
> Songtext
> @item artistphotos
> Photos of a certain band (press or live)
> @item rtistbio
> Artist biography from various sites
> @item review
> Album reviews from various sites
> @item albumlist
> A list of albums from a specific artist.
> @item tags
> Tags, either related to artist, album or title
> @item relations
> Links to Wikipedia, Myspace, MusicBrainz …
> @item similarartists
> Similar artists
> @item similarsongs
> Similar songs
> @item tracklist
> Tracklist of an album
> @item guitartabs
> Guitartabs in textual form
> @item backdrops
> Large artist photos, suitable for backgrounds
> @end table")
> (license license:lgpl3)))