[WIP SWI-Prolog 0/3] Add SWI-Prolog

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Brett Gilio
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 5 years ago
(address . guix-patches@gnu.org)
87immj7eig.fsf@posteo.net
From 08bee0ab7c3c67c6d3095e35bb734243bc93b217 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 13 Dec 2019 21:47:11 -0600
Subject: [WIP SWI-Prolog 0/3] Add SWI-Prolog

Just wanted to share my WIP on SWI-Prolog for anybody who wants to contribute,
and so I can keep track of my own progress.

Please send revision by re-rolling n+1.

Brett Gilio (3):
gnu: Rename module GPROLOG to PROLOG.
gnu: Rename GPROLOG to PROLOG in local.mk
gnu: Add swi-prolog.

gnu/local.mk | 2 +-
gnu/packages/gprolog.scm | 45 +++++++++++++++++++++++++++++++++++++++-
2 files changed, 45 insertions(+), 2 deletions(-)

--
2.24.1
Brett Gilio wrote 5 years ago
[WIP SWI-Prolog 1/3] gnu: Rename module GPROLOG to PROLOG.
(address . 38604@debbugs.gnu.org)
87fthn7eg9.fsf@posteo.net
From 2af9f1ffd8afd69a13d6247f180cf9aa55fd7c17 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 13 Dec 2019 21:44:54 -0600
Subject: [WIP SWI-Prolog 1/3] gnu: Rename module GPROLOG to PROLOG.

* gnu/packages/gprolog.scm -> gnu/packages/prolog.scm.
---
gnu/packages/gprolog.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/gprolog.scm b/gnu/packages/gprolog.scm
index 166bf33294..5046c91a84 100644
--- a/gnu/packages/gprolog.scm
+++ b/gnu/packages/gprolog.scm
@@ -17,7 +17,7 @@
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-(define-module (gnu packages gprolog)
+(define-module (gnu packages prolog)
#:use-module (guix download)
#:use-module (guix licenses)
#:use-module (guix packages)
--
2.24.1
Brett Gilio wrote 5 years ago
[WIP SWI-Prolog 2/3] gnu: Rename GPROLOG to PROLOG in local.mk
(address . 38604@debbugs.gnu.org)
87d0cr7efx.fsf@posteo.net
From 2b8e574008473ba81ed03ed519cb9798a8cd283d Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 13 Dec 2019 21:45:37 -0600
Subject: [WIP SWI-Prolog 2/3] gnu: Rename GPROLOG to PROLOG in local.mk

* gnu/local.mk (gprolog.scm): Rename to prolog.scm
---
gnu/local.mk | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 32b2c141fa..0aac1a58c2 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -227,7 +227,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/golang.scm \
%D%/packages/gperf.scm \
%D%/packages/gpodder.scm \
- %D%/packages/gprolog.scm \
%D%/packages/gps.scm \
%D%/packages/graph.scm \
%D%/packages/graphics.scm \
@@ -399,6 +398,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/popt.scm \
%D%/packages/printers.scm \
%D%/packages/profiling.scm \
+ %D%/packages/prolog.scm \
%D%/packages/pth.scm \
%D%/packages/pulseaudio.scm \
%D%/packages/pumpio.scm \
--
2.24.1
Brett Gilio wrote 5 years ago
[WIP SWI-Prolog 3/3] gnu: Add swi-prolog.
(address . 38604@debbugs.gnu.org)
87a77v7efg.fsf@posteo.net
From 08bee0ab7c3c67c6d3095e35bb734243bc93b217 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 13 Dec 2019 21:46:26 -0600
Subject: [WIP SWI-Prolog 3/3] gnu: Add swi-prolog.

* gnu/packages/gprolog.scm (swi-prolog): New variable.
---
gnu/packages/gprolog.scm | 43 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/gprolog.scm b/gnu/packages/gprolog.scm
index 5046c91a84..2f1fac2449 100644
--- a/gnu/packages/gprolog.scm
+++ b/gnu/packages/gprolog.scm
@@ -66,3 +66,46 @@ manner. It also features an interactive interpreter.")
(supported-systems (fold delete
%supported-systems
'("armhf-linux" "mips64el-linux")))))
+
+;; TODO: This current version of SWI-PROLOG using the
+;; tarball from the official website is completely self-contained
+;; such that all submodules are provided. Eventually replace this
+;; and manually patch those submodules.
+(define-public swi-prolog
+ (package
+ (name "swi-prolog")
+ (version "8.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.swi-prolog.org/download/stable/src/swipl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bnnwbdxnifb1qj42prsqhx8y0k2z596wgvh4bbnd0bw8w59rrff"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:parallel-build? #f
+ #:tests? #t)) ; FIXME:
+ ;#:configure-flags
+ ; (list "-DINSTALL_DOCUMENTATION=OFF"))) ; FIXME:
+ (native-inputs
+ `(("zlib" ,zlib)
+ ("gmp" ,gmp)
+ ("readline" ,readline)
+ ;("texlive" ,texlive)
+ ("texinfo" ,texinfo)
+ ("libunwind" ,libunwind)
+ ("libjpeg", libjpeg)
+ ("libxft" ,libxft)
+ ("fontconfig" ,fontconfig)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("openssl" ,openssl)))
+ (home-page "https://www.swi-prolog.org/")
+ (synopsis "ISO/Edinburgh-style Prolog interpreter")
+ (description "SWI-Prolog is a fast and powerful ISO/Edinburgh-style Prolog
+compiler with a rich set of built-in predicates. It offers a fast, robust and
+small environment which enables substantial applications to be developed with
+it.")
+ (license #f))) ; TODO:
--
2.24.1
Brett Gilio wrote 5 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 38604-done@debbugs.gnu.org)
87woa7zxu9.fsf@gnu.org
Added working package with commit
7eef98484c4eea2ce92fd53a86a001f006a78c16. Closing.

--
Brett M. Gilio
GNU Guix, Contributor | GNU Project, Webmaster
[DFC0 C7F7 9EE6 0CA7 AE55 5E19 6722 43C4 A03F 0EEE]
<brettg@gnu.org> <brettg@posteo.net>
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38604@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38604
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help