Unbound variable for some package --show invocations.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Jacob MacDonald
Owner
unassigned
Submitted by
Jacob MacDonald
Severity
normal
J
J
Jacob MacDonald wrote on 14 Dec 2019 02:08
(address . bug-guix@gnu.org)
CACy6W0C0s1R-VZ=jR0-sobqM+jpGjL87nD_S45=hM_YrXuh-Lg@mail.gmail.com
Noticed the problem with cl-slime-swank, but seems to happen with a
variety of packages including sbcl-cl-uglify-js itself. I checked
javascript.scm, which does import lisp-xyz; Haven't done any deeper
debugging to discover possible causes.

Backtrace follows.

$ guix package --show=sbcl-cl-uglify-js
Backtrace:
In ice-9/boot-9.scm:
222:29 19 (map1 (((gnu packages gettext)) ((gnu packages #)) (#) …))
222:29 18 (map1 (((gnu packages ghostscript)) ((gnu packages …)) …))
222:29 17 (map1 (((gnu packages gl)) ((gnu packages glib)) ((…)) …))
222:29 16 (map1 (((gnu packages glib)) ((gnu packages gnome)) # …))
222:29 15 (map1 (((gnu packages gnome)) ((gnu packages gnupg)) # …))
222:29 14 (map1 (((gnu packages gnupg)) ((gnu packages #)) ((…)) …))
222:29 13 (map1 (((gnu packages gstreamer)) ((gnu packages #)) # …))
222:29 12 (map1 (((gnu packages gtk)) ((gnu packages image)) (#) …))
222:29 11 (map1 (((gnu packages image)) ((gnu packages #)) ((…)) …))
222:29 10 (map1 (((gnu packages imagemagick)) ((gnu packages …)) …))
222:17 9 (map1 (((gnu packages javascript)) ((gnu packages #)) …))
2800:17 8 (resolve-interface (gnu packages javascript) #:select _ …)
In ice-9/threads.scm:
390:8 7 (_ _)
In ice-9/boot-9.scm:
2726:13 6 (_)
In ice-9/threads.scm:
390:8 5 (_ _)
In ice-9/boot-9.scm:
2994:20 4 (_)
2312:4 3 (save-module-excursion #<procedure 7fbf1f28b330 at ice-…>)
3014:26 2 (_)
In unknown file:
1 (primitive-load-path "gnu/packages/javascript" #<proced…>)
In gnu/packages/javascript.scm:
460:10 0 (_)

gnu/packages/javascript.scm:460:10: error: sbcl-cl-uglify-js: unbound variable
E
E
Efraim Flashner wrote on 15 Dec 2019 17:37
(name . Jacob MacDonald)(address . jaccarmac@gmail.com)(address . 38600@debbugs.gnu.org)
20191215163733.GL8302@E5400
If you run 'guix pull' again do you still get the same errors?

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl32YUkACgkQQarn3Mo9
g1GnBA/+IzzXfiLPFVKlPhywDVHGmOEri1oVB64H/79z2yaKAHKouIlFO7kXHhbC
5EoatUTE/9ZK3VuNy86EzDTFTBiZSnz1QCygfTmP7i1Mh5EFPw9Xz3aaSv+fw/Cp
G4Rj54yRUhCqhL2XUo1dNQtaT/kh1I/7sSaCmzd3HXfCXHOnhaabG01F6MVu23zR
AbB/St6ETkliyjAWCp0NAtrd8gbDu/4fGjVnME7kgX4Ciqqndx546kGkvUeMFePF
a8fN3f7pHbfRKw/5ILnsb4k6PGmGgGL6Uz/sBF2Q4956sDkpzk/LWg0lKtYAZEMn
pT79LgrRfVrwkK6NgwwA/2Dxx2HCZBgo8jwLut42tYnOhpPhCpRVkrFoOFVVqglj
nlEb3ULb1PhbqPUmmON6F9jYM4ZxF5H9zaxKYw73xs5fkSV8alHOaBGBjRLrkNrQ
1UeHZrERFnWbYuqgUzxvkAiKBF1zJBkAkwZrT9x4g0uzNvaFvrxBypv1A2M0yL9n
S/MJrbL/ZbZLdin9mRgOFzAVcCaVeIeyppn3agQYKEjyhEvsoEgWlpXx/zBRwLIt
VTH+W5koJWt/3mZoWA8zSI8DzYFCMeUDNiNZdMi9DwgxHpWwjRlf5iKwBYifYMDO
ynXhdi47m57Sy77v2hf/iudWirlhKCY8KRBDztWJHYE2Tlc3Kpk=
=ER4S
-----END PGP SIGNATURE-----


J
J
Jacob MacDonald wrote on 16 Dec 2019 00:31
(address . 38600@debbugs.gnu.org)
CACy6W0AFe7qoJdy+dhfHbnUDC+YMag1EpTJPVULq_s-f9QwyEA@mail.gmail.com
Yes, though interestingly I can't reproduce in a development tree at
the commit used when I submitted the report
(9f9520a1299fccd8508d03ce0c9280c6e0030207). In summary:

Error occurs:
1. In 9f9520a1299fccd8508d03ce0c9280c6e0030207
2. In 00386d3430f12710997f17091a55c07323ff138c
3. In 00386d3430f12710997f17091a55c07323ff138c after running guix pull
once again (this did cause a rebuild of compute-guix-derivation)
Error does not occur:
In the Guix source tree (using the pre-inst-env script) @
9f9520a1299fccd8508d03ce0c9280c6e0030207

Would it be useful to compare the hashes for packages I build manually
to hashes of the packages from the substitute server? If so, what
packages should I check and what's the easiest way (and is guix
challenge useful in this situation [forgive me, I'm pretty unfamiliar
with debugging this kind of error in Guix])?

On Sun, Dec 15, 2019 at 8:38 AM Efraim Flashner <efraim@flashner.co.il> wrote:
Toggle quote (7 lines)
>
> If you run 'guix pull' again do you still get the same errors?
>
> --
> Efraim Flashner <efraim@flashner.co.il> ????? ?????
> GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted
E
E
Efraim Flashner wrote on 16 Dec 2019 10:41
(name . Jacob MacDonald)(address . jaccarmac@gmail.com)(address . 38600-done@debbugs.gnu.org)
20191216094120.GA2105@E5400
On Sun, Dec 15, 2019 at 03:22:02PM -0800, Jacob MacDonald wrote:
Toggle quote (19 lines)
> Yes, though interestingly I can't reproduce in a development tree at
> the commit used when I submitted the report
> (9f9520a1299fccd8508d03ce0c9280c6e0030207). In summary:
>
> Error occurs:
> 1. In 9f9520a1299fccd8508d03ce0c9280c6e0030207
> 2. In 00386d3430f12710997f17091a55c07323ff138c
> 3. In 00386d3430f12710997f17091a55c07323ff138c after running guix pull
> once again (this did cause a rebuild of compute-guix-derivation)
> Error does not occur:
> In the Guix source tree (using the pre-inst-env script) @
> 9f9520a1299fccd8508d03ce0c9280c6e0030207
>
> Would it be useful to compare the hashes for packages I build manually
> to hashes of the packages from the substitute server? If so, what
> packages should I check and what's the easiest way (and is guix
> challenge useful in this situation [forgive me, I'm pretty unfamiliar
> with debugging this kind of error in Guix])?

I think it's more likely that it's a transitive error and while it
shouldn't have happened it's probably not worth worrying about.

Toggle quote (10 lines)
>
> On Sun, Dec 15, 2019 at 8:38 AM Efraim Flashner <efraim@flashner.co.il> wrote:
> >
> > If you run 'guix pull' again do you still get the same errors?
> >
> > --
> > Efraim Flashner <efraim@flashner.co.il> ????? ?????
> > GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> > Confidentiality cannot be guaranteed on emails sent or received unencrypted

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl33UTwACgkQQarn3Mo9
g1HNIQ//fZ8C9n7EE9Ot+wFCaCyClUD3NTMOABwompX19mVMdBBgx2y/PpQvwox2
JzhHoQEH/bE0Rlml6Znl+hmGpS4zcQ6wHQE1pTaSu4QbXkA8RE714fUuiYBk5Ll7
dt2izCGfjePGkZip6XX82tWEmgBtXX1AbwQaNBY0ZNk4TjVfakmlK2ioQbIiSeN6
zN+03DY8CVlDV7ezL5YQjJKviUiO4MXqjZfjrRvqiQqGkoSIDRC3BYk2jjLrKdj+
u1pLtw19OtQPAKbcC+MnAhKi5PBykasvRIsuE1+5Zc3qxzMY4rFLqpbUuEQc+LPW
PPJyA40WTJwC0nDWPB7pKPejbQ48fPyszH+zobWGXRBJUJkn5nuEAKZ2T1f6dD3W
guA7WMBnkURIwSbA6FItTduSRy2WBF5TDUD7LlMceEP633VOh3Vmnhs2/VyGCV3g
jc86RzcClq5N5hwgMi6q0izePbCa+TnGzuONKBgbUSMfAWlm9kuQid7cw9nWaW9k
D+a4ke86Z52s6vIC8ocalA66xvTS+soDvq493py+e0fD1gO1uyCQkidDHDW7J2DI
usLeiJPXJvpp1U/FcAwUAq1O2KNSHe5Fw0tt3C/HgkvJB7cCZ1aFl3nhNL3BjZtU
kWyJiNbq93wEqMZsMl/qmS2F/ci8Kg+FVpCvnOc0dvQPbeoGLS0=
=qlfm
-----END PGP SIGNATURE-----


Closed
J
J
Jacob MacDonald wrote on 16 Dec 2019 18:18
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38600-done@debbugs.gnu.org)
CACy6W0A+m6nCNdz86UOSBPrKftc99Vq=+S_q6k4Cb0jvpU2-tw@mail.gmail.com
I've been able to reproduce it consistently across multiple Guix versions
and after daemon/system. Seems like a bug in my install but not sure where
since my Guix binaries are from the substitute. Probably a better thread
for help-guix, thanks for the help!
Attachment: file
Closed
J
J
Jacob MacDonald wrote on 16 Dec 2019 18:18
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38600-done@debbugs.gnu.org)
CACy6W0BzM3tVJikYnVe+9Dsi2j29mscK4Tnyp59goRHfdzGPpw@mail.gmail.com
daemon/system restarts*
Attachment: file
Closed
?