John Soo wrote 5 years ago
(address . guix-patches@gnu.org)
Hi all,
When compiling with ghc, I have been getting the message that the following
packages have invalid package databases. These patches remove the library
from the output, keeping the executables.
There may be other packages with this problem but I have not done an audit.
- John
From f7bca9fca0b01b1c770d388fea80cbcee042b14a Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sun, 17 Nov 2019 01:15:16 -0800
Subject: [PATCH 1/3] gnu: ghc-hpack: Remove invalid lib directory.
* gnu/packages/haskell-xyz.scm (ghc-hpack): Remove invalid library directory
from output.
---
gnu/packages/haskell-xyz.scm | 7 +++++++
1 file changed, 7 insertions(+)
Toggle diff (20 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fb6833207d..1d78eb7894 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5500,6 +5500,13 @@ representations of current time.")
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-temporary" ,ghc-temporary)
("hspec-discover" ,hspec-discover)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-lib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out") "/lib")))))))
(home-page "https://github.com/sol/hpack")
(synopsis "Tools for an alternative Haskell package format")
(description
--
2.24.0
From eb18a37d60039c5f67f7cb923c88433159a8387c Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sun, 17 Nov 2019 08:25:53 -0800
Subject: [PATCH 3/3] gnu: hoogle: Remove invalid library.
* gnu/packages/haskell-apps.scm (hoogle): Remove invalid library from output.
---
gnu/packages/haskell-apps.scm | 7 +++++++
1 file changed, 7 insertions(+)
Toggle diff (20 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 5a16b1bb91..1e79294737 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -500,6 +500,13 @@ unwanted suggestions, and to add your own custom suggestions.")
("ghc-warp" ,ghc-warp)
("ghc-warp-tls" ,ghc-warp-tls)
("ghc-zlib" ,ghc-zlib)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-lib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out") "/lib")))))))
(home-page "https://hoogle.haskell.org/")
(synopsis "Haskell API Search")
(description "Hoogle is a Haskell API search engine, which allows
--
2.24.0
From c634931be8790342a0eaeec2bbef6f058c86448e Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sun, 17 Nov 2019 01:19:20 -0800
Subject: [PATCH 2/3] gnu: hlint: Remove invalid lib directory.
* gnu/packages/haskell-apps.scm (hlint): Remove invalid library from output.
---
gnu/packages/haskell-apps.scm | 7 +++++++
1 file changed, 7 insertions(+)
Toggle diff (20 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index d5c31cbb0b..5a16b1bb91 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -441,6 +441,13 @@ used to keep a folder in sync between computers.")
("ghc-aeson" ,ghc-aeson)
("ghc-lib-parser" ,ghc-lib-parser)
("hscolour" ,hscolour)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-lib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out") "/lib")))))))
(home-page "http://community.haskell.org/~ndm/hlint/")
(synopsis "Suggest improvements for Haskell source code")
(description "HLint reads Haskell programs and suggests changes that
--
2.24.0