[PATCH] gnu: Update libhandy to 0.0.12.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • jonathan.brielmaier
  • Ludovic Courtès
Owner
unassigned
Submitted by
jonathan.brielmaier
Severity
normal

Debbugs page

jonathan.brielmaier wrote 5 years ago
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20191213095434.25372-1-jonathan.brielmaier@web.de
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>

* gnu/packages/gnome.scm (libhandy): Update to 0.0.12.
[description]: Make clear that it's for mobile and desktop.
---
gnu/packages/gnome.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1d4d7563a5..09b6b65e1c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8780,7 +8781,7 @@ advanced image management tool")
(define-public libhandy
(package
(name "libhandy")
- (version "0.0.11")
+ (version "0.0.12")
(source
(origin
(method git-fetch)
@@ -8789,7 +8790,7 @@ advanced image management tool")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0622zp5wrvn5bvgardijxd11y76g1i54fs32y03dw9nrar7i6vb0"))))
+ (base32 "09wlknarzsbk9hr5ws6s7x5kibkhx9ayrbhshfqib4zkhq2f76hw"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -8819,7 +8820,8 @@ advanced image management tool")
(home-page "https://source.puri.sm/Librem5/libhandy")
(synopsis "Library full of GTK+ widgets for mobile phones")
(description "The aim of the handy library is to help with developing user
-intefaces for mobile devices using GTK+.")
+intefaces for mobile devices using GTK+. It provides responsive GTK+ widgets
+for useable interfaces on small and big screens.")
(license license:lgpl2.1+)))

(define-public libgit2-glib
--
2.24.0
Brett Gilio wrote 5 years ago
(address . jonathan.brielmaier@web.de)(address . 38588@debbugs.gnu.org)
87r218h0ro.fsf@posteo.net
jonathan.brielmaier@web.de writes:

Toggle quote (6 lines)
> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
>
> * gnu/packages/gnome.scm (libhandy): Update to 0.0.12.
> [description]: Make clear that it's for mobile and desktop.
> ---

Hi Jon.

I personally would split these two changes into two different patches
for a series. WDYT?

--
Brett M. Gilio
Homepage -- https://scm.pw/
Jonathan Brielmaier wrote 5 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 38588@debbugs.gnu.org)
5731871f-6ca2-34e7-4fb3-9c88987746e2@web.de
On 13.12.19 13:23, Brett Gilio wrote:
Toggle quote (13 lines)
> jonathan.brielmaier@web.de writes:
>
>> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
>>
>> * gnu/packages/gnome.scm (libhandy): Update to 0.0.12.
>> [description]: Make clear that it's for mobile and desktop.
>> ---
>
> Hi Jon.
>
> I personally would split these two changes into two different patches
> for a series. WDYT?

Oke, could make sense. I don't have a strong opinion. As it's only a
minor change to the description with no effect on the resulting package.

But if you wan't I can split them or you could do it yourself before
commiting :)
Jonathan Brielmaier wrote 5 years ago
[PATCH 1/2] gnu: Update libhandy to 0.0.12.
(address . 38588@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20191214173326.3899-1-jonathan.brielmaier@web.de
* gnu/packages/gnome.scm (libhandy): Update to 0.0.12.
---
gnu/packages/gnome.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 488a65a841..979064f128 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8780,7 +8781,7 @@ advanced image management tool")
(define-public libhandy
(package
(name "libhandy")
- (version "0.0.11")
+ (version "0.0.12")
(source
(origin
(method git-fetch)
@@ -8789,7 +8790,7 @@ advanced image management tool")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0622zp5wrvn5bvgardijxd11y76g1i54fs32y03dw9nrar7i6vb0"))))
+ (base32 "09wlknarzsbk9hr5ws6s7x5kibkhx9ayrbhshfqib4zkhq2f76hw"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
--
2.24.0
Jonathan Brielmaier wrote 5 years ago
[PATCH 2/2] gnu: libhandy: Update description.
(address . 38588@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20191214173512.4128-1-jonathan.brielmaier@web.de
* gnu/packages/gnome.scm (libhandy)[description]: Fix typo and make
clear it's not only for mobile interfaces.
---
gnu/packages/gnome.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 979064f128..d25c9b2636 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8820,7 +8820,8 @@ advanced image management tool")
(home-page "https://source.puri.sm/Librem5/libhandy")
(synopsis "Library full of GTK+ widgets for mobile phones")
(description "The aim of the handy library is to help with developing user
-intefaces for mobile devices using GTK+.")
+interfaces for mobile devices using GTK+. It provides responsive GTK+ widgets
+for usage on small and big screens.")
(license license:lgpl2.1+)))

(define-public libgit2-glib
--
2.24.0
Ludovic Courtès wrote 5 years ago
Re: [bug#38588] [PATCH 1/2] gnu: Update libhandy to 0.0.12.
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 38588-done@debbugs.gnu.org)
875zickl51.fsf@gnu.org
Hi,

Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (libhandy): Update to 0.0.12.

[...]

Toggle quote (3 lines)
> * gnu/packages/gnome.scm (libhandy)[description]: Fix typo and make
> clear it's not only for mobile interfaces.

Applied both, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38588@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38588
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help