[PATCH] gnu: qps: Updated to 2.0.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Reza Alizadeh Majd
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal

Debbugs page

Reza Alizadeh Majd wrote 5 years ago
(address . guix-patches@gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
20191210073108.1888-1-r.majd@pantherx.org
* gnu/packages/lxqt.scm (qps): Update to version 2.0.0
---
gnu/packages/lxqt.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 6b9ab051b4..5a3708e30a 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1143,14 +1143,14 @@ window manager OpenBox.")
(define-public qps
(package
(name "qps")
- (version "1.10.20")
+ (version "2.0.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0dz7ricxg2rrmdyca6mc2d4lyy5bpksjk751hvn95wssr76y2w0m"))))
+ (base32 "0ysnh918n9wz2vgjvyix32kx2j0v4lskjacgcychrpb8sch2dbsi"))))
(build-system cmake-build-system)
(inputs
`(("libxrender" ,libxrender)
--
2.23.0
Brett Gilio wrote 5 years ago
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 38556@debbugs.gnu.org)
87eexczl6r.fsf@posteo.net
Reza Alizadeh Majd <r.majd@pantherx.org> writes:

Toggle quote (27 lines)
> * gnu/packages/lxqt.scm (qps): Update to version 2.0.0
> ---
> gnu/packages/lxqt.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
> index 6b9ab051b4..5a3708e30a 100644
> --- a/gnu/packages/lxqt.scm
> +++ b/gnu/packages/lxqt.scm
> @@ -1143,14 +1143,14 @@ window manager OpenBox.")
> (define-public qps
> (package
> (name "qps")
> - (version "1.10.20")
> + (version "2.0.0")
> (source
> (origin
> (method url-fetch)
> (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
> version "/" name "-" version ".tar.xz"))
> (sha256
> - (base32 "0dz7ricxg2rrmdyca6mc2d4lyy5bpksjk751hvn95wssr76y2w0m"))))
> + (base32 "0ysnh918n9wz2vgjvyix32kx2j0v4lskjacgcychrpb8sch2dbsi"))))
> (build-system cmake-build-system)
> (inputs
> `(("libxrender" ,libxrender)

I havent had a chance to test it, but it looks fine.

There is an issue with your commit message. s/Updated/Update and both
the commit message and sub-header need punctuation.

Thank you for your contribution! :) I look forward to seeing it get
pushed if there are no other objections.

--
Brett M. Gilio
Homepage -- https://scm.pw/
Ricardo Wurmus wrote 5 years ago
(name . Brett Gilio)(address . brettg@posteo.net)
87fths603f.fsf@elephly.net
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (3 lines)
> There is an issue with your commit message. s/Updated/Update and both
> the commit message and sub-header need punctuation.

If you’re using Emacs with yasnippet and magit you can type “update” and
hit TAB (or whatever expansion key you have set up) to insert the
appropriate update message. There’s “add” as well, which inserts the
expected commit message for new packages. I use these all the time to
speed up big package upgrades.

--
Ricardo
Reza Alizadeh Majd wrote 5 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 38556@debbugs.gnu.org)
26f168c7-e367-4a2f-a2cb-8a97e263713a@www.fastmail.com
On Tue, Dec 10, 2019, at 11:06 AM, Brett Gilio wrote:
Toggle quote (3 lines)
> There is an issue with your commit message. s/Updated/Update and both
> the commit message and sub-header need punctuation.

sorry for the issue with commit message, here is an updated patch with amended commit message.


--
Regards
Reza Alizadeh Majd
PantherX Team
Brett Gilio wrote 5 years ago
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 38556-done@debbugs.gnu.org)
87a780ypk6.fsf@posteo.net
"Reza Alizadeh Majd" <r.majd@pantherx.org> writes:

Toggle quote (7 lines)
> On Tue, Dec 10, 2019, at 11:06 AM, Brett Gilio wrote:
>> There is an issue with your commit message. s/Updated/Update and both
>> the commit message and sub-header need punctuation.
>
> sorry for the issue with commit message, here is an updated patch with
> amended commit message.

Hey Reza,

As Ricardo noted, if you use GNU Emacs or anything with the ability to
parse yasnippet syntax you can use those snippets provided in
guix/etc/snippets to generate these commit messages. Your revised commit
messages still has some small problems.

I have revised them as such, (from my Magit buffer):

Toggle snippet (21 lines)
gnu: qps: Update to 2.0.0.

* gnu/packages/lxqt.scm (qps): Update to 2.0.0.

Signed-off-by: Brett Gilio <brettg@posteo.net>

# Please enter the commit message for your changes. Lines starting
# with '#' will be ignored, and an empty message aborts the commit.
#
# Author: Reza Alizadeh Majd <r.majd@pantherx.org>
# Date: Tue Dec 10 12:57:33 2019 +0330
#
# On branch master
# Your branch is ahead of 'origin/master' by 1 commit.
# (use "git push" to publish your local commits)
#
# Changes to be committed:
# modified: gnu/packages/lxqt.scm
#

Additionally, I have built and tested the changes on my machine. It
looks fine.

I have pushed the changes to master with
fc8131638499d907153473119279cbcd7f029bc7.

Closing! Thanks.


--
Brett M. Gilio
Homepage -- https://scm.pw/
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38556@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38556
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help