[PATCH 0/1] Dynamically-link Ruby

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Jonathan Brielmaier
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 5 years ago
(address . guix-patches@gnu.org)
877e35uspe.fsf@posteo.net
From 36e56ea5d882d112f24d49050813066eece98af2 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 9 Dec 2019 14:50:51 -0600
Subject: [PATCH 0/1] Dynamically-link Ruby
To: guix-patches@gnu.org

This patch solves #38500. The current behavior of Ruby is to compile against libruby-static.a

Brett Gilio (1):
gnu: ruby: Configure for dynamic linking.

gnu/packages/ruby.scm | 2 ++
1 file changed, 2 insertions(+)

--
2.24.0
Brett Gilio wrote 5 years ago
[PATCH 1/1] gnu: ruby: Configure for dynamic linking.
(address . 38552@debbugs.gnu.org)
8736dtusml.fsf@posteo.net
From 36e56ea5d882d112f24d49050813066eece98af2 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 9 Dec 2019 14:46:47 -0600
Subject: [PATCH 1/1] gnu: ruby: Configure for dynamic linking.
To: guix-patches@gnu.org

* gnu/packages/ruby.scm (ruby)[arguments]: Use #:configure-flags to properly
enable dynamic linking instead of using libruby-static.a. Solves #38500.

Reported-by: Vicente Eduardo <vic798@gmail.com>
---
gnu/packages/ruby.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 70b59e9156..a4b9bc6968 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2019 Diego N. Barbato <dnbarbato@posteo.de>
+;;; Copyright © 2019 Brett Gilio <brettg@posteo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -95,6 +96,7 @@
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
+ #:configure-flags '("--enable-shared") ; dynamic linking
#:phases
(modify-phases %standard-phases
(add-before 'configure 'replace-bin-sh-and-remove-libffi
--
2.24.0
Brett Gilio wrote 5 years ago
Re: [bug#38552] [PATCH 0/1] Dynamically-link Ruby
(address . 38552@debbugs.gnu.org)
87y2vlte03.fsf@posteo.net
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (14 lines)
>>From 36e56ea5d882d112f24d49050813066eece98af2 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Mon, 9 Dec 2019 14:50:51 -0600
> Subject: [PATCH 0/1] Dynamically-link Ruby
> To: guix-patches@gnu.org
>
> This patch solves #38500. The current behavior of Ruby is to compile against libruby-static.a
>
> Brett Gilio (1):
> gnu: ruby: Configure for dynamic linking.
>
> gnu/packages/ruby.scm | 2 ++
> 1 file changed, 2 insertions(+)

I forgot to mention that this should go in core-update since it triggers
a rebuild of 3000+ packages. I am happy to push this to core-updates if
everything looks alright.

--
Brett M. Gilio
Jonathan Brielmaier wrote 5 years ago
Re: [bug#38552] [PATCH 1/1] gnu: ruby: Configure for dynamic linking.
3cebb019-b09a-20d5-13e5-b45d844416a4@web.de
On 09.12.19 21:54, Brett Gilio wrote:
Toggle quote (8 lines)
> Subject: [PATCH 1/1] gnu: ruby: Configure for dynamic linking.
> To: guix-patches@gnu.org
>
> * gnu/packages/ruby.scm (ruby)[arguments]: Use #:configure-flags to properly
> enable dynamic linking instead of using libruby-static.a. Solves #38500.
>
> Reported-by: Vicente Eduardo <vic798@gmail.com>

Maybe change the commit format a little:

Reported-by: Vicente Eduardo <vic798@gmail.com>

* gnu/packages/ruby.scm (ruby)[arguments]: Use #:configure-flags to
properly enable dynamic linking instead of using libruby-static.a.
Brett Gilio wrote 5 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 38552@debbugs.gnu.org)
87r21dtaet.fsf@posteo.net
Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:
Toggle quote (10 lines)
>
> Maybe change the commit format a little:
>
> Fixes <https://bugs.gnu.org/38500>.
> Reported-by: Vicente Eduardo <vic798@gmail.com>
>
> * gnu/packages/ruby.scm (ruby)[arguments]: Use #:configure-flags to
> properly enable dynamic linking instead of using libruby-static.a.


Sounds like a good idea. Consider it done.

I will wait for more eyes before pushing to core-updates. Thank you Jonathan.

--
Brett M. Gilio
Brett Gilio wrote 5 years ago
(address . 38552-done@debbugs.gnu.org)
87mubw28bo.fsf@posteo.net
Pushed to core-updates with fd248cb815d571043c3a0c52a01c9b3e368a069e.

Closing.

--
Brett M. Gilio
Homepage -- https://scm.pw/
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38552@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38552
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help