[PATCH] gnu: Add gnome-shell-extension-hide-app-icon

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Leo Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
20191208201249.5479-1-leo.prikler@student.tugraz.at
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-hide-app-icon):
New variable.
---
gnu/packages/gnome-xyz.scm | 47 ++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 7c3fb072c0..80870fd25d 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -26,6 +26,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
@@ -149,6 +150,52 @@ faster window switching.")
(home-page "https://micheleg.github.io/dash-to-dock/")
(license license:gpl2+)))
+(define-public gnome-shell-extension-hide-app-icon
+ (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
+ (revision "0"))
+ (package
+ (name "gnome-shell-extension-hide-app-icon")
+ (version (git-version "2.7" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:make-flags (list (string-append "EXTENSIONS_DIR="
+ (assoc-ref %outputs "out")
+ "/share/gnome-shell/extensions"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (add-before 'install 'prepare-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append (assoc-ref outputs "out")
+ "/share/gnome-shell/extensions")))))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("unzip" ,unzip)
+ ("zip" ,zip)))
+ (propagated-inputs
+ `(("glib" ,glib)
+ ("glib" ,glib "bin")))
+ (synopsis "Hide app icon from GNOME's panel")
+ (description "This extension allows to hide the icon and/or title of the
+currently focused application in the top panel of the GNOME shell.")
+ (home-page "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
+ (license
+ ;; README.md and LICENSE.txt disagree -- the former claims v3, the
+ ;; latter v2. No mention of "or later" in either place or in the code.
+ (list license:gpl2
+ license:gpl3)))))
+
(define-public gnome-shell-extension-noannoyance
(package
(name "gnome-shell-extension-noannoyance")
--
2.24.0
Efraim Flashner wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 38538@debbugs.gnu.org)
20191219092004.GE917@E5400
What does this need glib and glib:bin for? Is it just for building the
schemas or does it actually need it at runtime?

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl37QMEACgkQQarn3Mo9
g1GSUxAAwLcnk+DG772QSTvJDOHRrkDgfYlMQwz7ESFy1HB3/R2dcNiBm1c9TB69
j2CUf1qJ/4fdagSglXmoEGWgQdXHSzrN3VdS4eGVormVIpDJfS+TzesIgRpEFwzP
75sLJwUC9o/3OxPInKKzxrYvjHSuYEKk7J+Fm5m7ZolPg4AY5mvRKrcwnhnXd/BV
k6zU61dkru7zDE3cC/dux7x4wRd/Jjnh8JU7/p0CG6CzCFafiXIZhf1L3TNWPv0v
Fe0Ax4PDdq6M/i4h+/vgamUA9dZHgp/it8nQmGEhUXkn9cSwmfBcJPWG16A2crTn
/oVwYPBoYCbXEWxrNGlwlRe8CWx7BhcrALg6NfBpovELQtdApJB13FoEw8CeIGU0
2g07MOn0NTjKCzT9ujWUqphQljtoHA5DpWXzWKw7VkCr/uSYAKVFia3ezV3jJnST
Bck685JeRh+dmkiM4AoNiX6bWjlKa2yKiVTw/xbtomxyjaXYLQzr/ULQ/+tKzIUh
oSqWi6AaVj23QrlPOIpHY/HhtvqEHoMngBhKzxVUEAneDdXXOq0cD/B0kMFmhOvu
Yli0/oqZ5ZqfqtR7QNoWmdb1zt4tLUO5fFum2z+UQXxHK/whgzaQnfHkPAeapbXO
Nh0jiais9yrZyDoCUQelpYo/3tDOsP57d242Dwxg1cv8HmDRlcg=
=m/7d
-----END PGP SIGNATURE-----


Efraim Flashner wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 38538@debbugs.gnu.org)
20191219092254.GF917@E5400
On Thu, Dec 19, 2019 at 11:20:04AM +0200, Efraim Flashner wrote:
Toggle quote (4 lines)
> What does this need glib and glib:bin for? Is it just for building the
> schemas or does it actually need it at runtime?
>

I also made some changes to the package

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
From f5d6a59409d6d119e40f5fda998287e4f7ca5a34 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 8 Dec 2019 21:12:50 +0100
Subject: [PATCH] gnu: Add gnome-shell-extension-hide-app-icon.

* gnu/packages/gnome-xyz.scm (gnome-shell-extension-hide-app-icon):
New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
---
gnu/packages/gnome-xyz.scm | 46 ++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 00ad701ad8..5aa2d292bf 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -151,6 +151,52 @@ faster window switching.")
(home-page "https://micheleg.github.io/dash-to-dock/")
(license license:gpl2+)))
+(define-public gnome-shell-extension-hide-app-icon
+ (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
+ (revision "0"))
+ (package
+ (name "gnome-shell-extension-hide-app-icon")
+ (version (git-version "2.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no test target
+ #:make-flags (list (string-append "EXTENSIONS_DIR="
+ (assoc-ref %outputs "out")
+ "/share/gnome-shell/extensions"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (copy-recursively "hide-app-icon@mrapp.sourceforge.com/"
+ (string-append out "/share/gnome-shell/extensions"))
+ #t))))))
+ (native-inputs
+ `(("intltool" ,intltool)))
+ (propagated-inputs
+ `(("glib" ,glib)
+ ("glib" ,glib "bin")))
+ (synopsis "Hide app icon from GNOME's panel")
+ (description "This extension allows to hide the icon and/or title of the
+currently focused application in the top panel of the GNOME shell.")
+ (home-page "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
+ (license
+ ;; README.md and LICENSE.txt disagree -- the former claims v3, the
+ ;; latter v2. No mention of "or later" in either place or in the code.
+ (list license:gpl2
+ license:gpl3)))))
+
(define-public gnome-shell-extension-noannoyance
(package
(name "gnome-shell-extension-noannoyance")
--
2.24.1
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl37QW4ACgkQQarn3Mo9
g1HkqA/7Bbb5A3wT7il2SLK+v16BB/vzY/4CGELWnG6ZvhS4Rt4eosMaUvv4U7I4
jrkB4wgKnZNo3ACvWX0b/j96OkZhX7d28KjxTUA/HDxtIMYBJyzs2lf5ENg2qN/E
93lsVuVBOugFKoLo9KLrBsaeI4Eit04Npm+m6BlM/W4xUI8RILlp5IXy2C49+PG0
HlJO6Qvc9foOYlwenHDu86LYPrrPP6tEH/6iN0e2RlzJ00NZZNwaEb2LsGXwH2ae
+TfMk4ujWnbYo66EJLYMfz5gC7d7bYQteXhVcAaMD121eYh28w8fBOrORh6mk+DT
onuCD3FgFYuhsQHrw06q+CVJS0e81Sl2eMWny3wf4Y0WWX0l51hwXtrOg5WtjSfM
Udpl9di5ktG/3ESHxQABPIgYroGir51OyiBVskGrfcQj89cliNKJ9ZcrMowQclCG
yeX+c3v9AkeieRdm5EW1wb7J35tcEGvv8VsUo2rWzA4z4+f3w4I/lYTFk96XLbLO
jFCSwMvz3rbLsOcGFLtpalBqYQIrNezoCXDw8oFd4RlvTd3adZIy0dSs1Bz6wz8m
PVJA8LI3dFLRmKrRWo0J0aF4h97l4PkEiABN28GjncBNYIbPp1HrLVJrcEuDGZM/
Q4GNDbG7ANk0xG0cGnZPkIQfAtcDYWb6W8QE+HsXlF61UFiDaGs=
=oSPs
-----END PGP SIGNATURE-----


Leo Prikler wrote 5 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38538@debbugs.gnu.org)
be32bfed7df3dc78380c27e703d6bbcd3b29d99d.camel@student.tugraz.at
Am Donnerstag, den 19.12.2019, 11:20 +0200 schrieb Efraim Flashner:
Toggle quote (3 lines)
> What does this need glib and glib:bin for? Is it just for building
> the
> schemas or does it actually need it at runtime?
To be honest, I'm not quite sure. I've copied this part from my dash-
to-dock extension, wherein I copied it from the gnome-shell-extensions
package.

As far as I'm aware both packages do build schemas, but I'm not sure
how extensions handle them at runtime. Perhaps this is already wrong
in the package I originally copied the snippet from. I'll try to see
how far I can get with depropagation.

Regards,
Leo
Leo Prikler wrote 5 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38538@debbugs.gnu.org)
15831159f236fe1a0e31d5882580c4d049a9522b.camel@student.tugraz.at
Am Donnerstag, den 19.12.2019, 12:00 +0100 schrieb Leo Prikler:
Toggle quote (17 lines)
> Am Donnerstag, den 19.12.2019, 11:20 +0200 schrieb Efraim Flashner:
> > What does this need glib and glib:bin for? Is it just for building
> > the
> > schemas or does it actually need it at runtime?
> To be honest, I'm not quite sure. I've copied this part from my
> dash-
> to-dock extension, wherein I copied it from the gnome-shell-
> extensions
> package.
>
> As far as I'm aware both packages do build schemas, but I'm not sure
> how extensions handle them at runtime. Perhaps this is already wrong
> in the package I originally copied the snippet from. I'll try to see
> how far I can get with depropagation.
>
> Regards,
> Leo
Upon closer inspection, it appears depropagation is indeed possible.
See the attached patch.
From 8b468ac52e55560e8581a4b93ddefba00dbfab62 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Thu, 19 Dec 2019 13:31:58 +0100
Subject: [PATCH 2/2] gnu: Depropagate glib from GNOME Shell extensions

* gnu/packages/gnome.scm (gnome-shell-extensions): Drop propagated inputs,
move them to more appropriate place.
[propagated-inputs]: Removed field.
[native-inputs] <glib:bin>: New input.
[inputs] <glib>: New input.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-dock): Likewise.
(gnome-shell-extension-hide-app-icon): Likewise.
---
gnu/packages/gnome-xyz.scm | 16 ++++++++--------
gnu/packages/gnome.scm | 8 ++++----
2 files changed, 12 insertions(+), 12 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 148f1db646..9dff38fa39 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -140,11 +140,11 @@ the Obsidian icon theme.")
(delete 'bootstrap)
(delete 'configure))))
(native-inputs
- `(("intltool" ,intltool)
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
("pkg-config" ,pkg-config)))
- (propagated-inputs
- `(("glib" ,glib)
- ("glib" ,glib "bin")))
+ (inputs
+ `(("glib" ,glib)))
(synopsis "Transforms GNOME's dash into a dock")
(description "This extension moves the dash out of the
overview, transforming it into a dock for easier application launching and
@@ -182,12 +182,12 @@ faster window switching.")
(mkdir-p (string-append (assoc-ref outputs "out")
"/share/gnome-shell/extensions")))))))
(native-inputs
- `(("intltool" ,intltool)
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
("unzip" ,unzip)
("zip" ,zip)))
- (propagated-inputs
- `(("glib" ,glib)
- ("glib" ,glib "bin")))
+ (inputs
+ `(("glib" ,glib)))
(synopsis "Hide app icon from GNOME's panel")
(description "This extension allows to hide the icon and/or title of the
currently focused application in the top panel of the GNOME shell.")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 77d96987d6..117937a9ba 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7537,11 +7537,11 @@ GNOME Shell appearance and extension, etc.")
(arguments
'(#:configure-flags '("-Dextension_set=all")))
(native-inputs
- `(("intltool" ,intltool)
+ `(("glib" ,glib "bin")
+ ("intltool" ,intltool)
("pkg-config" ,pkg-config)))
- (propagated-inputs
- `(("glib" ,glib)
- ("glib" ,glib "bin")))
+ (inputs
+ `(("glib" ,glib)))
(synopsis "Extensions for GNOME Shell")
(description "GNOME Shell extensions modify and extend GNOME Shell
functionality and behavior.")
--
2.24.1
Efraim Flashner wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 38538@debbugs.gnu.org)
20191219133801.GI917@E5400
On Thu, Dec 19, 2019 at 01:44:47PM +0100, Leo Prikler wrote:
Toggle quote (21 lines)
> Am Donnerstag, den 19.12.2019, 12:00 +0100 schrieb Leo Prikler:
> > Am Donnerstag, den 19.12.2019, 11:20 +0200 schrieb Efraim Flashner:
> > > What does this need glib and glib:bin for? Is it just for building
> > > the
> > > schemas or does it actually need it at runtime?
> > To be honest, I'm not quite sure. I've copied this part from my
> > dash-
> > to-dock extension, wherein I copied it from the gnome-shell-
> > extensions
> > package.
> >
> > As far as I'm aware both packages do build schemas, but I'm not sure
> > how extensions handle them at runtime. Perhaps this is already wrong
> > in the package I originally copied the snippet from. I'll try to see
> > how far I can get with depropagation.
> >
> > Regards,
> > Leo
> Upon closer inspection, it appears depropagation is indeed possible.
> See the attached patch.

It makes sense to me that glib:bin should be a native-input but I assume
glib, if it's needed at runtime, would probably need to be propagated
since the extension doesn't refer to it. Likely it's getting glib from
another package in the environment.

Also, the depropagation patch should really be a separate patch for each
package if we go that route.


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl37fTYACgkQQarn3Mo9
g1HQtA//fSChzHK/m84q0rRg2hXV0H4OAnAkch1HO9GGXx/YT1Yc3rZ8KO97DByh
LDPzRayMjMWMl6k8NzMTePYd1S6gzMFDKOlhFI6kOvTOee+mq3Aq4XuJjidgSiXG
lSS8s3TDchNuIvCXW1wG+ESE/wy4og/ODjHJWnJhsZr0SdU+gKqkjGPIPvH3FHaB
LYFqgYUDzb6/Bs3KMpR06deBFcNqJvtY1vS5j2vRZJ1KmT1J7wQrxFD3hMWnvl7Q
TDMqWm3bMDbuwmzeI9rVHlamDTorfLTriZvfEehTs2uN8fyHAq2uGESZ/UVZHgOZ
dU5vqkAH6WmoaDbGEc52MFeP6kwSHi3gjOUpTM0T/1QatH9bi88xvMWRuQhNq3aI
iuEWEVo3dXRycbhZnqkqZZuNz+RMZ/fZABF3+k4t291l/y2c5rcBoV2teBxdUnmv
EQmX3gvd71wNlT+wa4e10IeyKZw79GOwFrpSwnFTVU5vOEsi+s98ybh3l5KHt/8b
nmlQzp4KfrDN3pCgxv7iFH1JDUdFRqcWfhgbme+xNBGdlk4TjDAbFSDATiv+hJli
+Vm0KPLlPqt80PAwVbvBLdOcKJOH3svZeAIhiMidWu1Fd+znJg4Y0Bn0lwhuwdHm
55XrCR0u3cxIFv8UvGkkcevunCcjJO0soSLVe3QDCFdLnKW+7lQ=
=dU0g
-----END PGP SIGNATURE-----


Leo Prikler wrote 5 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38538@debbugs.gnu.org)
4f12bf6507870d42bd2b839e93cfc1db939d6ea8.camel@student.tugraz.at
Am Donnerstag, den 19.12.2019, 15:38 +0200 schrieb Efraim Flashner:
Toggle quote (34 lines)
> On Thu, Dec 19, 2019 at 01:44:47PM +0100, Leo Prikler wrote:
> > Am Donnerstag, den 19.12.2019, 12:00 +0100 schrieb Leo Prikler:
> > > Am Donnerstag, den 19.12.2019, 11:20 +0200 schrieb Efraim
> > > Flashner:
> > > > What does this need glib and glib:bin for? Is it just for
> > > > building
> > > > the
> > > > schemas or does it actually need it at runtime?
> > > To be honest, I'm not quite sure. I've copied this part from my
> > > dash-
> > > to-dock extension, wherein I copied it from the gnome-shell-
> > > extensions
> > > package.
> > >
> > > As far as I'm aware both packages do build schemas, but I'm not
> > > sure
> > > how extensions handle them at runtime. Perhaps this is already
> > > wrong
> > > in the package I originally copied the snippet from. I'll try to
> > > see
> > > how far I can get with depropagation.
> > >
> > > Regards,
> > > Leo
> > Upon closer inspection, it appears depropagation is indeed
> > possible.
> > See the attached patch.
>
> It makes sense to me that glib:bin should be a native-input but I
> assume
> glib, if it's needed at runtime, would probably need to be propagated
> since the extension doesn't refer to it. Likely it's getting glib
> from
> another package in the environment.
I'm not really sure, what the correct thing would be here. I did have
very weird behaviour with hide-app-icon, where having glib as input vs.
not having it made the difference of having to reload the extension
after changing settings vs. not having to. However, I'm really not
sure whether that was due to the extension or a weirdness in GNOME
Shell.

Toggle quote (3 lines)
> Also, the depropagation patch should really be a separate patch for
> each
> package if we go that route.
Perhaps. I just wanted to "prove" that you can at least depropagate
glib:bin and probably glib as well.
Efraim Flashner wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 38538-done@debbugs.gnu.org)
20191220070242.GB16523@E5400
On Thu, Dec 19, 2019 at 03:06:27PM +0100, Leo Prikler wrote:
Toggle quote (43 lines)
> Am Donnerstag, den 19.12.2019, 15:38 +0200 schrieb Efraim Flashner:
> > On Thu, Dec 19, 2019 at 01:44:47PM +0100, Leo Prikler wrote:
> > > Am Donnerstag, den 19.12.2019, 12:00 +0100 schrieb Leo Prikler:
> > > > Am Donnerstag, den 19.12.2019, 11:20 +0200 schrieb Efraim
> > > > Flashner:
> > > > > What does this need glib and glib:bin for? Is it just for
> > > > > building
> > > > > the
> > > > > schemas or does it actually need it at runtime?
> > > > To be honest, I'm not quite sure. I've copied this part from my
> > > > dash-
> > > > to-dock extension, wherein I copied it from the gnome-shell-
> > > > extensions
> > > > package.
> > > >
> > > > As far as I'm aware both packages do build schemas, but I'm not
> > > > sure
> > > > how extensions handle them at runtime. Perhaps this is already
> > > > wrong
> > > > in the package I originally copied the snippet from. I'll try to
> > > > see
> > > > how far I can get with depropagation.
> > > >
> > > > Regards,
> > > > Leo
> > > Upon closer inspection, it appears depropagation is indeed
> > > possible.
> > > See the attached patch.
> >
> > It makes sense to me that glib:bin should be a native-input but I
> > assume
> > glib, if it's needed at runtime, would probably need to be propagated
> > since the extension doesn't refer to it. Likely it's getting glib
> > from
> > another package in the environment.
> I'm not really sure, what the correct thing would be here. I did have
> very weird behaviour with hide-app-icon, where having glib as input vs.
> not having it made the difference of having to reload the extension
> after changing settings vs. not having to. However, I'm really not
> sure whether that was due to the extension or a weirdness in GNOME
> Shell.
>

In any case, I've pushed the patch with glib:bin in native-inputs and
glib in propagated-inputs.

Toggle quote (7 lines)
> > Also, the depropagation patch should really be a separate patch for
> > each
> > package if we go that route.
> Perhaps. I just wanted to "prove" that you can at least depropagate
> glib:bin and probably glib as well.
>

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl38chIACgkQQarn3Mo9
g1GfmA/+ONnZv9+x1DAY1HecocKdLsz6KarLe5HnAhmd198JMgqGSST9G2FGLg9H
dCu0dvV7Rqn/GOS5bClvmS5fV2/wd5RLGTpBRIXf+ag929OpotQ8xE60rYwKTZzv
Z+s2OIEiffW8RTgFV6hgFTTtEdIADagJfUqiZ83Qdim7iHU/aNEqeVOVtS7oeDxG
DaP7eveIvd/fUkhG5Pomdyy+bx1hNhceRqiyHNkD8ZfHCCOPCm/IS3mWjfIUABT6
q+Z0o5Cf3HSy7cAA+YhaLvL1sqY0FutM3C7/gBHTPFLC5ir81eYDrShH3sACOLXj
hRC1EXyjWaJv/hGTYE4lyuWGmRF2YmH8lP/SqxRRHpq3k2womy+DoY7woWIk6VB+
RZD87HQzsLCkupsf8s/Mw/NSp3QSl4omizNqeBtElQ4BF0Rci9WJUMsMjNn5YbVL
QKqzpD5Tp9zGWKTWbpqhVw05YP45d1qyWsdGJB8qPxWYLKewzWCuYekXu6+R+gLo
H3qJSMPOlSa23BiNlJOz5pfD+UZEXflCQScY/byCsRQbplwQmXxFout2VCfF8jU0
GiS3WYb7XjGARhqebMpTEQfGNxnBajLk9bhfUKcQ2Qp8LmXikk65sKpD9UQUVfsR
thyLKDqflVqfLdru3+/FSTIsoOF86MVByjvAjdQTzQqTGF31XI4=
=2C7J
-----END PGP SIGNATURE-----


Closed
Leo Prikler wrote 5 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38538-done@debbugs.gnu.org)
5045109122d5968f363a1206e01eab6f3fdf12b7.camel@student.tugraz.at
Am Freitag, den 20.12.2019, 09:02 +0200 schrieb Efraim Flashner:
Toggle quote (2 lines)
> In any case, I've pushed the patch with glib:bin in native-inputs and
> glib in propagated-inputs.
I just got around to checking and it appears the rewritten install
phase breaks the package. I've attached a fix in 0001, and also split
up my depropagation patch for the other packages.

Regards,
Leo
From 5d5e14ae3a03a1981ed0d98fe4b17353decd0095 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 22 Dec 2019 16:03:43 +0100
Subject: [PATCH 1/3] gnu: gnome-shell-extension-hide-app-icon: Fix
installation.

* gnu/packages/gnome-xyz.scm: (gnome-shell-extension-hide-app-icon):
Install in subdirectory. Adjust indentation.
---
gnu/packages/gnome-xyz.scm | 35 +++++++++++++++++++----------------
1 file changed, 19 insertions(+), 16 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 4b5e07a1a0..a43424026b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -158,15 +158,16 @@ faster window switching.")
(name "gnome-shell-extension-hide-app-icon")
(version (git-version "2.7" revision commit))
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon.git")
- (commit commit)))
- (sha256
- (base32
- "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
- (file-name (git-file-name name version))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/michael-rapp"
+ "/gnome-shell-extension-hide-app-icon.git"))
+ (commit commit)))
+ (sha256
+ (base32
+ "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test target
@@ -178,10 +179,11 @@ faster window switching.")
(delete 'configure) ; no configure script
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (copy-recursively "hide-app-icon@mrapp.sourceforge.com/"
- (string-append out "/share/gnome-shell/extensions"))
- #t))))))
+ (let ((out (assoc-ref outputs "out"))
+ (pre "/share/gnome-shell/extensions/")
+ (dir "hide-app-icon@mrapp.sourceforge.com"))
+ (copy-recursively dir (string-append out pre dir))
+ #t))))))
(native-inputs
`(("glib" ,glib "bin")
("intltool" ,intltool)))
@@ -190,12 +192,13 @@ faster window switching.")
(synopsis "Hide app icon from GNOME's panel")
(description "This extension allows to hide the icon and/or title of the
currently focused application in the top panel of the GNOME shell.")
- (home-page "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
+ (home-page
+ "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
(license
;; README.md and LICENSE.txt disagree -- the former claims v3, the
;; latter v2. No mention of "or later" in either place or in the code.
- (list license:gpl2
- license:gpl3)))))
+ (list license:gpl2
+ license:gpl3)))))
(define-public gnome-shell-extension-dash-to-panel
(package
--
2.24.1
From d48135da48aca403477799db9bd9d58ec79ce5e4 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 22 Dec 2019 16:10:04 +0100
Subject: [PATCH 2/3] gnu: gnome-shell-extension-dash-to-dock: Depropagate
glib:bin.

* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-dock):
[propagated-inputs]: Move glib:bin from here...
[native-inputs]: ... to here.
---
gnu/packages/gnome-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a43424026b..0d15532513 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -139,11 +139,11 @@ the Obsidian icon theme.")
(delete 'bootstrap)
(delete 'configure))))
(native-inputs
- `(("intltool" ,intltool)
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(propagated-inputs
- `(("glib" ,glib)
- ("glib" ,glib "bin")))
+ `(("glib" ,glib)))
(synopsis "Transforms GNOME's dash into a dock")
(description "This extension moves the dash out of the
overview, transforming it into a dock for easier application launching and
--
2.24.1
From 0b8dc9d4b8463c3f68d72c506e49c4706ae64144 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 22 Dec 2019 16:12:32 +0100
Subject: [PATCH 3/3] gnu: gnome-shell-extensions: Depropagate glib:bin.

* gnu/packages/gnome.scm (gnome-shell-extensions):
[propagated-inputs]: Move glib:bin from here...
[native-inputs]: ... to here.
---
gnu/packages/gnome.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2f772ee1b0..95da97e95d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7570,11 +7570,11 @@ GNOME Shell appearance and extension, etc.")
(arguments
'(#:configure-flags '("-Dextension_set=all")))
(native-inputs
- `(("intltool" ,intltool)
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(propagated-inputs
- `(("glib" ,glib)
- ("glib" ,glib "bin")))
+ `(("glib" ,glib)))
(synopsis "Extensions for GNOME Shell")
(description "GNOME Shell extensions modify and extend GNOME Shell
functionality and behavior.")
--
2.24.1
Closed
Efraim Flashner wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 38538-done@debbugs.gnu.org)
20191223074110.GM1115@E5400
On Sun, Dec 22, 2019 at 04:33:48PM +0100, Leo Prikler wrote:
Toggle quote (10 lines)
> Am Freitag, den 20.12.2019, 09:02 +0200 schrieb Efraim Flashner:
> > In any case, I've pushed the patch with glib:bin in native-inputs and
> > glib in propagated-inputs.
> I just got around to checking and it appears the rewritten install
> phase breaks the package. I've attached a fix in 0001, and also split
> up my depropagation patch for the other packages.
>
> Regards,
> Leo

Oh no! I'm glad you caught it. The included install phase was way too
complicated for what it was supposed to do.

I've gone ahead and pushed these too. Thanks!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl4Ab5YACgkQQarn3Mo9
g1GtDw/7BqPqhpJVvUIyIISJs5RrbcLcNVrjAMyAfdzW1SayDKWKapb6n6rkeAMB
9d6KhbDwT6llLopWfsavEtFbMXE2HzydJylh/RqF1+/nMbjJgyaaWId2gxsHXtN7
HIM/Ig2oD+YVSaS5zWfzeWhOXQncwCE7oyNXaFX5cdPujVvLazTHZDezMi70hvod
sLxLD+hBTxtZFCkv54ddYgB5W511fWSDRlmrc27FxPt7R2JS1uVVzxfPBvDo8jUU
h2CdS8WITbhOgwe0xRpcRUkk+C9N7oZrlOpYxaN1enuqNuBhk4OkiUKvl4/K0YKM
yO7PGJ9zwsNKMchTgNg/zqL+MeByxB5YzazskC2U+PbP8IZTMQCzYsS7kR5MPc6l
oiPXvsFfwnoydI7ga4fUQPCxolyLrWXivczzIaBnJbiydJZLZdWeaYXDQebbKwVD
79VGoF6wADehvh/RTe8L8RCKcbc121UOv6/q8uQi6Ez+rgtsJAVFxt2q6Aa87sLX
LHjsOJG9G7CP79XMWWqLAXzbDexz5clBZ+4F/8TfbFuQLq/NRYB+kP510lHrBirM
WA5UB3zG2s+4vhvz7a5Ad1tbkdQCzXqiOHNkNhOdxxjsO5Zvzk+dOvNc5IoFTJ8J
l7J/xGgm22wcftWdFTQvNj0vXyBgvdrBPIu+B8nnGN5aMAv/dZU=
=JzUT
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38538@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38538
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help