[PATCH] GHC-HAPPSTACK-SERVER

  • Done
  • quality assurance status badge
Details
One participant
  • Brett Gilio
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 5 years ago
(address . guix-patches@gnu.org)
871rtkr1g8.fsf@posteo.net
This patch series introduces two new variables.
-- ghc-sendfile
-- ghc-happstack-server

ghc-sendfile was added as a necessary input for ghc-happstack-server.

Let me know what you all think!

--
Brett M. Gilio
Brett Gilio wrote 5 years ago
[PATCH 1/2] gnu: Add ghc-sendfile.
(address . 38488@debbugs.gnu.org)
87y2vspms0.fsf@posteo.net
From bef2ec92972c3fbef7558edc9d9ba37d7ca98d68 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Wed, 4 Dec 2019 01:29:20 -0600
Subject: [PATCH 1/2] gnu: Add ghc-sendfile.

* gnu/packages/haskell-web.scm (ghc-sendfile): New variable.
---
gnu/packages/haskell-web.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 1672170131..6098ad5759 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1527,3 +1527,24 @@ The first three components of the version number match the upstream flot
version. The package is designed to meet the redistribution
requirements of downstream users (e.g. Debian).")
(license license:expat)))
+(define-public ghc-sendfile
+ (package
+ (name "ghc-sendfile")
+ (version "0.7.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/sendfile/sendfile-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0988snmx3bylpw3kcq8hsgji8idc6xcrcfp275qjv3apfdgc9rp0"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-network" ,ghc-network)))
+ (home-page
+ "https://hub.darcs.net/stepcut/sendfile")
+ (synopsis "Portable sendfile library for Haskell")
+ (description
+ "Haskell library which exposes zero-copy sendfile functionality in a portable way.")
+ (license license:bsd-3)))
--
2.24.0
Brett Gilio wrote 5 years ago
[PATCH 2/2] gnu: Add ghc-happstack-server.
(address . 38488@debbugs.gnu.org)
87v9qwpmrm.fsf@posteo.net
From cf5229f98030e835dd687b933713dc1a10d7ce92 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Wed, 4 Dec 2019 01:29:38 -0600
Subject: [PATCH 2/2] gnu: Add ghc-happstack-server.

* gnu/packages/haskell-web.scm (ghc-happstack-server): New variable.
---
gnu/packages/haskell-web.scm | 47 ++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 6098ad5759..5888e8542e 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1527,6 +1527,53 @@ The first three components of the version number match the upstream flot
version. The package is designed to meet the redistribution
requirements of downstream users (e.g. Debian).")
(license license:expat)))
+
+(define-public ghc-happstack-server
+ (package
+ (name "ghc-happstack-server")
+ (version "7.5.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/happstack-server/happstack-server-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0i7csvmwv7n68gkwqzi985p2mjdgzipjnlj873sdiknhx9pfmq70"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-network" ,ghc-network)
+ ("ghc-network-bsd" ,ghc-network-bsd)
+ ("ghc-network-uri" ,ghc-network-uri)
+ ("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-extensible-exceptions"
+ ,ghc-extensible-exceptions)
+ ("ghc-hslogger" ,ghc-hslogger)
+ ("ghc-html" ,ghc-html)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-sendfile" ,ghc-sendfile)
+ ("ghc-system-filepath" ,ghc-system-filepath)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-threads" ,ghc-threads)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-transformers-compat"
+ ,ghc-transformers-compat)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-zlib" ,ghc-zlib)))
+ (native-inputs `(("ghc-hunit" ,ghc-hunit)))
+ (home-page "http://happstack.com")
+ (synopsis "Web related tools and services for Haskell")
+ (description
+ "Happstack Server provides an HTTP server and a rich set of functions for
+routing requests, handling query parameters, generating responses, working with
+cookies, serving files, and more.")
+ (license license:bsd-3)))
+
(define-public ghc-sendfile
(package
(name "ghc-sendfile")
--
2.24.0
Brett Gilio wrote 5 years ago
Re: [bug#38488] [PATCH] GHC-HAPPSTACK-SERVER
(address . 38488-done@debbugs.gnu.org)
87tv6d9ko3.fsf@posteo.net
close
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38488@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38488
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help