[PATCH] gnu: Add lolcat

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
20191204014644.1491-1-leo.prikler@student.tugraz.at
* gnu/packages/games.scm (lolcat): New package.
---
gnu/packages/games.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8dd08844ee..b15016e4bb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -498,6 +498,47 @@ cows can think too: all you have to do is run @command{cowthink}. If you're
tired of cows, a variety of other ASCII-art messengers are available.")
(license license:gpl3+)))
+(define-public lolcat
+ (let ((commit "35dca3d0a381496d7195cd78f5b24aa7b62f2154")
+ (revision "0"))
+ (package
+ (name "lolcat")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaseg/lolcat.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0jjbkqcc2ikjxd1xgdyv4rb0vsw218181h89f2ywg29ffs3ypd8g"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;; tests don't exist
+ #:make-flags (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((dest (map (lambda (path) (string-append path "/bin"))
+ (list (assoc-ref outputs "out")
+ (assoc-ref outputs "censor")))))
+ (for-each mkdir-p dest)
+ (install-file "lolcat" (car dest))
+ (install-file "censor" (cadr dest))
+ #t))))))
+ (outputs (list "out" "censor"))
+ (home-page "https://github.com/jaseg/lolcat")
+ (synopsis "Rainbow coloring effect for text console display")
+ (description "Lolcat concatenates files and streams like regular cat,
+but it also adds terminal escape codes between characters and lines resulting
+in a rainbow effect.")
+ (license license:wtfpl2))))
+
(define-public freedoom
(package
(name "freedoom")
--
2.24.0
Brett Gilio wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 38480@debbugs.gnu.org)
877e3ciylo.fsf@posteo.net
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (2 lines)
> + `(#:tests? #f ;; tests don't exist

LGTM! Though, perhaps an aesthetic issue. I usually prefer (and see)
"no check target". Carry on!

--
Brett M. Gilio
Leo Prikler wrote 5 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 38480@debbugs.gnu.org)
fa8f7a346d9f190892f49e1538ed909d184c1412.camel@student.tugraz.at
Hi Brett,

Am Dienstag, den 03.12.2019, 21:00 -0600 schrieb Brett Gilio:
Toggle quote (6 lines)
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
>
> > + `(#:tests? #f ;; tests don't exist
>
> LGTM! Though, perhaps an aesthetic issue. I usually prefer (and see)
> "no check target". Carry on!
Fair enough, I've adapted the patch.

Regards,
Leo
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Wed, 4 Dec 2019 02:46:44 +0100
Subject: [PATCH] gnu: Add lolcat

* gnu/packages/games.scm (lolcat): New package.
---
gnu/packages/games.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8dd08844ee..b15016e4bb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -498,6 +498,47 @@ cows can think too: all you have to do is run @comma=
nd{cowthink}. If you're
tired of cows, a variety of other ASCII-art messengers are available.")
(license license:gpl3+)))

+(define-public lolcat
+ (let ((commit "35dca3d0a381496d7195cd78f5b24aa7b62f2154")
+ (revision "0"))
+ (package
+ (name "lolcat")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaseg/lolcat.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0jjbkqcc2ikjxd1xgdyv4rb0vsw218181h89f2ywg29ffs3ypd8g"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;; no check target
+ #:make-flags (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((dest (map (lambda (path) (string-append path "/bin"))
+ (list (assoc-ref outputs "out")
+ (assoc-ref outputs "censor")))))
+ (for-each mkdir-p dest)
+ (install-file "lolcat" (car dest))
+ (install-file "censor" (cadr dest))
+ #t))))))
+ (outputs (list "out" "censor"))
+ (home-page "https://github.com/jaseg/lolcat")
+ (synopsis "Rainbow coloring effect for text console display")
+ (description "Lolcat concatenates files and streams like regular cat,
+but it also adds terminal escape codes between characters and lines resulting
+in a rainbow effect.")
+ (license license:wtfpl2))))
+
(define-public freedoom
(package
(name "freedoom")
--
2.24.0
Ludovic Courtès wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
87k16ywkpp.fsf@gnu.org
Hello!

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (6 lines)
> From: Leo Prikler <leo.prikler@student.tugraz.at>
> Date: Wed, 4 Dec 2019 02:46:44 +0100
> Subject: [PATCH] gnu: Add lolcat
>
> * gnu/packages/games.scm (lolcat): New package.

[...]

Toggle quote (11 lines)
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((dest (map (lambda (path) (string-append path "/bin"))
> + (list (assoc-ref outputs "out")
> + (assoc-ref outputs "censor")))))
> + (for-each mkdir-p dest)
> + (install-file "lolcat" (car dest))
> + (install-file "censor" (cadr dest))
> + #t))))))
> + (outputs (list "out" "censor"))

Can’t we keep them both in the same output? Separate outputs are
normally only used when it helps save space, but I don’t think that’s a
concern here. :-)

Toggle quote (3 lines)
> + (synopsis "Rainbow coloring effect for text console display")
> + (description "Lolcat concatenates files and streams like regular cat,
^ ^
Maybe @command{cat} and @command{lolcat}.

Could you send an updated patch?

Thanks,
Ludo’.
Leo Prikler wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
a9087ff071bae8a10c948a32b8d5cef08aa6bc6a.camel@student.tugraz.at
Hello!

Am Sonntag, den 15.12.2019, 00:28 +0100 schrieb Ludovic Courtès:
Toggle quote (29 lines)
> Hello!
>
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
>
> > From: Leo Prikler <leo.prikler@student.tugraz.at>
> > Date: Wed, 4 Dec 2019 02:46:44 +0100
> > Subject: [PATCH] gnu: Add lolcat
> >
> > * gnu/packages/games.scm (lolcat): New package.
>
> [...]
>
> > + (replace 'install
> > + (lambda* (#:key outputs #:allow-other-keys)
> > + (let ((dest (map (lambda (path) (string-append path
> > "/bin"))
> > + (list (assoc-ref outputs "out")
> > + (assoc-ref outputs
> > "censor")))))
> > + (for-each mkdir-p dest)
> > + (install-file "lolcat" (car dest))
> > + (install-file "censor" (cadr dest))
> > + #t))))))
> > + (outputs (list "out" "censor"))
>
> Can’t we keep them both in the same output? Separate outputs are
> normally only used when it helps save space, but I don’t think that’s
> a
> concern here. :-)
Of course we can. I initially separated them, because it's really two
very different programs put into one git repo, but of course the
separation serves no real purpose.

Toggle quote (8 lines)
> > + (synopsis "Rainbow coloring effect for text console
> > display")
> > + (description "Lolcat concatenates files and streams like
> > regular cat,
> ^
> ^
> Maybe @command{cat} and @command{lolcat}.
Not sure about @command{lolcat}, since it's at the start of the
sentence, but okay.

Toggle quote (4 lines)
> Could you send an updated patch?
>
> Thanks,
> Ludo’.
Patch is attached.

Regards,
Leo
From 42827748e50fe20fdf23ff1137067a7d6c80c87e Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Wed, 4 Dec 2019 02:46:44 +0100
Subject: [PATCH] gnu: Add lolcat

* gnu/packages/games.scm (lolcat): New package.
---
gnu/packages/games.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ded27c1f63..1f08dd240a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -502,6 +502,44 @@ cows can think too: all you have to do is run @command{cowthink}. If you're
tired of cows, a variety of other ASCII-art messengers are available.")
(license license:gpl3+)))
+(define-public lolcat
+ (let ((commit "35dca3d0a381496d7195cd78f5b24aa7b62f2154")
+ (revision "0"))
+ (package
+ (name "lolcat")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaseg/lolcat.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0jjbkqcc2ikjxd1xgdyv4rb0vsw218181h89f2ywg29ffs3ypd8g"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;; no check target
+ #:make-flags (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((dest (string-append path "/bin")))
+ (mkdir-p dest)
+ (install-file "lolcat" dest)
+ #t))))))
+ (outputs (list "out" "censor"))
+ (home-page "https://github.com/jaseg/lolcat")
+ (synopsis "Rainbow coloring effect for text console display")
+ (description "@command{lolcat} concatenates files and streams like
+regular @command{cat}, but it also adds terminal escape codes between
+characters and lines resulting in a rainbow effect.")
+ (license license:wtfpl2))))
+
(define-public freedoom
(package
(name "freedoom")
--
2.24.0
Ludovic Courtès wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
87tv61tidl.fsf@gnu.org
Hi!

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (7 lines)
> From 42827748e50fe20fdf23ff1137067a7d6c80c87e Mon Sep 17 00:00:00 2001
> From: Leo Prikler <leo.prikler@student.tugraz.at>
> Date: Wed, 4 Dec 2019 02:46:44 +0100
> Subject: [PATCH] gnu: Add lolcat
>
> * gnu/packages/games.scm (lolcat): New package.

I made the changes below to make it work with a single output.

Committed, thanks!

Ludo’.
Toggle diff (19 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1f08dd240a..c8d671bbdc 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -528,11 +528,12 @@ tired of cows, a variety of other ASCII-art messengers are available.")
(delete 'configure)
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((dest (string-append path "/bin")))
+ (let* ((out (assoc-ref outputs "out"))
+ (dest (string-append out "/bin")))
(mkdir-p dest)
(install-file "lolcat" dest)
+ (install-file "censor" dest)
#t))))))
- (outputs (list "out" "censor"))
(home-page "https://github.com/jaseg/lolcat")
(synopsis "Rainbow coloring effect for text console display")
(description "@command{lolcat} concatenates files and streams like
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38480@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38480
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help