(address . guix-patches@gnu.org)
Hello,
This is to be applied against core-updates and fixes:
$ guix build --target=powerpc64le-linux-gnu bootstrap-tarballs
dftxbs3e
From dcbd3a812038fbc1a229836a850f529aa35b45c8 Mon Sep 17 00:00:00 2001
From: dftxbs3e <dftxbs3e@free.fr>
Date: Mon, 2 Dec 2019 20:02:24 +0100
Subject: [PATCH 2/2] gnu: cross-gcc-arguments: Enable 128 bit long double for
POWER9.
---
gnu/packages/cross-base.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (16 lines)
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 13237fb8a8..e60a8ed03a 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -150,6 +150,9 @@ base compiler and using LIBC (which may be either a libc package or #f.)"
"--disable-decimal-float" ;would need libc
"--disable-libcilkrts"
+ ;; On POWER9 (little endian) glibc needs the 128 bit long double type.
+ "--with-long-double-128"
+
;; When target is any OS other than 'none' these
;; libraries will fail if there is no libc
;; present. See
--
2.21.0
From 87b30dcb90572bd46c8eb087efe7d75db362f59b Mon Sep 17 00:00:00 2001
From: dftxbs3e <dftxbs3e@free.fr>
Date: Mon, 2 Dec 2019 19:58:19 +0100
Subject: [PATCH 1/2] gnu: gcc-boot0: Enable 128 bit long double for POWER9.
---
gnu/packages/commencement.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (16 lines)
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 8bf7704598..bfdba4dbd2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1576,6 +1576,9 @@ exec " gcc "/bin/" program
"--disable-shared"
"--enable-languages=c,c++"
+ ;; On POWER9 (little endian) glibc needs the 128 bit long double type.
+ "--with-long-double-128"
+
;; libstdc++ cannot be built at this stage
;; ("Link tests are not allowed after
;; GCC_NO_EXECUTABLES.").
--
2.21.0