[PATCH] gnu: Add emacs-org-present.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 5 years ago
(address . guix-patches@gnu.org)
87o8x3gqhq.fsf@posteo.net
From c007a92689004917fa422b668f8ab55b2a49af22 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 22 Nov 2019 22:32:46 -0600
Subject: [PATCH] gnu: Add emacs-org-present.

* gnu/packages/emacs-xyz.scm (emacs-org-present): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0caf12a423..963aa4d96f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19943,3 +19943,27 @@ Google guidelines.")
(description "Helm Fish Completion is a Helm interface for Emacs
fish-completion. It can be used in both Eshell and M-x shell.")
(license license:gpl3+))))
+
+(define-public emacs-org-present
+ (let ((commit "d13acd70eff6a1608bc991920232146a0de76b21"))
+ (package
+ (name "emacs-org-present")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rlister/org-present.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jz8xiny3rv9ql0p623byz32pip1b82j2c2nyfz2wd114kiabb6q"))))
+ (build-system emacs-build-system)
+ (synopsis "Ultra-minimalist presentation minor-mode for Emacs org-mode")
+ (description "Org-present is an extremely minimalist presentation tool
+for Emacs org-mode. Simply layout your presentation with each slide under a
+top-level header, start the minor mode with @code{org-present}, and page through
+each slide with left/right keys.")
+ (home-page "https://github.com/rlister/org-present")
+ (license license:gpl2))))
--
2.24.0
Ludovic Courtès wrote 5 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 38340-done@debbugs.gnu.org)
87a78bks4u.fsf@gnu.org
Brett Gilio <brettg@posteo.net> skribis:

Toggle quote (7 lines)
>>From c007a92689004917fa422b668f8ab55b2a49af22 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Fri, 22 Nov 2019 22:32:46 -0600
> Subject: [PATCH] gnu: Add emacs-org-present.
>
> * gnu/packages/emacs-xyz.scm (emacs-org-present): New variable.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38340@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38340
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help