[PATCH 1/2] gnu: Add emacs-shrink-path.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 5 years ago
(address . guix-patches@gnu.org)
87tv6vgs2w.fsf@posteo.net
From 90879f02c521d479630cabe3ff754952e859efd6 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 22 Nov 2019 21:50:54 -0600
Subject: [PATCH 1/2] gnu: Add emacs-shrink-path.

* gnu/packages/emacs-xyz.scm (emacs-shrink-path): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0caf12a423..c280d44f39 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19943,3 +19943,28 @@ Google guidelines.")
(description "Helm Fish Completion is a Helm interface for Emacs
fish-completion. It can be used in both Eshell and M-x shell.")
(license license:gpl3+))))
+(define-public emacs-shrink-path
+ (package
+ (name "emacs-shrink-path")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/bennya/shrink-path.el.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0kx0c4syd7k6ff9j463bib32pz4wq0rzjlg6b0yqnymlzfr1mbki"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)))
+ (home-page
+ "https://gitlab.com/bennya/shrink-path.el")
+ (synopsis "Fish-style path truncation in emacs-lisp")
+ (description "Small utility functions that allow for fish-style
+trunctated directories in eshell and various modelines.")
+ (license license:gpl3+)))
--
2.24.0
Brett Gilio wrote 5 years ago
[PATCH 2/2] gnu: Add emacs-doom-modeline.
(address . 38339@debbugs.gnu.org)
87r21zgryj.fsf@posteo.net
From 1ffd8682be2e9d11d54b26f2765464aab7a0b18e Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 22 Nov 2019 21:51:56 -0600
Subject: [PATCH 2/2] gnu: Add emacs-doom-modeline.

* gnu/packages/emacs-xyz.scm (emacs-doom-modeline): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c280d44f39..2bf7b0ab36 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19943,6 +19943,34 @@ Google guidelines.")
(description "Helm Fish Completion is a Helm interface for Emacs
fish-completion. It can be used in both Eshell and M-x shell.")
(license license:gpl3+))))
+
+(define-public emacs-doom-modeline
+ (package
+ (name "emacs-doom-modeline")
+ (version "2.7.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seagle0128/doom-modeline.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "16qlakgbwwjfr013g0cly4js4v9cfhxb8fn7zmn124f788m22357"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:test-command '("ert-runner")))
+ (native-inputs `(("emacs-ert-runner" ,emacs-ert-runner)))
+ (propagated-inputs
+ `(("emacs-all-the-icons" ,emacs-all-the-icons)
+ ("emacs-shrink-path" ,emacs-shrink-path)))
+ (synopsis "Fancy and fast mode-line inspired by minimalism design")
+ (description "Doom modeline is a complete modeline for GNU Emacs inspired
+by the Doom theme collection. This modeline features support for mode-specific
+icon support, git integration, and several other utilities.")
+ (home-page "https://github.com/seagle0128/doom-modeline/")
+ (license license:gpl3+)))
+
(define-public emacs-shrink-path
(package
(name "emacs-shrink-path")
--
2.24.0
Ludovic Courtès wrote 5 years ago
Re: [bug#38339] [PATCH 1/2] gnu: Add emacs-shrink-path.
(name . Brett Gilio)(address . brettg@posteo.net)(address . 38339@debbugs.gnu.org)
87immzksdm.fsf@gnu.org
Brett Gilio <brettg@posteo.net> skribis:

Toggle quote (7 lines)
>>From 90879f02c521d479630cabe3ff754952e859efd6 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Fri, 22 Nov 2019 21:50:54 -0600
> Subject: [PATCH 1/2] gnu: Add emacs-shrink-path.
>
> * gnu/packages/emacs-xyz.scm (emacs-shrink-path): New variable.

Applied with the changes below.
Toggle diff (25 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cda832df83..637bf0c9e3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19953,6 +19953,7 @@ Google guidelines.")
(description "Helm Fish Completion is a Helm interface for Emacs
fish-completion. It can be used in both Eshell and M-x shell.")
(license license:gpl3+))))
+
(define-public emacs-shrink-path
(package
(name "emacs-shrink-path")
@@ -19972,9 +19973,8 @@ fish-completion. It can be used in both Eshell and M-x shell.")
`(("emacs-s" ,emacs-s)
("emacs-dash" ,emacs-dash)
("emacs-f" ,emacs-f)))
- (home-page
- "https://gitlab.com/bennya/shrink-path.el")
+ (home-page "https://gitlab.com/bennya/shrink-path.el")
(synopsis "Fish-style path truncation in emacs-lisp")
- (description "Small utility functions that allow for fish-style
-trunctated directories in eshell and various modelines.")
+ (description "This package provides utility functions that allow for
+Fish-style truncated directories in eshell and various modelines.")
(license license:gpl3+)))
Ludovic Courtès wrote 5 years ago
Re: [bug#38339] [PATCH 2/2] gnu: Add emacs-doom-modeline.
(name . Brett Gilio)(address . brettg@posteo.net)(address . 38339-done@debbugs.gnu.org)
87eexnks8l.fsf@gnu.org
Brett Gilio <brettg@posteo.net> skribis:

Toggle quote (7 lines)
>>From 1ffd8682be2e9d11d54b26f2765464aab7a0b18e Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Fri, 22 Nov 2019 21:51:56 -0600
> Subject: [PATCH 2/2] gnu: Add emacs-doom-modeline.
>
> * gnu/packages/emacs-xyz.scm (emacs-doom-modeline): New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38339@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38339
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help