[PATCH 2/2] gnu: Add emacs-telega.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 5 years ago
(address . guix-patches@gnu.org)
87k17rviy8.fsf@posteo.net
From c632d01dd48f89dab2822d5a81d091ca68b43c62 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 22 Nov 2019 12:54:44 -0600
Subject: [PATCH 2/2] gnu: Add emacs-telega.

* gnu/packages/emacs-xyz.scm (emacs-telega): New variable.
---
gnu/packages/emacs-xyz.scm | 58 ++++++++++++++++++++++++++++++++++++++
1 file changed, 58 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0caf12a423..7ff53ecf1e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -114,6 +114,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages libevent)
+ #:use-module (gnu packages messaging)
#:use-module (gnu packages music)
#:use-module (gnu packages version-control)
#:use-module (gnu packages imagemagick)
@@ -19943,3 +19944,60 @@ Google guidelines.")
(description "Helm Fish Completion is a Helm interface for Emacs
fish-completion. It can be used in both Eshell and M-x shell.")
(license license:gpl3+))))
+
+(define-public emacs-telega
+ (let ((commit "019e923f933370d75dbe0a8473a18eb66fe94c0e")
+ (revision "1")
+ (version "0.4.4"))
+ (package
+ (name "emacs-telega")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zevlg/telega.el.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "058814agkq8mp9ajpj8sz51rm9nigs2xpsdij05wjkxhfq30kqva"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:modules ((guix build gnu-build-system)
+ ((guix build emacs-build-system) #:prefix emacs:)
+ (guix build utils)
+ (guix build emacs-utils))
+ #:imported-modules (,@%gnu-build-system-modules
+ (guix build emacs-build-system)
+ (guix build emacs-utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-patch
+ (lambda _
+ (substitute* "server/Makefile"
+ (("CC=cc")
+ "CC=gcc")
+ (("INSTALL_PREFIX=\\$\\(HOME\\)/.telega")
+ (string-append "INSTALL_PREFIX=" (assoc-ref %outputs "out") "/bin")))))
+ (delete 'configure)
+
+ ;; Build emacs-side using `emacs-build-system'
+ (add-after 'compress-documentation 'emacs-add-source-to-load-path
+ (assoc-ref emacs:%standard-phases 'add-source-to-load-path))
+ (add-after 'emacs-set-emacs-load-path 'emacs-install
+ (assoc-ref emacs:%standard-phases 'install))
+ (add-after 'emacs-install 'emacs-build
+ (assoc-ref emacs:%standard-phases 'build))
+ (add-after 'emacs-install 'emacs-make-autoloads
+ (assoc-ref emacs:%standard-phases 'make-autoloads)))))
+ (propagated-inputs
+ `(("emacs-visual-fill-column" ,emacs-visual-fill-column)))
+ (native-inputs
+ `(("tdlib" ,tdlib)
+ ("emacs" ,emacs-minimal)))
+ (synopsis "GNU Emacs telegram client")
+ (description "Telega is full-featured, unofficial client for Telegram platform for GNU Emacs.")
+ (home-page "https://github.com/zevlg/telega.el")
+ (license license:gpl3+))))
--
2.24.0
Ludovic Courtès wrote 5 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 38326@debbugs.gnu.org)
87mucer4jx.fsf@gnu.org
Hi Brett,

Brett Gilio <brettg@posteo.net> skribis:

Toggle quote (21 lines)
>>From c632d01dd48f89dab2822d5a81d091ca68b43c62 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Fri, 22 Nov 2019 12:54:44 -0600
> Subject: [PATCH 2/2] gnu: Add emacs-telega.
>
> * gnu/packages/emacs-xyz.scm (emacs-telega): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 58 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 58 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 0caf12a423..7ff53ecf1e 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -114,6 +114,7 @@
> #:use-module (gnu packages image)
> #:use-module (gnu packages linux)
> #:use-module (gnu packages libevent)
> + #:use-module (gnu packages messaging)
> #:use-module (gnu packages music)

We have a problem (not your fault!): applying this hunk on top of
current master breaks it all, due to circular top-level references in
the modules.

I haven’t been able to spend much time investigating, but we first need
to find out where that comes from.

Ludo’.
Brett Gilio wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38326@debbugs.gnu.org)
87y2vyfpyg.fsf@posteo.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (34 lines)
> Hi Brett,
>
> Brett Gilio <brettg@posteo.net> skribis:
>
>>>From c632d01dd48f89dab2822d5a81d091ca68b43c62 Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Fri, 22 Nov 2019 12:54:44 -0600
>> Subject: [PATCH 2/2] gnu: Add emacs-telega.
>>
>> * gnu/packages/emacs-xyz.scm (emacs-telega): New variable.
>> ---
>> gnu/packages/emacs-xyz.scm | 58 ++++++++++++++++++++++++++++++++++++++
>> 1 file changed, 58 insertions(+)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
>> index 0caf12a423..7ff53ecf1e 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -114,6 +114,7 @@
>> #:use-module (gnu packages image)
>> #:use-module (gnu packages linux)
>> #:use-module (gnu packages libevent)
>> + #:use-module (gnu packages messaging)
>> #:use-module (gnu packages music)
>
> We have a problem (not your fault!): applying this hunk on top of
> current master breaks it all, due to circular top-level references in
> the modules.
>
> I haven’t been able to spend much time investigating, but we first need
> to find out where that comes from.
>
> Ludo’.

Ludo,

That is perfectly okay. I have some revisions I will be sharing to this
patch soon anyways.

Regarding the circular top-level references. That is interesting. I was
not familiar with this issue. Is there an open bug report for this? I'd
be willing to investigate it a bit.

It is particularly interesting, because emacs-xyz is not used in the
messaging module, so the circular reference logic is indeed obscured
somewhere.

Best!

--
Brett M. Gilio
Ludovic Courtès wrote 5 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 38326-done@debbugs.gnu.org)
87v9qzj7dv.fsf@gnu.org
Hi Brett,

I fixed the circularity issue in commit
abad22dd4a3083498263cc5d6817dd7c01df4da1, and finally pushed
‘emacs-telega’.

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38326@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38326
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help